PDA

Visualizza la versione completa : Interfaccia grafica avviata non automaticamente


zed79
09-05-2004, 22:31
Vorrei sapere come posso fare per evitare che l'interfaccia grafica sia avviata automaticamente, esite un modo???

Una volta che sono dentro come faccio aspegnere il pc? Ho visto che eseguire il log-out non sufficiente.

Grazie a tutti

Enrico81
09-05-2004, 22:36
Originariamente inviato da zed79
Vorrei sapere come posso fare per evitare che l'interfaccia grafica sia avviata automaticamente, esite un modo???

Una volta che sono dentro come faccio aspegnere il pc? Ho visto che eseguire il log-out non sufficiente.

Grazie a tutti

Devi editare il file /etc/inittab e alla voce

# The default runlevel.
id:5:initdefault:

metti 3 al posto di 5 (o 4 secondo la distro).

zed79
10-05-2004, 18:39
Uso la Debian, adesso c' 2, e comunque non mi fa salvare, dice che il file di sola lettura...

Samos87
10-05-2004, 18:42
Originariamente inviato da zed79
Uso la Debian, adesso c' 2, e comunque non mi fa salvare, dice che il file di sola lettura...

Da root.

:ciauz:

zed79
10-05-2004, 19:05
Il mio problema che vorrei che x server non partisse automaticamente.

Enrico81 mi dice di mettere 3 o 4 al posto di 5, ma io ho 2..., ed ho provato a mettere 3, e x server si avvia lo stesso...

Che cosa metto??? Sto usando debian

alex4988
10-05-2004, 19:58
Originariamente inviato da zed79
Il mio problema che vorrei che x server non partisse automaticamente.

Enrico81 mi dice di mettere 3 o 4 al posto di 5, ma io ho 2..., ed ho provato a mettere 3, e x server si avvia lo stesso...

Che cosa metto??? Sto usando debian
da shell di user digita
su
password
mcedit /etc/inittab
modifichi il numero cmq c' un'elenco che spiega pigi f10 clicca yes e sei apposto


# These are the default runlevels in Slackware:
# 0 = halt
# 1 = single user mode
# 2 = unused (but configured the same as runlevel 3)
# 3 = multiuser mode (default Slackware runlevel)
# 4 = X11 with KDM/GDM/XDM (session managers)
# 5 = unused (but configured the same as runlevel 3)
# 6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

Enrico81
10-05-2004, 20:06
Originariamente inviato da zed79
Il mio problema che vorrei che x server non partisse automaticamente.

Enrico81 mi dice di mettere 3 o 4 al posto di 5, ma io ho 2..., ed ho provato a mettere 3, e x server si avvia lo stesso...

Che cosa metto??? Sto usando debian

Scusa colpa mia, dovevo chiederti la distro.
Debian ha una particolarit, quando installi xfree ti crea il file etc/X11/default-display-manager, devi editarlo e commentare (inserisci #) l'unica riga che dovresti trovare:

# /usr/bin/xdm (kdm o gdm dipende da cosa hai installato)

quindi lascia pure il 2 e commenta il file che ti ho detto e vedrai che si risolve il problema.

zed79
10-05-2004, 20:41
Ero finalmente riuscito a risolvere il mio problema, ma mi sa che adesso ce n uno peggio:
Prima ho cambiato quel valore di cui si parlava da 2 a 3, e adesso non si avvia pi il sistema l'ultima cosa che dice questa:

Starting syistem log deamon: syslogdchmod: chenging permission of 'dev/xconsole': read only file system.

Ovviamente non riuscendo ad avviare il sistema non riesco ad editare il file.

Penso che con un disco d'avvio avrei potuto risolver il probelema giusto? E comunque non ce l'ho... Che posso fare???

Grazie ancora

zed79
10-05-2004, 20:45
Adesso dopo una lunga attesa si avviato, ma lentissimo e non riesco pi a lanciare l'editor di testo vi...

zed79
10-05-2004, 20:52
Ho riavviato ripartito normalmente, problema risolto, non so cosa sia successo, ma non voglio chiedermelo... :confused: :confused:

Loading