PDA

Visualizza la versione completa : packages.mask su gentoo


almafer
10-05-2004, 14:23
allora, il fatto questo, io ho gimp 2.0.0 installato da masked, se adesso faccio un
emerge -uUp world
me lo vuole riportare alla versione 1.2.5, e gi questo non mi torna, allora ho inserito in
/usr/portage/profiles/packages.mask
questo:
<=media-gfx/gimp-1.2.5

corretto cos? :fagiano:

GhePeU
10-05-2004, 14:27
quel file viene sovrascritto ad ogni emerge sync

devi usare /etc/portage/packages.mask (mi raccomando, leggibile anche per gli utenti, ad esempio io l'ho creato 644 root:portage)

se non c' la dir, creala

Phemt
10-05-2004, 14:28
un'altra cosa che puoi fare mettere stabile gimp2 nella portage overlay...

GhePeU
10-05-2004, 14:30
Originariamente inviato da Phemt
un'altra cosa che puoi fare mettere stabile gimp2 nella portage overlay...

anche qui, invece di usare il portage overlay e duplicare il pacchetto conviene usare /etc/portage/packages.unmask (se hard-masked) o /et/portage/packages.keywords (se ~)

esempio:

media-gfx/gimp ~x86



o ho capito male cosa intendevi? :fagiano:

almafer
10-05-2004, 14:36
quindi se /etc/portage non esiste lo devo creare?
io avevo capito infati di usare /etc/portage leggendo il man di portage, ma non avendolo trovato ho cercato strade alternative :D

Phemt
10-05-2004, 15:45
Originariamente inviato da almafer
quindi se /etc/portage non esiste lo devo creare?
io avevo capito infati di usare /etc/portage leggendo il man di portage, ma non avendolo trovato ho cercato strade alternative :D
eheh idem :p

almafer
10-05-2004, 18:51
comunque package.mask non packages.mask :stordita:

Loading