PDA

Visualizza la versione completa : [debian] Installare qmail con apt-get


daviweb
11-05-2004, 17:07
Ciao!

Sto provando ad installare qmail utilizzando apt-get...



#apt-get install qmail-src
#build-qmail
...
Do you want to install qmail_1.03-24_i386.deb now? [Yn] Y
Selecting previously deselected package qmail.
dpkg: regarding qmail_1.03-24_i386.deb containing qmail:
qmail conflicts with mail-transport-agent
exim provides mail-transport-agent and is installed.
dpkg: error processing qmail_1.03-24_i386.deb (--install):
conflicting packages - not installing qmail
Errors were encountered while processing:
qmail_1.03-24_i386.deb

Do you want to purge qmail-src now? [yN] y
(Reading database ... 41538 files and directories currently installed.)
Removing qmail-src ...

Remember that you can install qmail_1.03-24_i386.deb
on other computers so you don't need to compile it again.

Don't forget to setup a /etc/qmail/rcpthosts file to prevent open relaying!

Good luck!


Seguendo le indicazioni che ho trovato ho fatto:



#dpkg -r exim
#dpkg -i /tmp/qmail/qmail_1.03-24_i386.deb


Ed ora...



dpkg -i /tmp/qmail/qmail_1.03-24_i386.deb
(Reading database ... 41760 files and directories currently installed.)
Preparing to replace qmail 1.03-24 (using .../qmail/qmail_1.03-24_i386.deb) ...
Performing upgrade
You are upgrading from version 1.03
Checking control files ...
Control files installed in /etc/qmail
Checking alias files location ...
Unpacking replacement qmail ...
dpkg: dependency problems prevent configuration of qmail:
qmail depends on ucspi-tcp; however:
Package ucspi-tcp is not installed.
dpkg: error processing qmail (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
qmail




Come posso fare per proseguire nell'installazione?

Grazie

Kylnas
11-05-2004, 17:10
Originariamente inviato da daviweb
Ciao!

Come posso fare per proseguire nell'installazione?

Grazie

Prova con apt-get install ucspi-tcp

daviweb
11-05-2004, 17:20
Grazie Kylnas!

#apt-get install ucspi-tcp

diceva che c'era qualche problema e di usare quindi: apt-get -f install

#apt-get -f install

Ha sistemato exim. Ma ora:

#dpkg -i /tmp/qmail/qmail_1.03-24_i386.deb
Selecting previously deselected package qmail.
dpkg: regarding .../qmail/qmail_1.03-24_i386.deb containing qmail:
qmail conflicts with mail-transport-agent
exim provides mail-transport-agent and is installed.
dpkg: error processing /tmp/qmail/qmail_1.03-24_i386.deb (--install):
conflicting packages - not installing qmail
Errors were encountered while processing:
/tmp/qmail/qmail_1.03-24_i386.deb


Che fare?

Kylnas
11-05-2004, 17:27
Originariamente inviato da daviweb
Grazie Kylnas!

#apt-get install ucspi-tcp

diceva che c'era qualche problema e di usare quindi: apt-get -f install

#apt-get -f install

Ha sistemato exim. Ma ora:

#dpkg -i /tmp/qmail/qmail_1.03-24_i386.deb
Selecting previously deselected package qmail.
dpkg: regarding .../qmail/qmail_1.03-24_i386.deb containing qmail:
qmail conflicts with mail-transport-agent
exim provides mail-transport-agent and is installed.
dpkg: error processing /tmp/qmail/qmail_1.03-24_i386.deb (--install):
conflicting packages - not installing qmail
Errors were encountered while processing:
/tmp/qmail/qmail_1.03-24_i386.deb


Che fare?

Non usare dpkg, usa apt ancora.

daviweb
11-05-2004, 17:32
Ho rifatto apt-get install qmail-src, ma alla fine mi da ancora questo:

...
dpkg: regarding qmail_1.03-24_i386.deb containing qmail:
qmail conflicts with mail-transport-agent
exim provides mail-transport-agent and is installed.
dpkg: error processing qmail_1.03-24_i386.deb (--install):
conflicting packages - not installing qmail
Errors were encountered while processing:
qmail_1.03-24_i386.deb

:bh:

Kylnas
11-05-2004, 17:35
Originariamente inviato da daviweb
Ho rifatto apt-get install qmail-src, ma alla fine mi da ancora questo:

...
dpkg: regarding qmail_1.03-24_i386.deb containing qmail:
qmail conflicts with mail-transport-agent
exim provides mail-transport-agent and is installed.
dpkg: error processing qmail_1.03-24_i386.deb (--install):
conflicting packages - not installing qmail
Errors were encountered while processing:
qmail_1.03-24_i386.deb

:bh:

Forse devi disinstallare mail-transport-agent. Ma non sono sicuro, non sono molto esperto.

daviweb
11-05-2004, 18:09
#apt-get --purge remove exim
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
samba-common smbclient smbfs
The following packages will be REMOVED:
apache* at* exim* logrotate* mailx* mutt* samba* swat*
3 packages upgraded, 0 newly installed, 8 to remove and 91 not upgraded.
Need to get 2741kB of archives. After unpacking 13.0MB will be freed.
Do you want to continue? [Y/n]


Rimuove solo alcuni componenti di apache, at, logrotate... vero??

PunkIvi
11-05-2004, 18:13
Prova senza --purge.

daviweb
11-05-2004, 18:17
Stessa cosa:

apt-get remove exim
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
samba-common smbclient smbfs
The following packages will be REMOVED:
apache at exim logrotate mailx mutt samba swat
3 packages upgraded, 0 newly installed, 8 to remove and 91 not upgraded.
Need to get 2741kB of archives. After unpacking 13.0MB will be freed.
Do you want to continue? [Y/n] n
Abort.

PunkIvi
11-05-2004, 18:25
E se invece togli mail-transport-agent (che on ho ben capito che sia)?

Loading