PDA

Visualizza la versione completa : Postfix che non va...


Burns
11-05-2004, 20:00
Stavo provando postfix, ma non va: non riesco ad inviare le email con mutt...
ci sto sbattendo la testa da un paio di giorni ma non va :dh:

Ho configurato tutto (credo) correttamente, compreso il file /etc/postfix/main.cf
Semplicemente scrivo un messaggio con mutt, poi lo invio e mutt si blocca, dicendo soltanto
"Spedisco il messaggio...".
Dando postfix start o reload o check non c' nessun errore :)

Cosa potrebbe essere?
Devo settare qualcosa dentro il file ~/.muttrc (credo di no comunque)?
Chiedo aiuto, visto che non ne sto venendo a capo :dh:

Ovviamente c' avviato solo postfix, niente sendmail o altro

:ciauz:

arsy
11-05-2004, 20:14
io uso mutt con exim, se vuoi ti posso dare una mano

Burns
11-05-2004, 20:19
Originariamente inviato da arsy
io uso mutt con exim, se vuoi ti posso dare una mano

Grazie dell'interessamento! Per adesso vorrei capire perch diamine non va postfix, mi sta tirando scemo :dh:

arsy
11-05-2004, 20:23
per quanto ne sappia, mutt gira con exim, altrimenti devi fare dei cambi nel Muttrc..
prendila con la pinza sta cosa, ma comunque in considerazione.
se vuoi con exim in 5 minuti mandi mail, io sono qua


:ciauz:

Burns
12-05-2004, 14:05
Originariamente inviato da ciromosketta
io uso mutt tranquillamente con postfix, per la configurazione trovi una buona guida qui (http://www.mrshark.it/qechowto/index.html)

Ho gi letto quella e anche un'altra, eppure non mi va...

morfeus
12-05-2004, 14:56
postaci il maillog

Burns
12-05-2004, 15:21
Originariamente inviato da Morfeus
postaci il maillog

Grazie, leggendo i log ho risolto questo piccolo problema... adesso le invia!
Non ci avevo neanche pensato :stordita:


Ma ora il problema vero, che non riesco a risolvere in nessun modo :dh:

In pratica nelle mie email, l'header sbagliato. O meglio, questi sono i miei dati
utente che invia: cava (ma lo fa anche con root)
hostname: hogwarts
dominio: land (o hogwarts.land, come vuoi te :) )

Adesso ti posto l'header di una mail che mi sono mandato a un mio account su yahoo, per provare ( una delle tre milioni di mail che mi sono mandato, visto che sto continuando a provare ma senza successo :D )
Come puoi vedere, di errato c' il campo Return-Path, e anche altri... ma come
diavolo faccio a mettere quello che voglio??



X-Apparently-To: matteox84@yahoo.it via 217.12.12.115; Wed, 12 May 2004 05:20:47 -0700
Return-Path: <cava@hogwarts.land>
Received: from 212.216.176.141 (EHLO vsmtp1.tin.it) (212.216.176.141) by mta102.mail.sc5.yahoo.com with SMTP; Wed, 12 May 2004 05:20:46 -0700
Received: from hogwarts.land (80.116.122.91) by vsmtp1.tin.it (7.0.027) id 4087242E0041F93C for matteox84@yahoo.it; Wed, 12 May 2004 14:20:45 +0200
Received: by hogwarts.land (Postfix, from userid 0) id 8B8DF15DDCF; Wed, 12 May 2004 14:20:46 +0200 (CEST)
Data: Wed, 12 May 2004 14:20:46 +0200
Da: "Matteo" <matteox84@yahoo.it> Aggiungi alla Rubrica
A: matteox84@yahoo.it
Oggetto: prova
Message-ID: <20040512122046.GA2088@hogwarts>
Rispondi: matteox84@yahoo.it
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.4.2.1i
Content-Length: 34


Aiuto che sono disperato :dh: :dh:

Burns
12-05-2004, 15:48
Tra l'altro in
/var/log/maillog
c' una riga che potrebbe essere quella "incriminata"

May 12 14:42:48 hogwarts postfix/qmgr[2063]: D822F15DDD8: from=<cava@hogwarts.land>, size=475, nrcpt=1 (queue active)

e qmgr un file (non di conf) presente in
/usr/libexec/postfix
ma il problema che non so che farmene :fagiano:

morfeus
12-05-2004, 16:08
Originariamente inviato da Burns
Tra l'altro in
/var/log/maillog
c' una riga che potrebbe essere quella "incriminata"

May 12 14:42:48 hogwarts postfix/qmgr[2063]: D822F15DDD8: from=<cava@hogwarts.land>, size=475, nrcpt=1 (queue active)

e qmgr un file (non di conf) presente in
/usr/libexec/postfix
ma il problema che non so che farmene :fagiano:


qmgr lascialo l dov': il binario che gestisce le code delle mail. Devi usare postqueue (come utente) o postsuper come root, ma non so che opzioni gli devi passare (casomai man postqueue). Ovviamente hai settato gli account in /etc/postfix/aliases vero? :fagiano:

Burns
12-05-2004, 16:21
Originariamente inviato da Morfeus
qmgr lascialo l dov': il binario che gestisce le code delle mail. Devi usare postqueue (come utente) o postsuper come root, ma non so che opzioni gli devi passare (casomai man postqueue). Ovviamente hai settato gli account in /etc/postfix/aliases vero? :fagiano:

aliases settato ;)
Per il resto... credevo che fosse un po' pi semplice postfix! Ma non basta settare qualche variabile nel main.cf?

Loading