PDA

Visualizza la versione completa : WebServer e client dietro stesso router


zed79
12-05-2004, 21:02
Ciao,

Ho un router, al quale č connesso un websever.

Ho impostato un Virtual server che gira le richieste alla porta 80 del mio ip pubblico sulla porta 80 dell'ip interno del server.

Se io apro explorer e digito il mio indirizzo ip, perņ la richiesta non viene girata, ma si apre la pagina di configurazione del router.

Dall'esterno funziona correttamente. Non c'č modo di risolvere questo problema in modo che io possa fare dei test dall'interno della mia lan???

Grazie a tutti

tia86
12-05-2004, 21:42
Originariamente inviato da zed79
Ciao,

Ho un router, al quale č connesso un websever.

Ho impostato un Virtual server che gira le richieste alla porta 80 del mio ip pubblico sulla porta 80 dell'ip interno del server.

Se io apro explorer e digito il mio indirizzo ip, perņ la richiesta non viene girata, ma si apre la pagina di configurazione del router.

Dall'esterno funziona correttamente. Non c'č modo di risolvere questo problema in modo che io possa fare dei test dall'interno della mia lan???

Grazie a tutti

dall'interno devi digitare l'indirizzo IP (interno) del webserver, mica l'ip pubblico del router

s|n3
13-05-2004, 00:19
Originariamente inviato da tia86
dall'interno devi digitare l'indirizzo IP (interno) del webserver, mica l'ip pubblico del router
penso che cercasse proprio un modo per fare dei test utilizzando l'ip pubblico,magari per controllare la configurazione del nat.

cmq no...chiamasi regola divina...se esci dal router non rientri dal nat

ARCTiC
13-05-2004, 01:23
Esci con un open proxy (su porta 80) e rientra comodamente sul tuo router dall'esterno... ed ecco servito il test.

zed79
13-05-2004, 20:13
Io ho installato un proxy server (browsgate), ho attivato il proxy sulla porta 80, devo attivarlo anche in upstream?

In explorer ho messo utilizza server proxy, con l'ip della macchina dove ho installato il proxy sulla porta 80

Vedo che funziona perchč il log si popola, perņ digitando il mio ip pubblico in explorer non raggiungo il webserver all'interno della rete, ma sempre la pagina di configurazione del router...

Mi scappa qualcosa??
Grazie ancora

ARCTiC
13-05-2004, 20:56
Si! Raggiungi il server sempre col tuo IP perche' il proxy l'hai installato sulla tua macchina.. in pratica fai un loop per niente.
Devi utilizzare un proxy ESTERNO, per questo ho parlato di "open proxy" ovvero quei proxy pubblici e senza password disponibili in gran quantita' in rete.
Prima di tutto disinstalla il proxy che hai installato (una mal configurazione potrbbe compromettere la sicurezza del tuo server: se io dall'esterno accedo al tuo proxy e vado di nuovo sul tuo IP arrivo sul router!), quindi semplicemente in explorer utilizza questo proxy, l'ho appena provato (porta 80):

61.50.172.128

...se dovesse essere "scaduto" (muoiono presto), fai una ricerca su google e trovane altri funzionanti.

Loading