PDA

Visualizza la versione completa : servlet -jsp-mysql


Marika257
13-05-2004, 22:43
Ciao sono ancora io.. forse non ho spiegato bene qual' il mio problema,
devo usare servlet, jsp (tomcat) e mysql, ho installato mysql e anche tomcat
come dicevo dovrei usare netbeans che fa tutto lui ma ho poca ram e non gira!
Ho modificato le variabili d'ambiente con:
catalina_home: c:\Programmi\Apache Group\Tomcat 4.1
classpath: c:\Programmi\Apache Group\Tomcat 4.1...
java_home c:\j2sdk1.4.1
path c:\j2sdk1.4.1\bin
quando metto la cartella con la mia applicazione gi compilata e funzionante
(da altri che usano netbeans) per creare tutta l'applicazione mi da
questo errore:

HTTP Status 404 - /servlet/servlet

--------------------------------------------------------------------------------

type Status report

message /servlet/servlet

description The requested resource (/servlet/servlet) is not available.


--------------------------------------------------------------------------------

Apache Tomcat/4.1.29

non capisco comer faccio per riuscire a fare il tutto senza
usare netbeans??? come compilo la mie servlet senza netbeans da
il prompt???
ciao grazie
MArika

Corwin
13-05-2004, 22:48
Se la servlet gi compilata va dichiarata nel file web.xml che si trova nella sottocartella WEB-INF del sito...
:fagiano:

Marika257
14-05-2004, 10:48
c' dichiarata nel file web.xml che il seguente:
<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>
<servlet>
<servlet-name>servlet</servlet-name>
<servlet-class>servlet</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>servlet</servlet-name>
<url-pattern>/servlet/servlet</url-pattern>
</servlet-mapping>
<session-config>
<session-timeout>
30
</session-timeout>
</session-config>
<welcome-file-list>
<welcome-file>
index.jsp
</welcome-file>
<welcome-file>
index.html
</welcome-file>
<welcome-file>
index.htm
</welcome-file>
</welcome-file-list>
<taglib>
<taglib-uri>/tags</taglib-uri>
<taglib-location>/WEB-INF/tlds/tags.tld</taglib-location>
</taglib>
</web-app>


non penso sia questo il problema.. scusami cmq il disturbo..
Marika

Loading