PDA

Visualizza la versione completa : Problema locales+localeconf con Debian


canox82
15-05-2004, 18:44
Aggiornando il sistema con apt-get dist-upgrade mi è saltato fuori questo errore



perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "it",
LC_ALL = (unset),
LANG = "it_IT@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up locales (2.3.2.ds1-12) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "it",
LC_ALL = (unset),
LANG = "it_IT@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
be_BY.CP1251... done
bg_BG.CP1251... done
br_FR.ISO-8859-1... done
ca_ES.ISO-8859-15@euro... done
cs_CZ.ISO-8859-2... done
da_DK.ISO-8859-1... done
de_AT.ISO-8859-15@euro... done
de_AT.ISO-8859-1... done
de_BE.ISO-8859-15@euro... done
de_BE.ISO-8859-1... done
de_CH.ISO-8859-1... done
de_CH.UTF-8...memory exhausted
dpkg: error processing locales (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of localeconf:
localeconf depends on locales; however:
Package locales is not configured yet.
dpkg: error processing localeconf (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
locales
localeconf
E: Sub-process /usr/bin/dpkg returned an error code (1)

qualche idea su come risolverlo? Grazie. :ciauz:

Enrico81
15-05-2004, 19:19
Originariamente inviato da canox82
Aggiornando il sistema con apt-get dist-upgrade mi è saltato fuori questo errore



qualche idea su come risolverlo? Grazie. :ciauz:

#dpkg-reconfigure locales

canox82
15-05-2004, 23:05
Originariamente inviato da Enrico81
#dpkg-reconfigure locales
mi restituisce questo errore
/usr/sbin/dpkg-reconfigure: locales is broken or not fully installed

ho provato anche a rimuovere locales e a reinstallarlo ma mi dà sempre l'errore del primo post :dhò:

Mutato
15-05-2004, 23:29
Sulla testing c'e' un problema da circa una settimana su quel pacchetto. Ho rinunciato a metterlo a posto e l'ho messo in HOLD.

canox82
16-05-2004, 13:33
Originariamente inviato da Mutato
Sulla testing c'e' un problema da circa una settimana su quel pacchetto. Ho rinunciato a metterlo a posto e l'ho messo in HOLD.
aspetterò la prossima release, grazie.

mschievano
16-05-2004, 13:53
3.4

Mettendo il pacchetto in hold, posso finalmente riuscire a collegarmi in internet? (nella configurazione pppoe mi mette dei GDK-WARNING nel file di configurazione e non funziona più un tubo)

to put a package in hold:


echo packagename hold | dpkg --set-selections


(from
http://www.knoppix.net/forum/viewtopic.php?t=2638&highlight=hold)

Mutato
16-05-2004, 14:11
Hai problemi su Locales? o su un altro pacchetto?

Se ti da' un errore su GTK puoi provare ad aggiorna il pacchetto che da' errore, oppure editare il file di configurazione a mano via shell.

Ma non so se ho capito bene.

mschievano
16-05-2004, 15:27
dai un occhio qui, senza che riscrivo tutto:

http://www.knoppix.net/forum/viewtopic.php?t=10558

il problema è che mi tocca usare il livecd per colegarmi ad internet e non riesco più a risolvere...
:dhò:

Mutato
16-05-2004, 15:43
Perche' non provi ad installare una versione precedente??

Inoltre, puoi configurare l'ADSL anche senza passare per il front end di KDE... in questo modo dovresti risolvere alla radice e aspettare una nuova release di Locales.

mschievano
16-05-2004, 15:46
versione precedente di locales e come configuro pppoeconf senza passare per la grafica :confused:

Loading