PDA

Visualizza la versione completa : Blender


gandalf45
16-05-2004, 16:08
#include "nemby_disclaimer.h"
premetto che sono un neofita di linux e che quindi potrei aver dimenticato di fare operazione che per un esperto sono basilari
...

Ho scaricato l'archivio contenente i file di blender poi ho lanciato il comando ./blender (come indica il manuale),
ma il programma non parte e mi segnale che:

[mithrandir@localhost blender-2.33a-linux-glibc2.2.5-i386]$ ./blender
./blender: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

Che vuol dire?
Io sto usando Mandrake 10, forse la versione non compatibile?

EkoZZ
16-05-2004, 16:13
Penso che tu debba scaricare una versione compatibile con le GNUlibc che ha tu sul sistema... Oppure aggiornare le librerie alla versione richiesta dal programma

gandalf45
16-05-2004, 16:21
Originariamente inviato da EkoZZ
Penso che tu debba scaricare una versione compatibile con le GNUlibc che ha tu sul sistema... Oppure aggiornare le librerie alla versione richiesta dal programma

forse centra qualcosa che usa la Mandrake 10?
non credo servano librerie + aggiornate, forse al contrario servono librerie + vecchie...
ma pu essere che io mi stia sbagliando del tutto :D

Mike Vargas
16-05-2004, 17:11
Originariamente inviato da gandalf45
#include "nemby_disclaimer.h"
premetto che sono un neofita di linux e che quindi potrei aver dimenticato di fare operazione che per un esperto sono basilari
...

Ho scaricato l'archivio contenente i file di blender poi ho lanciato il comando ./blender (come indica il manuale),
ma il programma non parte e mi segnale che:

[mithrandir@localhost blender-2.33a-linux-glibc2.2.5-i386]$ ./blender
./blender: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

Che vuol dire?
Io sto usando Mandrake 10, forse la versione non compatibile?

Prova a installare questo pacchetto (o pi recente):
libstdc++2.10-2.96-0.83mdk

Ciao, Mike

gandalf45
16-05-2004, 17:19
dove lo posso trovare?

Mike Vargas
16-05-2004, 17:42
In questi casi www.rpmfind.net il tuo miglior amico. Basta cercare libstdc++2.10.
Ecco un link (ftp://fr2.rpmfind.net/linux/Mandrake/9.2/i586/Mandrake/RPMS/libstdc++2.10-2.96-0.83mdk.i586.rpm).
Ciao, Mike :)

gandalf45
16-05-2004, 19:47
grazie mille!

gandalf45
16-05-2004, 19:56
finalmente il programma parte!

purtroppo va piuttosto a scatti e non penso dipenda dall hardware (2400Xp, 768 ddr, GeForce 5600 128mb) ma dalla mancanza di driver appropriati per la scheda video...
ho provato ad installare i driver Nvidia ma mi dice che il mio Kernel non supportato... qualcuno mi sa dare qualche dritta?

chaosd
16-05-2004, 20:05
guarda, lo sbaglio di usare una GEforce sotto Linux l'ho fatto anch'io... una tragedia! ho scaricato i pacchetti del Kernel Nvidia e il pacchetto GLX, cos da poter attivare l'hardware 3D.

MI SI E' PIANTATO TUTTO!! :dh: :dh:

e dato che modestamente non so assolutamente come cavarmela in situazioni del genere, format!

per ho semi-risolto la cosa usando l'aggiornamento automatico online di YAST2 (ho la Suse 9.0) e nonostante mi dica che il 3d non si possa attivare, in effetti funziona lo stesso e benone :confused:

:bh: :bh:

chaosd
16-05-2004, 20:05
guarda, lo sbaglio di usare una GEforce sotto Linux l'ho fatto anch'io... una tragedia! ho scaricato i pacchetti del Kernel Nvidia e il pacchetto GLX, cos da poter attivare l'hardware 3D.

MI SI E' PIANTATO TUTTO!! :dh: :dh:

e dato che modestamente non so assolutamente come cavarmela in situazioni del genere, format!

per ho semi-risolto la cosa usando l'aggiornamento automatico online di YAST2 (ho la Suse 9.0) e nonostante mi dica che il 3d non si possa attivare, in effetti funziona lo stesso e benone :confused:

:bh: :bh:

Loading