PDA

Visualizza la versione completa : pacchetti


kodode
25-05-2004, 16:32
ciao a tutti!

io dovrei installare i pacchetti:

glibc-kernheaders
glibc-devel
binutils
cpp
patch
httpd
gdbm
gdbm-devel
openssl
openssl-devel
stunnel

come faccio a trovarli nel cd1 di redhat?? portate pazienza ma sono un principiante :D

grazie...

kodode
25-05-2004, 16:52
forse li ho trovati.. mah... però ora mi dice che non trova il paccheto "make" che serve per installare gli altri pacchetti :dhò: :dhò: quindi??

Outermarker
25-05-2004, 16:59
ma scusa, questi pacchetti hanno estensione .rpm vero?

kodode
25-05-2004, 17:21
ti spiego meglio.. prima ho tentato inutilmente di installare postfix e niente nemmeno seguendo diverse guide. Ora sto provando a installare qmail :
http://www.baslug.org/vega/index.php?p=qmail
e mi dice che devo installare questi pacchetti ma ancora con scarsi risultati... quindi non ho idea se hanno estensione .rpm
ecco l'elenco...
http://www.baslug.org/vega/index.php?p=qmail2

Outermarker
25-05-2004, 17:50
allora... ho dato un'occhiata ai pacchetti e credo che siano tutti (o quasi) presenti nei cd di installazione di Redhat. Se non mi ricordo male esiste un tool grafico che ti permette di installare selettivamente i pacchetti contenuti nei cd, ma siccome non ho una redhat sottomano, facciamo in un altro modo:

inserisci il cd1 e aprilo con un file manager (o con il terminale, se sei pratico).
Dentro dovresti trovare due directory: una si chiama 'boot' e l'altra dovrebbe chiamarsi 'redhat' o 'rpms'.
Entra in 'rpms' e lì trovi una miriade di files con estensione 'rpm'. Questi files sono i nostri famosi "pacchetti", che sono, grosso modo, gli equivalenti degli installer di windows.
Sicuramente troverai i pacchetti specificati nella guida che stai seguendo. Li selezioni e li copi in una directory qualsiasi (ti consiglio di crearne una apposita per l'installazione dei pacchetti).

Una volta che ti sei copiato questi file in locale vai nella directory dove li hai messi, li selezioni tutti, poi clicchi col destro e successivamente clicchi su "Install Packages" (credo che si chiami così ma non ricordo bene); a questo punto viene lanciata l'utility grafica di redhat per l'installazione dei pacchetti, la quale ti dovrebbe installare senza problemi tutto.

In alternativa, se sei già avvezzo al terminale, una volta copiati i pacchetti in locale, digita il comando


rpm -ivh nome-pacchetto.rpm

oppure, per installarli tutti assieme


rpm -ivh *.rpm

buon divertimento...

kodode
25-05-2004, 17:57
ok, grazie mille per l'aiuto ho trovato e ora provo... un'ultima cosa :D , ho trovato anche il pacchetto make-versione.rpm; che dici installo anche quello visto l'errore che ti dicevo prima??

Outermarker
25-05-2004, 18:09
Installalo.... non ti serve per installare gli rpm, ma ti servirà quando ti troverai a doverti compilare un programma partendo dai sorgenti (succederà presto, vedrai)... oltre a make ti consiglio di installare anche tutta la suite del compilatore GCC.

In ogni caso make è una utility che aiuta il compilatore a generare un binario secondo determinati parametri, che gli vengono passati da un file chiamato Makefile. GLi rpm invece, contengono già il programma in formato binario, nella maggior parte dei casi.

Ti consiglio una buona lettura degli "Appunti di informatica libera" per approfondire tutti questi argomenti. Li trovi con una ricerchina su San Google oppure cercando tra i link utili di questo forum.


Buon divertimento. :metallica

kodode
25-05-2004, 19:23
altro errore... non conosce il comando sv ?? esiste??
penso sia sv perchè quando provo a far partire qmail mi dà sempre errore non riconoscendo i comandi:

svstat
svok
svc

etc..

qualche idea??

Outermarker
25-05-2004, 19:32
non ho mai sentito parlare di quei comandi. non uso qmail comunque. non saprei aiutarti. ma dove li hai trovati quei comandi?

Loading