PDA

Visualizza la versione completa : Compiler seg foult: si può fare qualcosa?


giacomolg
27-05-2004, 23:00
Compilando waimea-0.5.0, ma anche Kahakai, ottengo da Make questo output di errore:
[...]
if g++ -DHAVE_CONFIG_H -I. -I. -I.. -DWAIMEA_PATH=\"/usr/local/share/waimea\" -I/usr/include/freetype2 -I/usr/X11R6/include -I%{x11includedir} -I/usr/include/libpng12 -I/usr/X11R6/include -DSHAPE -DXINERAMA -DRANDR -DPNG -I/usr/include/libpng12 -DXCURSOR -g -O2 -MT Screen.o -MD -MP -MF ".deps/Screen.Tpo" \
-c -o Screen.o `test -f 'Screen.cc' || echo './'`Screen.cc; \
then mv -f ".deps/Screen.Tpo" ".deps/Screen.Po"; \
else rm -f ".deps/Screen.Tpo"; exit 1; \
fi
/usr/include/c++/3.3.2/bits/stl_map.h: In member function `std::pair<typename std::_Rb_tree<_Key, std::pair<const _Key, _Tp>, std::_Select1st<std::pair<const _Key, _Tp> >, _Compare, _Alloc>::iterator, bool> std::map<_Key, _Tp, _Compare, _Alloc>::insert(const std::pair<const _Key, _Tp>&) [with _Key = Window, _Tp = WindowObject*, _Compare = std::less<Window>, _Alloc = std::allocator<std::pair<const Window, WindowObject*> >]':
Screen.cc:149: instantiated from here
/usr/include/c++/3.3.2/bits/stl_map.h:340: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:https://qa.mandrakesoft.com/> for instructions.
make[2]: *** [Screen.o] Error 1
make[2]: Leaving directory `/home/giacomo/download/waimea-0.5.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/giacomo/download/waimea-0.5.0'
make: *** [all] Error 2
[root@localhost waimea-0.5.0]#

Volevo chiedere se è un errore che deriva da qualche "difetto" del compilatore (sono andato su https://qa.mandrakesoft.com/ ma non ci ho capito 'na mazza!) o si può fare qualcosa.Ho la Mandrake 10 (Community) su un i586....

Ciiao e grazie!

P.S.
I rispettivi ./configure non mi davano alcun errore....
Thank you!!

andy caps
27-05-2004, 23:27
ftp://ftp.u-strasbg.fr/pub/linux/distributions/mandrakelinux/official/10.0/contrib/i586/waimea-0.4.0-4mdk.i586.rpm


scarica quello per mandrake

giacomolg
27-05-2004, 23:56
Uso proprio quella lì, è che voplevo risolvere questo problema ed installare la versione successiva.... :fagiano:

Loading