PDA

Visualizza la versione completa : modem ethernet


Darcken
02-06-2004, 03:23
salve a tutti, sono mesi che sto cercando di risolvere questo problema ma a quanto pare nessuno sa darmi una risposta concreta :cry:

il problema in questione è il seguente: Con un modem ethernet non posso fare da server mentre con un modem usb (stesso identico abbonamento, avendo i NAT dinamici posso usare entrambi i modem) posso farlo tranquillamente!!!! :dhò:

in poche parole se io ho l'ip 1.1.1.1, con un modem usb sono raggiungibilissimo mentre con un modem ethernet no, e dire che il firewall non lo sfioro neanche, attivo solo le seguenti righe:

ifconfig eth0 192.168.0.1 up netmask 255.255.255.0
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

la seconda solo per la condivisione di internet tramite la lan.

ora mi chiedo, possibile che con un modem ethernet (ericsson 220dp) NON sia possibile farsi raggiungere??? Insomma, non sono mica il server della nasa, che me frega delle misure di sicurezza che scattano insieme al pppoe????? :nonlodire

Chiedo gentilmente a chi ne capisce di più di illuminarmi sull'argomento, rosico molto nel sapere di non poter usare il mio modem ethernet e di dovermi arrangiare con l'usb che ogni ora perde la connessione per colpa degli eciadsl :jam:

:ciauz:

Sergio Pedone
02-06-2004, 04:03
# iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
mascheramento IP
# ifconfig eth0
è sufficiente tirare su la NIC senza darle un'indirizzo
# adsl-setup
segui le indicazioni a video
# adsl-start
per lanciare la connessione
# adsl-stop
termina la connessione

ciao.

Darcken
02-06-2004, 04:41
modem ethernet collegato, lancio adsl-start dopo aver seguito tutta la procedura di configurazione, ma mi viene scritto:
...............TIMED OUT
/usr/sbin/adsl-start: line 191: 1226 Terminated $CONNECT "$@" >/dev/null 2>&1

grazie infinite per la mano che mi stai dando :ciauz:

Sergio Pedone
02-06-2004, 11:47
Hai più di una scheda di rete sulla macchina connessa
ad internet?
Sei sicuro di aver collegato il modem alla scheda
riconoscita ed identificata come eth0?
Fino alla settimana scorsa ho utilizzato quel modem
fornitomi dalla telecom, senza alcun problema.

Piccola curiosità:
Kernel, distro utilizzata?

Ciao.

gigyz
02-06-2004, 13:53
:master: sbaglio o il problema è l'accessibilità dall'esterno non il collegamento quindi che c'azzecca poi l'errore con l'adsl start ? ma tu riesci a connetteri o no ? cmq il problema di essere visibili lato internet lo dovresti risolvere o con il NATP oppure con il bridging, non conosco il modem, sto parlando in generale, anch'io sto cercando di risolvere un problema simile con un IPM Datacom speedweb eth che se lo uso come router si blocca al primo ftp che apro. Cmq settando la route al momento accedo a un server da remoto con ssh, la route è necessaria perchè gli eth sono spesso router mentre gli usb sono modem e non fanno routing quindi il pc è totalmente raggiungibile dal web.

Darcken
02-06-2004, 14:44
Rieccomi. Io con il modem ethernet mi connetto (senza usare adsl-start) e internet funziona, solo non sono raggiungibile... ho usato bridge come dici tu ma la cosa diventa irrilevante perchè rimane tutto identico a prima :cry:

sembra di stare in una cassaforte con sto maledetto modem :nonlodire

p.s.: Distro usata è la Slackware 9.0

gigyz
02-06-2004, 16:40
esatto, perchè lo usi come router, come ti ho già detto o lo usi come modem oppure crei la route, a cosa devi accedere dall'esterno ? web server, mail server, ftp ,ssh ? basta impostare le regole giuste e sei a posto oppure devi trovare il modo do disabilitare il routing.

Darcken
03-06-2004, 02:10
sarò iellato io, ma in modalita' Bridged non parte, mentre con il router si :dhò:

ho seguito anche un howto trovato su google per la configurazione (più che banale) del modem in modalità Bridged. Se qualcuno riesce ad illuminarmi ne sarei veramente grato.

Grazie a tutti :ciauz:

Loading