PDA

Visualizza la versione completa : Errore upgrade Kde 3.2 su slackware 9.1


Trotto@81
04-06-2004, 16:48
Non riesco a capire perch dopo avere aggiornato kde dalla 3.1.4 alla 3.2.2 con i pacchetti ufficiali slackware, al momento di dare startkde ricevo il seguente errore:
xset: unable to open display ""
xset: unable to open display ""
xset: unable to open display ""
xsetroot: unable to open display ''
Usage: lnusertemp tmp|socket
startkde: Starting up...
ksplash: cannot connect to X server
kdeinit: Aborting. $DISPLAY is not set.
Warning: connect() failed: : No such file or directory
ksmserver: relocation error: /opt/kde/lib/libkdeinit_ksmserver.so: undefined symbol: _ZN10DCOPClient11iceauthPathEv
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done.
A qualcuno di voi lo ha fatto??
L'unica cosa che ho aggiontao xfree alla versione 4.4 per il resto tutto quanto come fornito dalla distro..
In rete non sono riuscito a trovare un argomento simile..

Grazie..

Ciao!

Sergio Pedone
04-06-2004, 17:56
Tramite swaret, xfree 4.4 e kde 3.2.2 nessun problema.

Trotto@81
04-06-2004, 18:58
Il problema che swaret non lo posso usare avendo un 56k, mi sono fatto scaricare i pacchetti da un mio amico che ha adsl..

DonFabio
04-06-2004, 19:01
Comunque un problema di xfree...ci vogliono le 4.4

Trotto@81
04-06-2004, 19:17
Originariamente inviato da DonFabio
Comunque un problema di xfree...ci vogliono le 4.4

Sono passato a xfree 4.4 prima di fare l'upgrade a kde 3.2.2 ma non funziona ugualmente...l'avevo scritto anche nel post..

DonFabio
04-06-2004, 19:24
Rimettile, dopo il kde.

Trotto@81
04-06-2004, 20:11
Ho provato ma non funziona...almeno se riuscirei a capire cosa vuole sarebbe un gran passo, non penso necessita di altri pacchetti...

Sergio Pedone
04-06-2004, 20:40
Questi i pacchetti installati sulla mia macchina.

*** KDE ***

sergio@slack91:~$ ls /var/log/packages/ | grep -i kde
kde-i18n-en_GB-3.2.2-noarch-1
kde-i18n-it-3.2.1-noarch-1
kde-i18n-uk-3.2.1-noarch-1
kdeaccessibility-3.2.2-i486-1
kdeaddons-3.2.2-i486-1
kdeadmin-3.2.2-i486-1
kdeartwork-3.2.2-i486-1
kdebase-3.2.2-i486-2
kdebindings-3.2.2-i486-1
kdeedu-3.2.2-i486-1
kdegames-3.2.2-i486-1
kdegraphics-3.2.2-i486-1
kdelibs-3.2.2-i486-2
kdelinks-1.2-noarch-1
kdemultimedia-3.2.2-i486-1
kdenetwork-3.2.2-i486-1
kdepim-3.2.2-i486-1
kdesdk-3.2.2-i486-1
kdetoys-3.2.2-i486-1
kdeutils-3.2.2-i486-1
kdevelop-3.0.3-i486-1

*** XFREE ***

sergio@slack91:~$ ls /var/log/packages/ | grep -i xfree
xfree86-4.4.0-i486-3
xfree86-devel-4.4.0-i486-3
xfree86-docs-4.4.0-noarch-2
xfree86-docs-html-4.4.0-noarch-1
xfree86-fonts-100dpi-4.4.0-noarch-1
xfree86-fonts-cyrillic-4.4.0-noarch-1
xfree86-fonts-misc-4.4.0-noarch-1
xfree86-fonts-scale-4.4.0-noarch-2
xfree86-xnest-4.4.0-i486-3
xfree86-xprt-4.4.0-i486-3
xfree86-xvfb-4.4.0-i486-3

Trotto@81
04-06-2004, 21:55
Gli stessi pacchetti installati da me..
La 3.2.0 andava senza problemi, ma dalla 3.2.1 non sono riuscito pi a farlo avviare.. :dh:

Sergio Pedone
04-06-2004, 22:31
invece di startkde prova questo:
$ cp /etc/X11/xinit/xinitrc.kde $HOME/.xinitrc
$ startx

Loading