PDA

Visualizza la versione completa : tasti che non funzionano regolarmente


protoneee
06-06-2004, 21:45
da ATERM in Xfce4 se premo il tasto < o anche > (non sono la freccia sx e dx) non succede niente. Se la stessa cosa la faccio sotto shell bash i tasti funzionano regolarmente.
Non mi ero mai accorto prima, ma non penso sia normale!
Cosa puo' essere il problema?
ciao

andy caps
07-06-2004, 00:58
io ho risolto modificando il file

/etc/X11/xkb/types/basic
fai un file di testo vuoto ed incollaci questo

------------------------------
// $Xorg: basic,v 1.3 2000/08/17 19:54:48 cpqbld Exp $
default xkb_types "basic" {

// Fairly standard definitions for
// the four required key types

virtual_modifiers NumLock;

type "ONE_LEVEL" {
modifiers = None;
map[None] = Level1;
level_name[Level1]= "Any";
};

type "TWO_LEVEL" {
modifiers = Shift;
map[Shift] = Level2;
level_name[Level1] = "Base";
level_name[Level2] = "Shift";
};

type "ALPHABETIC" {
modifiers = Shift+Lock;
map[Shift] = Level2;
preserve[Lock]= Lock;
level_name[Level1] = "Base";
level_name[Level2] = "Caps";
};

type "KEYPAD" {
modifiers = Shift+NumLock;
map[None] = Level1;
map[Shift] = Level2;
map[NumLock] = Level2;
map[Shift+NumLock] = Level1;
level_name[Level1] = "Base";
level_name[Level2] = "Number";
};
};

----------------------

poi dopo avere rinominato quello esistente per sicurezza lo chiami basic e lo metti in /etc/X11/xkb/types/

al riavvio dovrebbe essere tutto normale

protoneee
07-06-2004, 20:46
Ho provato a fare come mi hai detto ma non e' cambiato nulla.
Non so se puo' essere questo il problema, ho installato GNU/Linux su un portatile, precisamente un Gericom Masterpiece.

andy caps
07-06-2004, 20:50
:bh: non so dirti a me mettendo questo file al posto dell'altro a funzionato perfettamente


prova con dpkg-reconfigure xserver-xfree86 a cambiare numero di tasti da 102 a 104 o 108

protoneee
07-06-2004, 20:54
Ho notato che anche il tasto e in ATERM non funzionano e ora il tasto maggiore/minore non funziona pi ovunque!
Boh! non so che dire!

protoneee
07-06-2004, 21:08
Ho rimesso il file basic originale e ho modificato XF86Config-4, avevo PC104 e ho messo PC108.
Il tasto < / > funziona ovunque ma il tasto / continua a non funzionare in ATERM.
Evvai, un passo avanti!

Per chi fosse interessato il mio file /etc/X11/xkb/types/basic
e' questo:

--------
// $Xorg: basic,v 1.3 2000/08/17 19:54:48 cpqbld Exp $
default xkb_types "basic" {

// Fairly standard definitions for
// the four required key types

virtual_modifiers NumLock;

type "ONE_LEVEL" {
modifiers = None;
map[None] = Level1;
level_name[Level1]= "Any";
};

type "TWO_LEVEL" {
modifiers = Shift;
map[Shift] = Level2;
level_name[Level1] = "Base";
level_name[Level2] = "Shift";
};

type "ALPHABETIC" {
modifiers = Shift+Lock;
map[Shift] = Level2;
preserve[Lock]= Lock;
level_name[Level1] = "Base";
level_name[Level2] = "Caps";
};

type "KEYPAD" {
modifiers = Shift+NumLock;
map[None] = Level1;
map[Shift] = Level2;
map[NumLock] = Level2;
map[Shift+NumLock] = Level1;
level_name[Level1] = "Base";
level_name[Level2] = "Number";
};
};
--------

Loading