PDA

Visualizza la versione completa : libc.so.6 con Slack


chaosd
11-06-2004, 17:59
ho JoLinux 1.2, tipo Slack
vorrei installare Mplayer ma ha 10000000 dipendenze, tra cui una libreria che si chiama

libc.so.6

usando l'utility pkgtool o Kpakage, mi dice che installata la

libc.so

dove trovo l'altra? se possibile dove posso trovare soltanto il file che mi interessa, evitando di scaricare pacchetti immensi?

(ho un 56k :dh: :dh:)

:ciauz:

DonFabio
11-06-2004, 18:04
Se gi li hai potrebbe bastare un ln -s dopo aver visto dove punta ldd

chaosd
11-06-2004, 18:10
spik italian please...

adarkar
12-06-2004, 00:20
Originariamente inviato da DonFabio
Se gi li hai potrebbe bastare un ln -s dopo aver visto dove punta ldd

ciao chaosd, ti traduco in italiano visto che non sai il bashese :gren:
allora ldd elenca le dipendenze di un binario
ln -s crea un link simbolico
per non so dirti di pi, perch non ho capito come questo possa servire.. :eek:
so solo che la libc la standard library del c.. insomma quella con printf ecc. ecc. e mi sembra strano che non ti funzia..
ah forse comunque la tua libc.so un link a libc.so.6 controllalo!
ps. anche a me mi dava dei problemi la libc... :tongue: sar scemo eh? :D
nel senso che ho copiato un less, diceva che voleva le libc, glile ho date ma al momento di runnarlo diceva libc3 non trovato :eek:
intendeva che voleva la versione 3 invece della 6? dal messaggio che dava nn mi pareva.. e poi quel less gira con la libreria libc6 che gli ho copiato.. MAH!!
il giorno in cui capir qualcosa di librerie far una festona siete tutti invitati :gren:

chaosd
12-06-2004, 13:47
dunque, in effetti la mia libc un link (di 4 mega!!!) alla libc.so.6 che tra l'altro non esiste in tutto /
non so che fare, non conosci un link che mi faccia scaricare SOLO la libc.so.6??? ho gi scaricato e installato un pacchettone che non ha risolto niente (anche che mi sa che era per Fedora, ma io pensavo: le librerie sono uguali in ogni distro...)

cmq non capisco perch non ci sia gi: OGNI pacchetto di multimedia che voglio installare ha quella dipendenza...

e poi, dato che ci sono, ci sono altre lib che mi richiedono e non sono installate... solo che ora sono sotto zozz e non ricordo

ma porca p...! perch con la Suse mi andava tutto?????
:dh: :dh: :dh: :dh: :dh: :dh: :dh:

adarkar
13-06-2004, 22:23
ma la libc C'E' dappertutto!
forse ti sei dimenticato di installarla.. :p
cn la suse ti andava tutto perch non dovevi fare niente
mwhuahuah :p :gren: :p :gren:
:ciauz:

chaosd
14-06-2004, 08:22
Originariamente inviato da adarkar
ma la libc C'E' dappertutto!
forse ti sei dimenticato di installarla.. :p
cn la suse ti andava tutto perch non dovevi fare niente
mwhuahuah :p :gren: :p :gren:
:ciauz:

fai meno il figo... giusto per non prendere a morsi l'hd, ho reinstallato la slack PACCHETTO PER PACCHETTO, e con mio immenso gaudio (molti lo chiamano bestemmiare) non ho visto n "vi" n la libc.so.6 (beh, questa ovvio), nonostante io abbia installato qualunque pacchetto nel cui nome c'era una "c" :dh: :dh: :dh:

ridatemi la Suse :di56:

Loading