PDA

Visualizza la versione completa : Aiuto: JoLinux non si spegne più.....


hebiten
13-06-2004, 21:48
Ciao a tutti,
ho installato giorni fa JoLinux (basata su Slack).
Ho installato alcuni pacchetti e personalizzato un pò kde ma da oggi non riesco più a fare lo shutdown.
L'errore che mi dà è il seguente:

error: rc.0 line 46: killall not found

A parte il fatto che alla linea 46 non c'è la chiamata a questo comando, ho cercato il comando nel sistema e difatti non c'è ( mentre ho trovato kill e killall5).

Cosa può essere successo?
Come risolvo?

PS
La chiamata a l comando killall la trovo anche nel file rc.6 e anche il file rc.6 se eseguito mi da lo stesso errore.


Help, per ora posso solo spegnere il mio pinguino staccando la spina...... :(

Grazie

francofait
13-06-2004, 22:28
#! /bin/sh
#
# rc.6 This file is executed by init when it goes into runlevel
# 0 (halt) or runlevel 6 (reboot). It kills all processes,
# unmounts file systems and then either halts or reboots.
#
# Version: @(#)/etc/rc.d/rc.6 2.47 Sat Jan 13 13:37:26 PST 2001
#
# Author: Miquel van Smoorenburg <miquels@drinkel.nl.mugnet.org>
# Modified by: Patrick J. Volkerding, <volkerdi@slackware.com>
#

# Set the path.
PATH=/sbin:/etc:/bin:/usr/bin

# If there are SystemV init scripts for this runlevel, run them.
if [ -x /etc/rc.d/rc.sysvinit ]; then
. /etc/rc.d/rc.sysvinit
fi

# Set linefeed mode to avoid staircase effect.
stty onlcr

echo "Running shutdown script $0:"

# Find out how we were called.
case "$0" in
*0)
command="halt"
;;
*6)
command=reboot
;;
*)
echo "$0: call me as \"rc.0\" or \"rc.6\" please!"
exit 1
;;
esac

# Save the system time to the hardware clock using hwclock --systohc.
# Detect SGI Visual Workstation, since hwclock will make those freeze up:
if fgrep -l Cobalt-APIC /proc/interrupts 1> /dev/null 2> /dev/null ; then
echo "SGI Visual Workstation detected. Not running hwclock."
elif [ -x /sbin/hwclock ]; then
if grep "^UTC" /etc/hardwareclock 1> /dev/null 2> /dev/null ; then
echo "Saving system time to the hardware clock (UTC)."
/sbin/hwclock --utc --systohc
else
echo "Saving system time to the hardware clock (localtime)."
/sbin/hwclock --localtime --systohc
fi
fi

# Stop the Apache web server:
if [ -x /etc/rc.d/rc.httpd ]; then
/etc/rc.d/rc.httpd stop
fi

# Stop the MySQL database:
if [ -r /var/run/mysql/mysql.pid ]; then
. /etc/rc.d/rc.mysqld stop
fi

# Stop the Samba server:
if [ -x /etc/rc.d/rc.samba ]; then
. /etc/rc.d/rc.samba stop
fi

# Shut down the NFS server:
if [ -x /etc/rc.d/rc.nfsd ]; then
/etc/rc.d/rc.nfsd stop
fi

# Unmount any NFS or SMB filesystems:
echo "Unmounting remote filesystems."
umount -a -r -t nfs,smbfs

# Try to kill dhcpcd so the DHCP leases can be returned:
killall -15 dhcpcd 1> /dev/null 2> /dev/null

# Shut down PCMCIA devices:
if [ -x /etc/rc.d/rc.pcmcia ] ; then
. /etc/rc.d/rc.pcmcia stop
# The cards might need a little extra time here to initialize.
sleep 5
fi

# Turn off process accounting:
if [ -x /sbin/accton -a -r /var/log/pacct ]; then
echo "Turning off process accounting."
/sbin/accton
fi

# Kill all processes.
# INIT is supposed to handle this entirely now, but this didn't always
# work correctly without this second pass at killing off the processes.
# Since INIT already notified the user that processes were being killed,
# we'll avoid echoing this info this time around.
if [ "$1" != "fast" ]; then # shutdown did not already kill all processes
killall5 -15
sleep 5
killall5 -9
fi

# Try to turn off quota:
if fgrep quota /etc/fstab 1> /dev/null 2> /dev/null ; then
if [ -x /sbin/quotaoff ]; then
echo "Turning off filesystem quotas."
/sbin/quotaoff -a
fi
fi

# Before unmounting file systems write a reboot or halt record to wtmp.
$command -w

# Carry a random seed between reboots.
# Save 512 bytes, which is the size of the entropy pool.
if [ ! -r /etc/random-seed ]; then
touch /etc/random-seed
chmod 600 /etc/random-seed
fi
echo "Saving random seed from /dev/urandom in /etc/random-seed."
dd if=/dev/urandom of=/etc/random-seed count=1 bs=512 2> /dev/null

# Clear /var/lock/subsys.
if [ -d /var/lock/subsys ]; then
rm -f /var/lock/subsys/*
fi

# Turn off swap, then unmount local file systems.
echo "Turning off swap."
swapoff -a
echo "Unmounting local file systems."
# Don't remount UMSDOS root volumes:
if [ ! "`mount | head -1 | cut -d ' ' -f 5`" = "umsdos" ]; then
umount -a -r -t nonfs
echo "Remounting root filesystem read-only."
mount -n -o remount,ro /
else
umount -a -r -t nonfs,noumsdos,nosmbfs
fi

# This never hurts:
sync

# If we're using LVM, we need to deactivate the volume groups:
if [ -r /etc/lvmtab ]; then
/sbin/vgchange -an
fi

# sleep 1 fixes problems with some hard drives that don't
# otherwise finish syncing before reboot or poweroff
sleep 1

# This is to ensure all processes have completed on SMP machines:
wait

if [ -x /sbin/genpowerd ]; then
# See if this is a powerfail situation:
if egrep "FAIL|SCRAM" /etc/upsstatus 1> /dev/null 2> /dev/null ; then
# Signal UPS to shut off the inverter:
/sbin/genpowerd -k /dev/ttyS4 tripp-nt
if [ ! $? = 0 ]; then
echo
echo "There was an error signaling the UPS."
echo "Perhaps you need to edit /etc/rc.d/rc.6 to configure"
echo "the serial line and UPS type."
# Wasting 15 seconds of precious power:
sleep 15
fi
fi
fi

# Now halt (poweroff with APM kernels) or reboot.
if [ "$command" = "reboot" ]; then
echo "Rebooting."
reboot
else
poweroff
fi

francofait
13-06-2004, 22:35
salvo tu non sia intervenuto con modifiche manuali su rc.0 (che in realtà è un link sinbolico di rc.6
Con molta probabilità devi solo riattivare l' APM

modprobe apm

e renderlo attivo al boot decommentandolo in rc.modules

hebiten
14-06-2004, 09:50
Ho forse capito dove sta il problema della famosa riga 46.
Guardando al file rc.mysqld ho visto che alla riga 46 c'è la chiamata al comando killall.
Ho provato a mandare in esecuzione rc.mysqld e il sistema va in errore proprio a quella riga.
Questo problema si è verificato da quando ho installato Mysql.

Il mio rc.0 è identico a quello che hai postato tu e vedo che anche lì c'è la chiamata a killall.

Ma questo comando esiste per Slack? (io sto unsando JoLinux)

Nel pomeriggio provo a fare come dici e poi vedrò, ma provo anche a non far partire mysqld al boot così rc.mysqld non dovrebbe dare problemi.


Ciao

RockSteady
14-06-2004, 10:12
prova con #halt o #poweroff #shutdown -h now

hebiten
14-06-2004, 10:18
Ma questi comandi non eseguono lo script rc.0?
Mi pare di aver provato ma il risultato è lo stesso.



ciao

RockSteady
14-06-2004, 10:21
scusa la domanda (lò sò che nn e proprio la soluzione che vorresti)
ma perche non installi direttamente slackware??? :fagiano:
e una distro ottima veloce stabile provala :)

hebiten
14-06-2004, 11:12
Mentre aspetto di tornare a casa per fare le suddette prove, mi confermate che su Slack 9.1 esiste il comando killall?

E' possibile ,in qualche modo, installarlo sul mio sistema (JoLinux)?

grazie

hebiten
14-06-2004, 16:33
Avevo installato Slack 9.1 poi per prova ho messo JoLinux con kde 3.2.0 e kernek 2.6.5 allora mi sono detto: metto su Slack 9.1 e l'aggiorno alla current.
Kde 3.2.2 mi ha dato molti problemi in più avrei dovuto ricompilare il kernel così sono tornato alla JoLinux :)

Il tutto durante questo weekend.
Smanettando un pò sulle configurazioni ho imparato molto.

Al prossimo weekend mi sa che rimetto su Slack 9.1, ma ho letto in giro che kde 3.2.2 da un pò di problemi mentre per la ricompilazione del kernel ho avuto delle difficoltà in passato.


Per il problema del killall sto scaricando il pacchetto psmisc; dovrebbe avere al suo interno killall....

Vediamo che succede


Ciauz

francofait
14-06-2004, 17:13
Originariamente inviato da hebiten
Avevo installato Slack 9.1 poi per prova ho messo JoLinux con kde 3.2.0 e kernek 2.6.5 allora mi sono detto: metto su Slack 9.1 e l'aggiorno alla current.
Kde 3.2.2 mi ha dato molti problemi in più avrei dovuto ricompilare il kernel così sono tornato alla JoLinux :)

Il tutto durante questo weekend.
Smanettando un pò sulle configurazioni ho imparato molto.

Al prossimo weekend mi sa che rimetto su Slack 9.1, ma ho letto in giro che kde 3.2.2 da un pò di problemi mentre per la ricompilazione del kernel ho avuto delle difficoltà in passato.


Per il problema del killall sto scaricando il pacchetto psmisc; dovrebbe avere al suo interno killall....

Vediamo che succede

Uso regolarmente Slackware 9.1 con kde3.2.2 , non mi da problemi di alcun genere.
Slackware 9.1 - kde3.2.2 - kernel-2.6.7-1rc3








Ciauz

Loading