PDA

Visualizza la versione completa : Errore con moduli


LonelyWolf
17-06-2004, 10:03
MDK 10, sto installando il mio modem adsl pci, ho seguito tutte le istruzioni x filo e x segno e finalmente sembra tutto a posto, ma quando do l'avvio:

FATAL: Module XXXX not found

ed ovviamente non va!

C' un posto standard in cui sono messi tutti i moduli?
Oppure sufficiente che aggiunga il nome nel file "modules"?
Grazie!

PunkIvi
17-06-2004, 10:36
I moduli sono in /lib/modules/versionekernel. Se non lo inserisce perch non lo trova...ti toccherebbe ricompilare il kernel...che modulo ?

LonelyWolf
17-06-2004, 10:54
non un modulo standard, quello per il modem adsl pci (Conexant AccessRunner)
Si chiama: CnxADSL

Ma le istruzioni dicevano di scaricate il driver, scompattarlo (tar.bz2) poi un bel make ed infine make install.

Cosa ke ho fatto e non ho visto nessun warning o errore.

Prover a cercare bene!

PunkIvi
17-06-2004, 10:59
Solitamente in questi casi quando si fa il make per un driver viene generato il modulo. Prova a cercarlo nella cartella dove hai fatto il make, dev'essere un *.o .

LonelyWolf
17-06-2004, 11:05
ehm la cartella non c' +, l'ho cestinata non pensavo servisse ancora! :(
ma se faccio di nuovo solo un make (non install) sono a posto?
oppure dove trovo il cestino? quando entro come root con kde non lo trovo1

Un'ultima domanda, mentre provavo per avviare l'adsl come utente normale, ho dovuto usare su, c' un modo x evitare questo passaggio? ovvero come posso avere i permessi per avviare l'adsl senza dover fare login come root?

PunkIvi
17-06-2004, 11:09
Fai cos: ricomincia da capo, cio riscarica il driver, fai configure make ecc ecc e dimmi se trovi il modulo.

LonelyWolf
17-06-2004, 11:39
il configure non c' nelle istruzioni, quindi se rifaccio tutto da capo non succede nulla? bene prover.

Se vuoi dare un'okkiata, ecco la pagina da cui ho recuperato tutto:

http://patrick.spacesurfer.com/linux_conexant_pci_adsl.html

grazie 1000.

PunkIvi
17-06-2004, 11:44
Segui semplicemente le istruzioni e guarda se esce fuori il modulo.

LonelyWolf
17-06-2004, 14:15
Allora prima di rifare tutto ho cercato il modulo e l'ho trovato in /lib/modules/2.6.3-7mdkcustom/CnxADSL.ko
ho provato con modprobe indicando tutto il persorso, non trovato
ho provato a copiarlo in /lib/modules/2.6.3-7mdk/CnxADSL.ko, idem non trovato
ho provato a metterlo (con il percorso completo) nel file modules, idem
ho provato a seguire nuovamente la guida e quindi di nuyovo make e make install, stesso risultato.

Ho notato x durante l'output del make che c' un messaggio riguardante le SUBDIRS ma veloce e non ho capito molto.

ho provato ad aggiornare il kernel alla 2.6.3-13mdk, ricompilare tutto e idem, non trovato.

Faccio tutto da root e faccio anke il reboot.

non so + ke fare!

PunkIvi
17-06-2004, 14:34
Prova modconf e guarda se trovi il modulo. Che kernel hai al momento?

Loading