PDA

Visualizza la versione completa : Ho' bisogno di aiuto...


Franco78
20-06-2004, 17:08
vi spiego il problema.

Uso Mandrake 9.2
Sto' compilando kde ma termina con un errore perche' cerca
libvorbisfile.la nella directory sbagliata./usr/lib invece di /usr/local/lib.
Questo errore dovrebbe essere dovuto al fatto che cerca in /usr/lib/pkgconfig/vorbisfile.pc che invece sta in /usr/local/lib/pkgconfig/...

Ho' cercato in rete vari modi per configurare la variabile PKG_CONFIG_PATH ma il programma si ostina a cercare la libreria in /usr/lib.

Vi prego di aiutarmi. Grazie

andy caps
20-06-2004, 17:26
prova a fargli in link


cd /usr/lib


ln -s /usr/local/lib/libvorbisfile.la

Franco78
20-06-2004, 17:53
> prova a fargli un link

Grazie per l'aiuto ma, effettivamente ho' provato a fare un link e funziona solo che, credo non sia il metodo piu' corretto.

Ciao.

andy caps
20-06-2004, 17:59
il metodo corretto se guardi in /usr/lib quelli di mandrake ne avreanno fatti un centinaio

non so semmai quanto andra' bene compilato da sorgente gli rpm di mandrake sono tutti diversi

Franco78
20-06-2004, 18:07
Comunque io non ho' ancora capito perche' lo cerca nella directory sbagliata, e' solo una curiosita'.

> non so semmai quanto andra' bene compilato da sorgente gli rpm di mandrake sono tutti diversi

A me' va benissimo te lo posso assicurare, per essere sicuro di aver cancellato tutti i file di configurazione della versione vecchia ho creato un nuovo users e ho' eliminato quello vecchio.
E' da un po' che la uso solo che non avevo ancora compilato tutti i pacchetti.

Franco78
20-06-2004, 18:17
> non so semmai quanto andra' bene compilato da sorgente gli rpm di mandrake sono tutti diversi

Non ho' ben capito in che senso gli RPM sono diversi.

andy caps
20-06-2004, 18:24
fondamentalmente sono creati con i sorgenti pero quelli di mandrake li patchano continuamente per adattarli alla mandrake

sulla cooker (la mandrake sperimentale in continua evoluzione ) prima di fare uscire la release finali sono capaci di aggiornare anche 40 volte kde con sotto release diverse

Franco78
20-06-2004, 18:37
Io sapevo che il kernel della mandrake era molto patchato, non sapevo che lo fossero anche le applicazioni.
Comunque a me' kde non mi sta' dando nessun problema. Al massimo li avevo in compilazione sulla Mandrake 10.0 perche' credo non fossero stati ancora adattati i sorgenti (ma non solo con kde). Per questo secondo me' e' meglio stare una release in dietro a quella attuale.
Ti ringrazio ancora, sei l'unico che mi ha' risposto.
Ciao

Loading