PDA

Visualizza la versione completa : Installazione CGI


keratox
22-06-2004, 08:42
Io ho apportato tutte le modifiche al httpd.conf di apache che dicono le guide

ma se provo ad andare su http://localhost/cgi-bin/
mi dice che ho l'accesso negato

Ciao

geiar99
22-06-2004, 13:47
hai provato a scrivere http://localhost/cgi-bin/nomescript ?
è naturale che la directory cgi-bin non sia direttamente visualizzabile tramite webserver.

keratox
22-06-2004, 14:00
si' ho provato e mi dà l'errore...



Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

geiar99
22-06-2004, 14:04
:) ho il tuo stesso problema. ho postato un messaggio sul forum, ma ancora nessuno mi ha risposto. Comunque se trovo la soluzione ti faccio sapere. Ma il codice che hai inserito è semplice perl oppure hai utilizzato dei moduli particolari?

keratox
22-06-2004, 14:17
ho semplicemente scritto

print "ciao";

:)

geiar99
22-06-2004, 14:25
allora il problema lo puoi risolvere facilmente scrivendo:


ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

#
# "/var/www/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "/var/www/cgi-bin">
SetHandler perl-script
PerlSendHeader On
Options +ExecCGI
Order allow,deny
Allow from all
</Directory>

a partire dalla riga 579 del file httpd.conf (apache 2.0). è il contennuto del mio file così come lo modificato e funziona senza problemi con tutti gli scirpt perl, a parte quelli dove sono utilizzati moduli particolari, ma non è il tuo caso.
:)

keratox
30-06-2004, 08:11
ma il percorso



ScriptAlias /cgi-bin/ "D:/Programmi/EasyPHP1-7/cgi-bin/"
<Directory "D:/Programmi/EasyPHP1-7/cgi-bin/">
AllowOverride None
Options All +MultiViews
Allow from All
</Directory>


Deve essere impostato dalla directory root o da D:/ ?
Se dalla dir root sarebbe



ScriptAlias /cgi-bin/ "/cgi-bin/"
<Directory "/cgi-bin/">
AllowOverride None
Options All +MultiViews
Allow from All
</Directory>


o no??

geiar99
30-06-2004, 11:56
Credo proprio che devi impostarlo dalla dir D:/ visto che lavori su windows. Non credo che Apache sia capace di capire che lavori già su quella partizione. Non ne ha gli elementi. ma così ti funziona?
Ciao :)

Loading