PDA

Visualizza la versione completa : chmod su tutti i file


spanishjhonny
23-06-2004, 15:51
ciao
sto cercando di dare tutti i permessi a una cartella usando il comando chmod 7777, ma il comando non si applica su tutti i file presenti nella cartella...ho cercato con man chmod ma non ho trovato nulla ... avete dei suggerimenti?

grazie
fabio

Steph
23-06-2004, 15:52
chmod -R 777

:ciauz:

spanishjhonny
23-06-2004, 17:18
grazie mille
:D
fabio

fabio58
20-07-2004, 19:57
e per rimettere tutto come prima??

almafer
20-07-2004, 20:26
Originariamente inviato da fabio58
e per rimettere tutto come prima??
devi sapere come erano settati i permessi prima e cambi i numeri di conseguenza :fagiano:

Crauto
20-07-2004, 20:47
Fai un restore dal backup che siiiiiicuramente avrai effettuato. :dhò:

fabio58
21-07-2004, 11:33
quando usavo Gnome cliccando sulla proprietà dei file permessi vedevo il relativo codice (es.777 ecc) e potevo rimettere a posto dopo aver variato, invece non riesco a vederli anche cliccando in proprietà file con KDE e nemmeno da shell usando il comando ls -la. Qualche consiglio magari c'e qualcosa da settare su KDE??? Grazie in anticipo

superbubba
21-07-2004, 14:57
Nelle ultime versione di KDE mi pare di aver visto una gestione semplificata dei permessi in stile Windows (flag di sola lettura, e così via) che ovviamente nasconde e non sostituisce i permessi UNIX classici.

Se non ti va nemmeno da shell non so che dirti... :bhò:

fabio58
21-07-2004, 15:02
se da shell faccio ls -la mi da i tipi di permessi ma non il classico codice numerico mi interessa poterlo vedere almeno tramite kde non è facile risalire a un rw--x- e via discorrendo

l.golinelli
21-07-2004, 15:22
Originariamente inviato da fabio58
se da shell faccio ls -la mi da i tipi di permessi ma non il classico codice numerico mi interessa poterlo vedere almeno tramite kde non è facile risalire a un rw--x- e via discorrendo

Non è facile se non sei espeto, altrimenti diventa del tutto automatico...

Loading