PDA

Visualizza la versione completa : Pendrive e cdrom su debian


markus007
25-06-2004, 23:14
Rieccomi,
non riesco a "vedere" su debian sid n il cd-rom n la pendrive (forse non riconosce le porte usb).

Cosa mi consigliate di fare?

Kamui
25-06-2004, 23:15
Beh.. ma l'hai montata? Che hai fatto?

markus007
25-06-2004, 23:19
non ho fatto proprio niente, ma se passo il comando fdisk -l mi vede solo l'hard disk!

RockSteady
25-06-2004, 23:51
inserisci la pen drive
ls /dev/ds*
vedi quale del e libero e lo monti
mount -t vfat /dev/dsa1 /mnt/pen <----esempio

per il cd rom se sono dati lo monti mount -t auto /mnt/cdrom

se e un cd normale apri il programma per i dc e l ascolti

markus007
26-06-2004, 00:14
non sono riuscito a montare n pendrive n cdrom! :dh: :dh: :dh:


per la pendrive ho dato ls /dev/ds* ma mi visualizza la lista:
/dev/dsp /dev/dsp1 /dev/dsp2 /dev/dsp2

come faccio da qui a vedere quale del libero? :confused:
ne ho provati un paio ma mi dice /dev/dsp1 "is not a block device".



per il cdrom invece dopo aver dato mount -t auto /mnt/cdrom mi esce una lista di opzioni. Che faccio? :confused: :confused:

markus007
26-06-2004, 00:18
ok, il cdrom andato! :metallica


ho semplicemente dato:
mount -t auto /dev/cdrom /mnt/cdrom



per la pendrive invece sto ancora smanettando senza risultati! :bh:

mykol
26-06-2004, 00:53
.... invece di ls /dev/ds* mi pare che dovrebbe essere

ls /dev/sd*

e

mount -t vfat /dev/sda1 /mnt/pen

Comunque prima da console di root dai

# lsusb

io vedo WinMaxGroup che la penna USB e Logitech, Inc. Optical Mouse (mouse USB)

root@LinuxBoxCompaq:/home/giorgio# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 0ed1:6680 WinMaxGroup
Bus 001 Device 002: ID 046d:c00e Logitech, Inc. Optical Mouse
Bus 001 Device 001: ID 0000:0000
root@LinuxBoxCompaq:/home/giorgio#

Dai # lsusb prima di aver collegato la penna USB e dopo;

se compare una nuova scritta come nel mio caso, significa che la penna riconosciuta e quindi dovrai solo montarla provando con /dev/sda1, /dev/sda2, ... altrimenti bisogna vedere se hai caricato i moduli per l'USB con

# lsmod

in particolare usb-storage.

Se non compare aggiungilo in /etc/modules

Riassumendo, fai:

# lsusb (prima e dopo aver inserito la penna usb)

se compare

# mkdir /mnt/pen

metti in /etc/fstab

/dev/sda1 /mnt/pen vfat auto,rw,user,exec,umask=000 0 0

(o sda2, ecc..., ma se non hai altri dispositivi USB dovrebbe essere sda1)

poi

# mount /dev/sda1 mnt/pen

poi con

# ls /mnt/pen

devi vedere il contenuto della penna.

se invece #lsusb non evidenzia la penna, devi inserire usb-storage in /etc/modules (ed eventualmente, gli altri moduli per l'USB).

se non va prova a postare il contenuto del tuo /etc/modules e del tuo /etc/fstab

markus007
26-06-2004, 13:48
La tua spiegazione sembra eccellente, ma dando il comando lsusb mi esce "command not found".
Cosa faccio?

Kamui
26-06-2004, 14:14
Tanto nel 90% dei casi cos:

# mkdir /mnt/usb
[ collega la fotocamera al PC ]
# mount -t vfat /dev/sda1 /mnt/usb

E in /mnt/usb ci trovi le foto.
Se non andasse, prova a fare #modprobe usb-storage e ritentare il mount.

markus007
26-06-2004, 15:14
niente da fare, non funge.

d il comando:
mount -t vfat /dev/sda1 /mnt/usb
e mi esce:

mount: No medium found

che faccio? :confused:


inoltre, perch non mi riconosce il comando lsusb????

Loading