PDA

Visualizza la versione completa : Slackware 10 e dvdrom: non mi v!!


andrea_NET-_DSL
26-06-2004, 19:21
Ho installato oggi la nuova slackware 10 da 0.
Come faccio ad utilizzare il dvdrom?

Se inserisco un cd nel masterizzatore di cd e scrivo


root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/cdrom
root@linuxbox:~#


nella cartella scelta mi compare il contenuto del cd.

Mentre se do'


root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/dvd
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found
root@linuxbox:~#

ricevo questi "errori"!! :dh:

come mai?:(
come potrei risolvere??:confused: (naturalmente metto il cd dentro il dvdrom... :stordita: )

Grazie mille
:ciauz:

ps in slack non ho modificato nulla se non la configurazione di internet e del mouse,per abilitare la rotella!

Enrico81
26-06-2004, 20:37
Originariamente inviato da andrea_NET-_DSL
Ho installato oggi la nuova slackware 10 da 0.
Come faccio ad utilizzare il dvdrom?

Se inserisco un cd nel masterizzatore di cd e scrivo


root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/cdrom
root@linuxbox:~#


nella cartella scelta mi compare il contenuto del cd.

Mentre se do'


root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/dvd
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found
root@linuxbox:~#

ricevo questi "errori"!! :dh:

come mai?:(
come potrei risolvere??:confused: (naturalmente metto il cd dentro il dvdrom... :stordita: )

Grazie mille
:ciauz:

ps in slack non ho modificato nulla se non la configurazione di internet e del mouse,per abilitare la rotella!

In /mnt hai creato la directory dvd?
Prova a dare un dmesg | less e guarda come riconosce il dvd (hdc1, hdc2, hd.....) e montalo con:

mount -t iso9660 /dev/hd..... /mnt/dvd

andrea_NET-_DSL
26-06-2004, 21:01
Originariamente inviato da Enrico81
In /mnt hai creato la directory dvd?
Prova a dare un dmesg | less e guarda come riconosce il dvd (hdc1, hdc2, hd.....) e montalo con:

mount -t iso9660 /dev/hd..... /mnt/dvd
sisi l'avevo creata la cartella /mnt/dvd.

azz se provo il montaggio con /dev/hdd viene eseguito senza problemi,son contento :D ... ma vorrei capire come mai?perch x il cdrom va bene /dev/cdrom mentre per il dvd /dev/dvd no? :confused: :stordita:

ecco la parte dell'output del comando dmesg relativa alle periferiche ottiche

hdc: SONY CD-RW CRX145E, ATAPI CD/DVD-ROM drive
hdd: DV-516E, ATAPI CD/DVD-ROM drive


grazie
:ciauz:

ps allora ,seguendo questa logica,il mount x il cdrom dovrebbe andarea buon fine solo con /dev/hdc mentre funge anche con /dev/cdrom,cosa non vera x il dvdrom... :bh:

Enrico81
26-06-2004, 21:39
Originariamente inviato da andrea_NET-_DSL
sisi l'avevo creata la cartella /mnt/dvd.

azz se provo il montaggio con /dev/hdd viene eseguito senza problemi,son contento :D ... ma vorrei capire come mai?perch x il cdrom va bene /dev/cdrom mentre per il dvd /dev/dvd no? :confused: :stordita:

ecco la parte dell'output del comando dmesg relativa alle periferiche ottiche

hdc: SONY CD-RW CRX145E, ATAPI CD/DVD-ROM drive
hdd: DV-516E, ATAPI CD/DVD-ROM drive


grazie
:ciauz:

ps allora ,seguendo questa logica,il mount x il cdrom dovrebbe andarea buon fine solo con /dev/hdc mentre funge anche con /dev/cdrom,cosa non vera x il dvdrom... :bh:

Ora non so di preciso ma si vede che durante l'installazione il sistema ha creato un link simbolico da /dev/hdc e /dev/cdrom.
Prova a sostituire nel file /etc/fstab /dev/cdrom con /dev/hdc vedrai che riesci a montarlo ugualmente.

ps. ti conviene creare un riga nel file suddetto anche per il dvd cos lo monti con un semplice mount /mnt/dvd.

the rich
26-06-2004, 21:44
stavi parlando che hai installato la slackware 10.....

come??

grazie in anticipo!!!

ciao :ciauz:

francofait
26-06-2004, 23:50
Originariamente inviato da the rich
stavi parlando che hai installato la slackware 10.....

come??

grazie in anticipo!!!

ciao :ciauz:

chmod 777 /dev/sr0

/etc/fstab mio :
/dev/hdb5 swap swap defaults 0 0
/dev/hdb9 / reiserfs defaults 1 1
/dev/hda1 /winxp vfat defaults 1 0
/dev/hdd /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/sr0 /dvd iso9660 user,owner,exec,umask=00,rw 0 0
/dev/hdb1 /suse reiserfs defaults 0 0

vai in /dev/@cdrom errato come linksimbolico , lo sopprimi e lo ricstruisci dal driver reale corretto ( io ho il masteriz. dvd come master sec (hdc). e il lettore come slave sec (hdd)
per cui il linck simbolico @cdrom l' ho ricreato da /dev/hdd -
Te chiaramente dovrai farlo dal driver reale tuo.

:ciauz: :ciauz:

francofait
27-06-2004, 01:42
Usando il kernel-generic-2.6.7 invece ho dovuto aggiornare fstab in questo modo:
/dev/hdb5 swap swap defaults 0 0
/dev/hdb9 / reiserfs defaults 1 1
/dev/hda1 /winxp vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,user,exec,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/hdc /dvd iso9660 noauto,user,owner,exec,rw 0 0
/dev/hdb1 /suse reiserfs defaults 0 0

diversamente cdrom e masteriz. dvd non vengono gestiti correttamente.

andrea_NET-_DSL
27-06-2004, 10:14
Originariamente inviato da francofait
chmod 777 /dev/sr0

/etc/fstab mio :
/dev/hdb5 swap swap defaults 0 0
/dev/hdb9 / reiserfs defaults 1 1
/dev/hda1 /winxp vfat defaults 1 0
/dev/hdd /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/sr0 /dvd iso9660 user,owner,exec,umask=00,rw 0 0
/dev/hdb1 /suse reiserfs defaults 0 0

vai in /dev/@cdrom errato come linksimbolico , lo sopprimi e lo ricstruisci dal driver reale corretto ( io ho il masteriz. dvd come master sec (hdc). e il lettore come slave sec (hdd)
per cui il linck simbolico @cdrom l' ho ricreato da /dev/hdd -
Te chiaramente dovrai farlo dal driver reale tuo.

:ciauz: :ciauz:
a me il cdrom(mast/lett cd-rw sony) lo ha messo in auto in fstab mentre il dvdrom no.

Dentro /dev c' @dvd ma sicuramente errato il link :bh:

normale che succeda quindi? :stordita: non ho toccato nulla... :fagiano: :D

Per la cronaca ecco il mio /etc/fstab

/dev/hda5 swap swap defaults 0 0
/dev/hda6 / reiserfs defaults 1 1
/dev/hda1 /mnt/linux2 reiserfs defaults 1 2
/dev/hdb1 /mnt/hd80gb vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0



Cmq il kernel 2.4.26 una bomba...mi riconosce lo scanner agfa usb mentre il 2.6.x o il 2.4.x, precedente, no:D
W slack eheh :gren:

** Infatti il suddeto scanner mi funge anche con la live knoppix 3.4 propio xch usa il 2.4.26 come kernel!! **

ps quindi cambio a cosa punta il link @dvd,mettendolo verso /dev/hdd ? :stordita:
come potrei farlo da lineda di comando? :fagiano:

gigyz
27-06-2004, 10:50
:dott: togliete i prosciutti dagli occhi :D
che differenza c' tra

root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/cdrom
root@linuxbox:~#

root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/dvd
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found
root@linuxbox:~#

solo il punto di mount ma non di device che sempre /dev/cdrom infatti se lasci il cd nel cdrom ti ritroverai montato il cd in /mnt/dvd. Devi cambiare il device quindi

mount /dev/hdxy /mnt/dvd

naturalmente dopo che hai visto dal dmesg dove sta il tuo dvd

andrea_NET-_DSL
27-06-2004, 11:42
Originariamente inviato da gigyz
:dott: togliete i prosciutti dagli occhi :D
che differenza c' tra

root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/cdrom
root@linuxbox:~#

root@linuxbox:~# mount -t iso9660 /dev/cdrom /mnt/dvd
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found
root@linuxbox:~#

solo il punto di mount ma non di device che sempre /dev/cdrom infatti se lasci il cd nel cdrom ti ritroverai montato il cd in /mnt/dvd. Devi cambiare il device quindi

mount /dev/hdxy /mnt/dvd

naturalmente dopo che hai visto dal dmesg dove sta il tuo dvd
sissi certo
ma infatti non qui il problema :stordita:
capire come mai dopo una installazioen "fresca" di slackware10 il cdrom viene montato senza problemi dando come device /dev/cdrom mentre il dvd ,dando /dev/dvd , no.

Nel primo post ho fatto un errore di battitura davo /dev/dvd su cartella /mnt/dvd (il /dev/cdrom v senza problemi...su cartella /mnt/cdrom)e NON /dev/cdrom sulla cartella del dvd :fagiano: ;)



root@linuxbox:~# mount -t auto /dev/dvd /mnt/dvd
mount: block device /dev/dvd is write-protected, mounting read-only
mount: No medium found
root@linuxbox:~# mount -t auto /dev/hdd /mnt/dvd
mount: block device /dev/hdd is write-protected, mounting read-only
root@linuxbox:~#

vedete..dove hdd il dvdrom mentre hdc il masterizzatore/lettore cdrom..
il dvd viene montato solo se specifico /dev/hdd e non con /dev/dvd

:ciauz:

Loading