PDA

Visualizza la versione completa : Ruotare log - problema


daviweb
02-07-2004, 11:52
Ciao!

Quando ho installato qmail ho dovuto disinstallare exim tramite apt-get, il quale mi ha disintallato anche logrotate (e mailx).

Ora i log generati da qmail finiscono in /var/log/mail.log come impostato nel file /etc/syslog.conf.

Vorrei però che venissero ruotati ogni giorno, non ogni settimana!!

Pensavo quindi di configurare questa cosa tramite /etc/logrotete.conf, ma non c'è più visto che è stato disinstallato! E' rimasta solo la directory /etc/logrotate.d/.


Quindi come potrei fare? E' possibile impostarlo tramite syslog.conf?

l.golinelli
02-07-2004, 12:15
apt-get install logrotate

daviweb
02-07-2004, 12:29
Ciao l.golinelli!

Se faccio "apt-get install logrotate" mi vuole installare anche exim e mailx, ma sul sistema c'è installato qmail... non so cosa potrebbe succedere...

daviweb
02-07-2004, 16:38
Originariamente inviato da daviweb
... ma sul sistema c'è installato qmail... non so cosa potrebbe succedere...

Il fatto è che non posso provare e rischiare! :dhò:

Avrei bisogno di sapere cosa potrebbe succedere. Apt-get non sa che sulla porta 25 c'è già in ascolto qmail, ma se ne accorgerà solo quando tenterà di installare exim suppongo, e allora cosa accadrà?

Guardando sul sito debian le dipendenze risulta che logrotate necessita di mailx, il quale a sua volta ha bisogno di un MTA qualsiasi. Dovrei dirgli di utilizzare qmail! Ma come?

daviweb
02-07-2004, 18:31
Ce l'ho fatta!! :D

Grazie.

ciao

l.golinelli
05-07-2004, 08:39
Originariamente inviato da daviweb
Ce l'ho fatta!! :D

Grazie.

ciao

Mica dire come hai fatto... :incupito:

daviweb
05-07-2004, 10:11
Scusa... ma sembrava che non interessava a nessuno... :messner: :rollo:


Ma che bello, oggi ci sono le faccine nuove! :) :stordita:



Dunque, siccome a logrotate serviva mailx, e a mailx ovviamente serviva un MTA (qualsiasi), ho spostato la mia attenzione all'installazione di mailx.

Ho tentato quindi di utilizzare apt-get con l'opzione --force-yes ma mi dava sempre l'errore di dipendenza... ho quindi provato con #dpkg -i --force-depends e finalmente ha funzionato!!! :yuppi:

Dopodichè l'installazione di logrotate è andata via liscia liscia! :D



E sono inoltre riuscito a configurarlo come volevo!

Grazie
ciao

:ciauz:

l.golinelli
05-07-2004, 11:17
:ciauz: :ciauz: :ciauz:

Loading