PDA

Visualizza la versione completa : qmail - installazione e configurazione


james
06-07-2004, 11:50
Dopo tanto sono riuscito ad installare qmail, ma questo solo il primo passo, ora dovr (non so come) gestire gli utenti virutali, ho letto in giro riguardo ad alcuni pacchetti. Ma prima di questo dovrei testare il funzionamento di qmail, il file TEST.deliver dice cosa dovrei fare, controllare il file syslog, ma dove lo trovo?! Uso Suse 9.1

james
06-07-2004, 13:11
di syslog ne trovo 2000! Dove lo trovo questo file di log? (credo sia un file di log) il file che mi da le istruzioni dice:

You can do several tests of qmail delivery without setting up qmail to
accept messages through SMTP or through /usr/lib/sendmail:

1. After you start qmail, look for a
qmail: status: local 0/10 remote 0/20
line in syslog. qmail-send always prints either ``cannot start'' or
``status''. (The big number is a splogger timestamp.)


Poi continua

daviweb
06-07-2004, 15:24
guarda se hai il file /var/log/mail.log ...

james
06-07-2004, 15:31
Originariamente inviato da daviweb
guarda se hai il file /var/log/mail.log ...

no, ho cercato anche il file syslog ma non c'.

daviweb
06-07-2004, 15:41
Guarda in questo file, dove impostato che finiscono i log delle mail...

/etc/syslog.conf

Altrimenti guarda in /var/log/messages

james
06-07-2004, 15:48
come faccio poi a controllare i messaggi nei test? Non posso scaricare la posta con un normale client in pop3

james
06-07-2004, 15:50
Originariamente inviato da daviweb
Guarda in questo file, dove impostato che finiscono i log delle mail...

/etc/syslog.conf

Altrimenti guarda in /var/log/messages

C' scritto

mail.* -/var/log/mail
mail.info -/var/log/mail.info
mail.warning -/var/log/mail.warn
mail.err /var/log/mail.err


i file esistono, ma non ci sono i messaggi che dovrei trovare

daviweb
06-07-2004, 15:55
Molto probabilmente se non hai trovato questa riga:

qmail: status: local 0/10 remote 0/20

significa che qmail non stato avviato correttamente... :bh:


Che guida stai seguendo?
Prova ad inviare un messaggio (sicuramente sulla guida viene scritto come) e vedere cosa succede. :)

james
06-07-2004, 16:11
Originariamente inviato da daviweb
Molto probabilmente se non hai trovato questa riga:

qmail: status: local 0/10 remote 0/20

significa che qmail non stato avviato correttamente... :bh:


Che guida stai seguendo?
Prova ad inviare un messaggio (sicuramente sulla guida viene scritto come) e vedere cosa succede. :)

Sto seguendo questa guida http://medialab.dyndns.org/~elibus/lwq.html#configuration, passo alla configurazione e comunque qmail sta su

james
06-07-2004, 16:14
la guida dice di inviare la mail con il comando

echo to: utente | /var/qmail/bin/qmail-inject

poi dice di controllare la mailbox, ma come la controllo?!

Loading