PDA

Visualizza la versione completa : [Debian] Errore Debconf durante apt


oTTony
07-07-2004, 09:55
Ciao a tutti , ho un problema con apt-get install , quando installo un qualsiasi pacchetto ricevo questo errore :

debconf: unable to initialize frontend: Kde
debconf: (Can't locate Qt.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.3 /usr/local/share/perl/5.8.3 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Kde/Wizard.pm line 7.)
debconf: falling back to frontend: Dialog

Non riesco a capire se il problema dato da Qt.pm o da perl o da altro cosa .I pacchetti vengono installati ma a volte qulacuno mi da problemi ...

Distyro Debian Sarge

TheX
07-07-2004, 12:57
prova ad installare le librerie qt e il perl....

oTTony
07-07-2004, 14:03
Il problema non era quello ma ti ringrazio molto comunque , infatti le Qt e il perl erano gi installati , il problema era sui moduli di comunicazione tra essi , infatti per risolvare il problema ho installato le seguenti librerie :

libqt-perl
libquantum-entanglement-perl
libquantum-superpositions-perl
libquota-perl

Giusto per i posteri .... :unz:

TheX
07-07-2004, 14:59
Originariamente inviato da oTTony
Il problema non era quello ma ti ringrazio molto comunque , infatti le Qt e il perl erano gi installati , il problema era sui moduli di comunicazione tra essi , infatti per risolvare il problema ho installato le seguenti librerie :

libqt-perl
libquantum-entanglement-perl
libquantum-superpositions-perl
libquota-perl

Giusto per i posteri .... :unz:

Beh, parlando d librerie qt e perl intendo, anke, le sopra citate libqt-perl :P

Cmq l'importante ke tu sia riuscito a risolvere il tuo problema...

P.S. Per esperienza personale, nn t conviene (a sto punto) a passare direttamente a SID invece ke Sarge ? Io ho provato entrambe le 3 "versioni" e l'unica ke mi ha dato seri problemi stata la testing xk come si dice "Nn ne' carne ne' pesce".... Imho....

oTTony
07-07-2004, 15:55
Si ci stavo gi pensando seriamente , avevo gi provato a fare il passaggio alla sid ma non con buoni risultati ....

TheX
07-07-2004, 17:00
Originariamente inviato da oTTony
Si ci stavo gi pensando seriamente , avevo gi provato a fare il passaggio alla sid ma non con buoni risultati ....

beh, se nn hai hardware troppo particolare e stai attento ai dist-upgrade io ritengo migliore la sid rispetto alla sarge....

oTTony
07-07-2004, 17:38
Originariamente inviato da TheX
beh, se nn hai hardware troppo particolare e stai attento ai dist-upgrade io ritengo migliore la sid rispetto alla sarge....

Per il momento ho cambiato le repostory e ho fatto un bel ;

apt-get update && apt-get dist-upgrade

Sembra essere andato tutto bene , per in questo modo non sono passato a sid , o si ???? :confused:

Ho messo questa repostory :

deb ftp://ftp.ie.debian.org/debian/ unstable main non-free contrib
deb-src ftp://ftp.ie.debian.org/debian/ unstable main non-free contrib
deb http://non-us.debian.org/debian-non-US/ unstable/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US/ unstable/non-US main contrib non-free

deb ftp://ftp.nerim.net/debian-marillat/ unstable main

Quindi penso sia sid a tutti gli effetti ??? :fagiano:

TheX
07-07-2004, 18:29
Si, esatto... ora hai 1 bella SID :P

Loading