PDA

Visualizza la versione completa : Installare Libreria


m@ximo
08-07-2004, 21:15
Salve a tutti, sono completamente inesperto di tutto ciò che è Linux. Ora però mi trovo a dover risolvere un problema:

Premetto che sto lavorando in remoto e interagisco col pc su cui risiede Linux mediante una sessione Telnet, quindi posso lavorare usando solo la console. Ho provato a lanciare un programma, ma quest'ultimo mi da il seguente errore: "/lib/i686/libc.so.6: version `GLIBC_2.3' not found"

A tal proposito ho scaricato il seguente file "glibc-2.3.2-27.9.7.i686.rpm" che dovrebbe contenere la suddetta libreria.
Infine facendo una ricerca in rete ho letto che per installare il package era necessario digitare: "rpm -ivh NomeFile.rpm"

Fatto anche questo mi escono i seguenti errori:

error: cannot open Packages index using db3 - Permission denied (13)
error: cannot open Packages database in /var/lib/rpm

Sono dovuti al fatto che non ho i diritti di amministratore sulla macchina o sono dovuti a qualke mio errore nei passi precedenti.

Grazie per l'attenzione e soprattutto a chi mi risponderà. :ciauz:

fra7576
08-07-2004, 21:58
il "permission denied" mi fa intuire che non hai i permessi di amministratore, essenziali per installare-rimuovere sw in linux.

m@ximo
08-07-2004, 22:02
Grazie allora è come pensavo.

Secondo voi il file che ho scaricato andrà bene per la libreria mancante?

Grazie

andy caps
09-07-2004, 00:45
glibc-2.3.2-27.9.7.i686.rpm è alla base del sistema
io non proverei ad installarla perche' potrebbe compromettere la stabilita

senza privilegi di amministratore non riusciresti comunque ad installarla

/dev/null
09-07-2004, 01:01
Quoto quanto detto da andy...
Linux si chiama GNU/Linux proprio per le glibc (gnu c libraries), si occupano di azioni basilari, come l'allocazione della memoria...

Che programma ti da quell'errore?

m@ximo
09-07-2004, 09:28
Il programma si chiama "Slipper".

Secondo voi come posso risolvere?

Ikitt
09-07-2004, 11:42
Originariamente inviato da m@ximo
Il programma si chiama "Slipper".

Secondo voi come posso risolvere?

Il mondo standard e` cercare un pacchetto prefatto per la tua distribuzione...

m@ximo
09-07-2004, 12:04
Tutti i link che parlano di questo software mi riportano a questa pagina: Slipper (http://www-2.cs.cmu.edu/~wcohen/slipper/)

Ma io non vedo alcun link per particolari librerie. Non trovo una soluzione :dhò:

Loading