PDA

Visualizza la versione completa : errori di apt-get


Ratatuia
09-07-2004, 14:13
ho provato a dare un apt-get dist upgrade e alla fine mi dà un errore che nn saprei proprio come risolverlo...di seguito metto tutto l'output della console che magari può essere utile...dimenticavo, il tutto è su una suse 9.0



athlon:/home/ratatuia # apt-get dist-upgrade
Lettura della lista di pacchetti... Done
Calcolo dell'albero delle dipendenze... Done
Calcolo dell'aggiornamento... Fatto
Verranno aggiornati i seguenti pacchetti
3ddiag BASS CheckHardware DirectFB Geramik OpenOffice_org
OpenOffice_org-Quickstarter OpenOffice_org-it QtPixmap RealPlayer SDL
SDL_image SDL_mixer SDL_net SDL_perl SDL_ttf SuSEfirewall2 WindowMaker
WindowMaker-applets WindowMaker-themes aaa_base aaa_skel aalib acl acpid
acroread alsa alsa-tools apt apt-libs armagetron arts ash aspell at atk attr
audiofile autoyast2-installation awesfx bash bc bind-utils binutils
bitstream-vera blueprint-cursor-theme bootsplash bootsplash-theme-SuSE bzip2
cabextract capi4linux cdk cdparanoia cdrdao cdrecord clanlib compat
coreutils cpio cpp cracklib cron cups cups-client cups-drivers
cups-drivers-stp cups-libs curl cyrus-sasl db desktop-data-SuSE devs dhcpcd
dialog diffutils dos2unix dosbootdisk dosfstools dvd+rw-tools e2fsprogs ed
eject enigma enscript esound ethtool expat fam fbset file filesystem fillup
filters findutils finger flash-player fontconfig foomatic-filters freetype2
fribidi frozen-bubble fvwm2 gail gawk gconf2 gdb gdbm gettext
ghostscript-fonts-other ghostscript-fonts-std ghostscript-library
ghostscript-x11 gle glib glib2 glibc glibc-locale gnome-filesystem
gnome-icon-theme gnome-mime-data gnome-vfs2 gpart gpgme gpm grep groff grub
gtk gtk2 guile gzip hdparm heimdal-lib hermes hotplug hotplugctl
hp-officeJet htdig hwinfo i4l-base i4l-isdnlog i4lfirm ifnteuro imlib
imwheel info info2html initviocons insserv intlfnts iproute2 iptables
iputils isapnp ispell ispell-american ispell-british ispell-italian itcl
iwidgets jack java2-jre jfsutils joe joystick k3b kaffeine kamix kbd
kde3-i18n-it kdeaddons3-kicker kdeartwork3-sound kdeartwork3-xscreensaver
kdebase3-kdm kdebase3-ksysguardd kdebase3-nsplugin kdegames3 kdegraphics3
kdegraphics3-fax kdegraphics3-postscript kdelibs3 kdemultimedia3 kdenetwork3
kdenetwork3-lisa kdenetwork3-news kdenetwork3-vnc kdepim3 kdepim3-kpilot
kdepim3-organizer kdeutils3 kdeutils3-laptop kdirstat kinternet knights
krecord ksymoops latex2html-pngicons less libacl libao libart_lgpl libattr
libavc1394 libbonobo libbonoboui libcap libdc1394 libdv libdvdnav libdvdread
libexif libgcc libgcj libgcrypt libgimpprint libglade2 libgnome
libgnomecanvas libgnomeui libgsf libgtkhtml libidl libjpeg libksba liblcms
libmal libmikmod libmng libmpeg3 libnetpbm libogg libpcap libpth libraw1394
librsvg libsndfile libstdc++ libstroke libtiff libungif libvorbis libxcrypt
libxml libxml2 libxslt liby2util lilo linc linux-atm-lib lirc logrotate lsof
lukemftp mad mailx man man-pages man-pages-it mdadm microcode_ctl mkinitrd
mkisofs mktemp modutils mtools myspell-italian ncurses net-tools netcat
netcfg nfs-utils normalize ntfsprogs openmotif-libs openssh openssh-askpass
openssl orbit2 pam pam-modules pango parted patch pciutils pcre pcsc-lite
perl perl-PDA-Pilot perl-XML-Parser perl-gettext phalanx pico pilot-link pin
pinentry pingus popt portmap postfix ppp pptp procmail providers qt3
readline recode reiserfs release-notes resmgr rpm rrdtool rsh sash scpm
screen scsi scummvm sed sensors setserial shadow siga sitar slang smpeg
smpppd speex src_vipa startup-notification strace sudo suse-build-key
suse-release susehelp susehelp_it suselinux-userguide_it sysconfig syslogd
sysvinit tar tcl tcpd tcpdump tcsh telnet terminfo tightvnc timezone
timidity tk unclutter unixODBC unzip usbutils util-linux v4l-conf vacation
vim vorbis-tools w3m wget wine wireless-tools words wvdial xanim xaw3d
xbanner xdg-menu xdmbgrd xf86tools xfsprogs xinetd xlockmore xmms xntp
xpenguins xscreensaver xtermset yast2 yast2-backup yast2-bootloader
yast2-control-center yast2-core yast2-country yast2-dhcp-server
yast2-dns-server yast2-firewall yast2-http-server yast2-inetd
yast2-installation yast2-kerberos-client yast2-ldap yast2-ldap-client
yast2-mail yast2-mail-aliases yast2-mouse yast2-ncurses yast2-network
yast2-nfs-client yast2-nfs-server yast2-nis-client yast2-nis-server
yast2-nisplus-client yast2-ntp-client yast2-online-update
yast2-packagemanager yast2-packager yast2-pam yast2-phone-services
yast2-powertweak yast2-printer yast2-profile-manager yast2-qt yast2-repair
yast2-restore yast2-runlevel yast2-samba-client yast2-samba-server
yast2-scanner yast2-security yast2-sound yast2-storage yast2-support
yast2-sysconfig yast2-tftp-server yast2-theme-SuSELinux yast2-trans-it
yast2-transfer yast2-tune yast2-tv yast2-update yast2-users yast2-x11
yast2-xml yp-tools ypbind zip ziptool zisofs-tools zlib zsh
The following packages will be REPLACED:
XFree86 (by xorg-x11) XFree86-Xvnc (by xorg-x11-Xvnc) XFree86-fonts-75dpi
(by xorg-x11-fonts-75dpi) XFree86-fonts-scalable (by
xorg-x11-fonts-scalable) XFree86-libs (by xorg-x11-libs) bonobo-activation
(by libbonobo) k_athlon (by kernel-default) kdenetwork3-mail (by kdepim3)
kgamma (by kdegraphics3) kopete (by kdenetwork3-InstantMessenger) kwintv
(by kdetv) lvm (by lvm2) mesaglut (by freeglut) ps (by procps) saxident
(by sax2-ident) ucdsnmp (by net-snmp) unrar (by rar) xine-lib (by
libxine1) xpmroot (by fvwm2)
Verranno ELIMINATI i seguenti pacchetti:
cryptplug digikam dirmngr gimp2 gimp2-svg gnomemeeting gphoto kdebase3-SuSE
kdebase3-samba kdegraphics3-kamera kdenetwork3-lan libgphoto2 libsmbclient3
libusb mc mesa newpg openct opensc sax2 saxtools
Saranno installati i seguenti pacchetti NUOVI:
EastWest XFree86-server-glx a2ps db41 device-mapper eazy evms flac freeglut
gnokii gnome-keyring id3lib kdenetwork3-InstantMessenger kdepim3-sync kdetv
kernel-default kio_slp libgpg-error libidn libjasper libsamplerate
libselinux libwmf libxine1 lvm2 net-snmp openslp perl-Config-Crontab
perl-Digest-SHA1 perl-TermReadKey procps pwlib-plugins-alsa
pwlib-plugins-avc rar sax2-ident shared-mime-info taglib udev wvstreams
xorg-x11 xorg-x11-Xvnc xorg-x11-fonts-75dpi xorg-x11-fonts-scalable
xorg-x11-libs yast2-perl-bindings yast2-slp zvbi
I seguenti pacchetti sono stati mantenuti
XFree86-Mesa XFree86-server autofs gpg kdeaddons3-kate kdeaddons3-konqueror
kdebase3 ldapcpplib openh323 openldap2-client pwlib samba-client
442 upgraded, 47 newly installed, 19 replaced, 21 removed and 12 not upgraded.
Need to get 0B/532MB of archives.
After unpacking 158MB of additional disk space will be used.
Vuoi proseguire? [S/n] s
Committing changes...
Preparing... ########################################### [100%]
file /opt/kde3/lib/kde3/gsthumbnail.la from install of kdegraphics3-3.2.91-3 conflicts with file from package kdebase3-3.1.4-48
file /opt/kde3/lib/kde3/gsthumbnail.so from install of kdegraphics3-3.2.91-3 conflicts with file from package kdebase3-3.1.4-48
file /opt/kde3/share/services/gsthumbnail.desktop from install of kdegraphics3-3.2.91-3 conflicts with file from package kdebase3-3.1.4-48
file /opt/kde3/lib/kde3/kcm_fileshare.la from install of kdenetwork3-3.2.91-2 conflicts with file from package kdebase3-3.1.4-48
file /opt/kde3/lib/kde3/kcm_fileshare.so from install of kdenetwork3-3.2.91-2 conflicts with file from package kdebase3-3.1.4-48
file /usr/X11R6/lib/modules/drivers/nvidia_drv.o from install of XFree86-server-glx-6.7.0-0 conflicts with file from package XFree86-server-4.3.0.1-21
file /usr/X11R6/lib/modules/extensions/libGLcore.a from install of XFree86-server-glx-6.7.0-0 conflicts with file from package XFree86-server-4.3.0.1-21
file /usr/X11R6/lib/modules/extensions/libglx.a from install of XFree86-server-glx-6.7.0-0 conflicts with file from package XFree86-server-4.3.0.1-21
file /usr/share/man/man3/getspnam.3.gz conflicts between attempted installs of man-pages-1.66-38 and shadow-4.0.3-191
file /usr/share/man/man5/passwd.5.gz conflicts between attempted installs of man-pages-1.66-38 and shadow-4.0.3-191
E: Error while running transaction
athlon:/home/ratatuia #

andy caps
09-07-2004, 14:29
dovresti provare a rimovere un po di robetta prima o fare un aggionamento per gradi

quelli che danno problemi sembrano essere

kdegraphics kdenetwork man-pages ed i driver nvidia


dovresi provare a rimuovere questi pacchetti prina di fare l'aggiornamento
anche con yast o con apt-get remove kdegraphics kdenetwork man-pages

Ratatuia
09-07-2004, 14:30
ok, ci provo... intanto grazie...

Ratatuia
09-07-2004, 14:34
ho tentato di fare i primi tre insieme e nulla...
quindi prima ho tolto man-pages
quando provo con kdenetwork ottengo qst:



athlon:/home/ratatuia # apt-get remove kdenetwork
Lettura della lista di pacchetti... Done
Calcolo dell'albero delle dipendenze... Done
Selecting kdenetwork3 for 'kdenetwork'
Verranno installati i seguenti pacchetti extra:
arts glibc glibc-locale kdelibs3 kdenetwork3-news libidn libjasper qt3
Verranno aggiornati i seguenti pacchetti
arts glibc glibc-locale kdelibs3 kdenetwork3-news qt3
Verranno ELIMINATI i seguenti pacchetti:
kdenetwork3 kdenetwork3-mail
Saranno installati i seguenti pacchetti NUOVI:
libidn libjasper
6 upgraded, 2 newly installed, 2 removed and 483 not upgraded.
Need to get 0B/33,5MB of archives.
After unpacking 7952kB of additional disk space will be used.
Vuoi proseguire? [S/n] S
Committing changes...
Preparing... ########################################### [100%]
file /opt/kde3/share/mimelnk/application/x-cue.desktop from install of kdelibs3-3.2.91-4 conflicts with file from package k3b-0.9.cvs20030901-35
file /opt/kde3/share/mimelnk/application/x-iso.desktop from install of kdelibs3-3.2.91-4 conflicts with file from package k3b-0.9.cvs20030901-35
file /opt/kde3/lib/libknewstuff.la from install of kdelibs3-3.2.91-4 conflicts with file from package kdepim3-3.1.4-45
file /opt/kde3/lib/libknewstuff.so.1.0.0 from install of kdelibs3-3.2.91-4 conflicts with file from package kdepim3-3.1.4-45
E: Error while running transaction
athlon:/home/ratatuia #

Ratatuia
09-07-2004, 14:47
anche kdegraphics me lo toglie senza problemi...

andy caps
09-07-2004, 15:02
togli anche kdepim
se hai problemi fallo con yast

Ratatuia
09-07-2004, 15:14
sono andato di yast...

Ratatuia
09-07-2004, 15:16
però ho ancora qst errore:



Preparing... ########################################### [100%]
file /usr/X11R6/lib/modules/drivers/nvidia_drv.o from install of XFree86-server-glx-6.7.0-0 conflicts with file from package XFree86-server-4.3.0.1-21
file /usr/X11R6/lib/modules/extensions/libGLcore.a from install of XFree86-server-glx-6.7.0-0 conflicts with file from package XFree86-server-4.3.0.1-21
file /usr/X11R6/lib/modules/extensions/libglx.a from install of XFree86-server-glx-6.7.0-0 conflicts with file from package XFree86-server-4.3.0.1-21
file /opt/kde3/lib/kde3/gsthumbnail.la from install of kdegraphics3-3.2.91-3 conflicts with file from package kdebase3-3.1.4-48
file /opt/kde3/lib/kde3/gsthumbnail.so from install of kdegraphics3-3.2.91-3 conflicts with file from package kdebase3-3.1.4-48
file /opt/kde3/share/services/gsthumbnail.desktop from install of kdegraphics3-3.2.91-3 conflicts with file from package kdebase3-3.1.4-48
E: Error while running transaction

Ratatuia
09-07-2004, 18:13
up...

Ratatuia
09-07-2004, 19:32
adesso sto facendo l'aggiornamento del sistema da yast con "Aggiornamento Sistema"...solo che deve scaricare 1.4 gb :dottò:

Loading