PDA

Visualizza la versione completa : mount pen drive usb


robi.c
13-07-2004, 15:11
Ciao ragazzi, ho una chiave usb2 da 256Mb della Kingston, ho installato la nuova Suse 9.1 e mi sono accorto che gi "montata" in /media/usb-storage-08C0F340F222C108:0:0:0p1 !!!

La cosa strana che in fstab non trovo nulla montato in quella directory se non le unit ottiche!?

E' sicuramente opera di Yast, ma forse qualcosa nel nuovo kernel 2.6 cambiata rispetto al 2.4 ??!!
Se si dove lo monta??



/dev/hda1 / reiserfs acl,user_xattr 1 1
/dev/hda5 /data1 auto noauto,user 0 0
/dev/hda6 /windows/C vfat users,gid=users,umask=0002,iocharset=utf8 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=ut f8 0 0
/dev/dvd /media/dvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=ut f8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0

flower
13-07-2004, 15:34
Se provi a fare un

cat /etc/mtab

trovi il dispositivo montato oppure no?

NewSlack
13-07-2004, 18:56
Non dovresti installare nessun driver (almeno per pendrive e dischi USB) ed in teoria una volta collegate le periferiche dovrebbero essere riconosciute in automatico.
Ad esempio se hai Slackware l'unica cosa che devi fare lanciare pkgtool e verificare di aver attivato l'hotplug

robi.c
13-07-2004, 21:18
Senza alcun driver d'accordo, ma automaticamente senza nemmeno un mount...ma da quando??!! booo

Ma il nuovo kernel 2.6.x che lavora in questo modo?

neryo
14-07-2004, 21:16
Originariamente inviato da robi.c
Senza alcun driver d'accordo, ma automaticamente senza nemmeno un mount...ma da quando??!! booo

Ma il nuovo kernel 2.6.x che lavora in questo modo?

allora...fai un

lsmod | grep usb

e dovresti avere un modulo chiamato usb-storage o usb_storage , se non ce l hai caricalo con

modprobe nomeModulo

poi..

con il comando fdisk guardi su che sd te l ha mappato...
ad esempio sulla mia suse 9.1 e' su sdb...



linux:/mnt/flashUSB # fdisk /dev/sdb

Command (m for help): p

Disk /dev/sdb: 131 MB, 131072000 bytes
5 heads, 50 sectors/track, 1024 cylinders
Units = cylinders of 250 * 512 = 128000 bytes

Device Boot Start End Blocks Id System

Command (m for help): q

linux:/mnt/flashUSB #


ora che sai su che device e'.. ti crei il mount point e dai il mount:


mount -t vfat /dev/sdb /mnt/flashUSB/

se hai problemi fammi sapere...

ola

Yuzadellenuvole
06-01-2005, 20:06
Salve a tutti ho la fedora core 3 ho appena messo la pen drive x montarla ma al momento di montarla mi dice questo:
il device speciale /dev/sda1 non esiste cosa devo fare?

ricciare
06-01-2005, 20:13
usa /dev/sda con fc3.

:ciauz:

Yuzadellenuvole
06-01-2005, 20:58
Niente da fare ho provato ma mi da lo stesso identico errore.......aiuto :dh: :dh: :dh: :dh: :confused: :confused:

ricciare
06-01-2005, 22:15
Hai provato anche a montarlo "manualmente" usando una finestra di terminale? crea una cartella flashpen nella cartella media e poi digita mount /dev/sda /media/flashpen.
Fammi sapere (adesso uso fc2 e questa soluzione funziona, ma domani o dopodomani rimettero' fc3).

Yuzadellenuvole
12-01-2005, 16:12
Rieccomi co sta maledetta pen drive ke ho cambiato xk era difettosa ma mi da sempre il solito errore ovvero "/dev/sda nn esiste" dando il comando da shell dmesg mi ha dato i seguenti errori
usb 1-1: new high speed USB device using ehci_hcd and address 4
usb 2-1: new full speed USB device using uhci_hcd and address 2
usb 2-1: device descriptor read/64, error -71
usb 2-1: device descriptor read/64, error -71
usb 2-1: new full speed USB device using uhci_hcd and address 3
usb 2-1: device descriptor read/64, error -71
usb 2-1: device descriptor read/64, error -71

Qualcuno sa dirmi cosa devo fare?Ho la Fedora core 3,Grazie!

Loading