PDA

Visualizza la versione completa : errore di apt, sono perso...


gianiaz
14-07-2004, 11:42
guardate:



root@dune:/home/gianiaz# apt-get install qmail
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Pacchetti suggeriti:
mutt mail-reader
I seguenti pacchetti NUOVI (NEW) saranno installati:
qmail
0 aggiornati, 1 installati, 0 da rimuovere e 210 non aggiornati.
5 non completamente installati o rimossi.
necessario prendere 0B/352kB di archivi.
Dopo l'estrazione, verranno occupati 1452kB di spazio su disco.
(Lettura del database ... 59804 file e directory attualmente installati.)
Spacchettamento di qmail (da .../qmail_1.03-25-khb1_i386.deb) ...
Unknown 'strict' tag(s) 'barewords' at /var/lib/dpkg/tmp.ci/preinst line 5
BEGIN failed--compilation aborted at /var/lib/dpkg/tmp.ci/preinst line 5.
dpkg: errore processando /var/cache/apt/archives/qmail_1.03-25-khb1_i386.deb (--unpack):
il sottoprocesso pre-installation script ha restituito un codice di errore 255
Sono occorsi degli errori processando:
/var/cache/apt/archives/qmail_1.03-25-khb1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)




root@dune:/home/gianiaz# apt-get -f install
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Correzione delle dipendenze in corso... Fatto
I seguenti pacchetti verranno inoltre installati:
courier-mta
I seguenti pacchetti NUOVI (NEW) saranno installati:
courier-mta
0 aggiornati, 1 installati, 0 da rimuovere e 210 non aggiornati.
5 non completamente installati o rimossi.
necessario prendere 0B/2068kB di archivi.
Dopo l'estrazione, verranno occupati 5845kB di spazio su disco.
Continuare? [S/n]
Preconfiguring packages ...
(Lettura del database ... 59804 file e directory attualmente installati.)
Spacchettamento di courier-mta (da .../courier-mta_0.45.6-1_i386.deb) ...
dpkg: errore processando /var/cache/apt/archives/courier-mta_0.45.6-1_i386.deb (--unpack):
tentata sovrascrittura di `/usr/bin/addcr', che si trova anche nel pacchetto ucspi-tcp
Sono occorsi degli errori processando:
/var/cache/apt/archives/courier-mta_0.45.6-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


non so che fare, tutti gli apt-get mi danno errori di dipendenze non soddisfatte....

mi date una mano?

francofait
14-07-2004, 11:51
Originariamente inviato da gianiaz
guardate:



root@dune:/home/gianiaz# apt-get install qmail
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Pacchetti suggeriti:
mutt mail-reader
I seguenti pacchetti NUOVI (NEW) saranno installati:
qmail
0 aggiornati, 1 installati, 0 da rimuovere e 210 non aggiornati.
5 non completamente installati o rimossi.
necessario prendere 0B/352kB di archivi.
Dopo l'estrazione, verranno occupati 1452kB di spazio su disco.
(Lettura del database ... 59804 file e directory attualmente installati.)
Spacchettamento di qmail (da .../qmail_1.03-25-khb1_i386.deb) ...
Unknown 'strict' tag(s) 'barewords' at /var/lib/dpkg/tmp.ci/preinst line 5
BEGIN failed--compilation aborted at /var/lib/dpkg/tmp.ci/preinst line 5.
dpkg: errore processando /var/cache/apt/archives/qmail_1.03-25-khb1_i386.deb (--unpack):
il sottoprocesso pre-installation script ha restituito un codice di errore 255
Sono occorsi degli errori processando:
/var/cache/apt/archives/qmail_1.03-25-khb1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)




root@dune:/home/gianiaz# apt-get -f install
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Correzione delle dipendenze in corso... Fatto
I seguenti pacchetti verranno inoltre installati:
courier-mta
I seguenti pacchetti NUOVI (NEW) saranno installati:
courier-mta
0 aggiornati, 1 installati, 0 da rimuovere e 210 non aggiornati.
5 non completamente installati o rimossi.
necessario prendere 0B/2068kB di archivi.
Dopo l'estrazione, verranno occupati 5845kB di spazio su disco.
Continuare? [S/n]
Preconfiguring packages ...
(Lettura del database ... 59804 file e directory attualmente installati.)
Spacchettamento di courier-mta (da .../courier-mta_0.45.6-1_i386.deb) ...
dpkg: errore processando /var/cache/apt/archives/courier-mta_0.45.6-1_i386.deb (--unpack):
tentata sovrascrittura di `/usr/bin/addcr', che si trova anche nel pacchetto ucspi-tcp
Sono occorsi degli errori processando:
/var/cache/apt/archives/courier-mta_0.45.6-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


non so che fare, tutti gli apt-get mi danno errori di dipendenze non soddisfatte....

mi date una mano?

apt-get -f install
dpkg --configure -a

virusbye
14-07-2004, 11:52
apt-get update
cd /var/cache/apt/archives/

poi dai questi comandi

dpkg --force-all -i nomepacchetto.deb
apt-get -f install
apt-get dist-upgrade
aptitude -f install

fino a quando non risolvi il problema

gianiaz
14-07-2004, 11:56
grazie virusbye, dando il dpkg--force-all ho risolto.

ciau!

grazie anche a te franco, ma cosi avevo provato senza risolvere...

Loading