PDA

Visualizza la versione completa : Help per mount


epix
14-07-2004, 20:46
Ciao a tutti,
sono appena approdato a Linux installando Mandrake 10.0 Official.

Nella home di root sono riuscito a "creare" i dispositivi montati, vederne le normali icone e li utilizzo regolarmente.

/dev/hda6 on /home type ext3 (rw)
/dev/hdc1 on /mnt/win_c type vfat (rw,iocharset=iso8859-15,codepage=850)
/dev/hdd1 on /mnt/win_c2 type vfat (rw,iocharset=iso8859-15,codepage=850)
/dev/hdg1 on /mnt/win_c3 type vfat (rw,iocharset=iso8859-15,codepage=850)
/dev/hdb on /mnt/cdrom type iso9660 (ro,nosuid,nodev,iocharset=iso8859-15,codepage=850)

Il problema sorge quando mi loggo come user.
Non mi riesce di montarle, e la risposta è:
Il file o la cartella /mnt/cdrom non esiste.

E' chiaro che dipende dalle autorizzazioni. :dhò:
Mi aiutate?
Grazie a tutti per l'umana comprensione :incupito:

andy caps
14-07-2004, 21:21
se hai fatto le dir da root prova a dargli i permessi anche click destro > proprieta
controlla anche con esattezza i nomi delle dir
altrimenti prova a mettere queste opzioni in fstab

vfat user,owner,exec,auto,umask=000,rw 0 0


per il cdrom metti quelle di default

/dev/hdb /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0

andy caps
14-07-2004, 21:23
per le partizioni fat da se mette

/dev/hdxx /mnt/windows vfat umask=0,iocharset=iso8859-15,codepage=850 0 0

adatta fstab con queste opzioni

epix
15-07-2004, 16:12
Originariamente inviato da andy caps
se hai fatto le dir da root prova a dargli i permessi anche click destro > proprieta
controlla anche con esattezza i nomi delle dir
altrimenti prova a mettere queste opzioni in fstab

vfat user,owner,exec,auto,umask=000,rw 0 0


per il cdrom metti quelle di default

/dev/hdb /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0

Ciao andy caps e grazie per la risposta.
In questo momento sono in ufficio e non posso fare quello che mi hai suggerito, lo farò al mio ritorno a casa.

/dev/hdc1 on /mnt/win_c type vfat (rw,iocharset=iso8859-15,codepage=850)
/dev/hdd1 on /mnt/win_c2 type vfat (rw,iocharset=iso8859-15,codepage=850)
/dev/hdg1 on /mnt/win_c3 type vfat (rw,iocharset=iso8859-15,codepage=850)

sono "native" windows e contengono solo "dati"; da root non ho creato alcuna directory.
In pratica ho semplicemente installato su un HD vergine Linux perchè mi ha sempre affascinato ed è più "robusto".
L'installazione MDK 10.0 l'ho fatta con protezione "più alta" ed in fase di installazione sono stato avvisato che le partizioni/unità windows sarebbero state viste solo da root.
Non me ne sono preoccupato troppo perchè ho ritenuto che root avrebbe potuto, in seguito, concedere autorizzazione. :confused:

Ma questa è solo "accademia" :D
Appena a casa faccio delle prove e... spero vada tutto bene.
Grazie e ti/vi faccio sapere.

epix
15-07-2004, 20:46
:dhò: :dhò:
Rieccomi... ho modificato fstab così:
/dev/hdc1 /mnt/win_c vfat user,owner,exec,auto,umask=000,rw 0 0

ma... niente.
Da user mi riesce di creare un nuovo dispositivo -> disco rigido -> /dev/hdc1 )(mnt/win_c) ma quando ci clicco su mi risponde:
Il file o la cartella /mnt/win_c non esiste.

Ma in mnt, win_c c'è.

il CDROM, invece, va che è una meraviglia...

Boooo!

andy caps
15-07-2004, 20:53
se hai impostato i livelli di sicurezza alti tutto quello che è di proprieta di root non esiste
digita
su
in una consolle metti la password di root e scrivi konqueror poi prova a dare i permessi alle dir in /mnt

epix
15-07-2004, 21:50
Grazie andy caps...
forse mi ero spinto un pò oltre impostando sicurezza "più alta".
Ho formattato e reinstallato MDK... ora ma tutto che è una meraviglia.
Pian pianino, con il tuo/vostro aiuto, inizierò a capire qualcosina di questo GRANDE SO.

Grazie ancora... corro a leggere un po di howto.
TNKs! :smack:

Loading