PDA

Visualizza la versione completa : Adduser


cicciobaliccio
15-07-2004, 09:40
E' possibile aggiungere utenti da un file di testo semplicemente con il comando adduser?

gianiaz
15-07-2004, 09:42
intendi dare in pasto al comando adduser un file di testo che contenga i nomi utenti?

cicciobaliccio
15-07-2004, 09:43
si

gianiaz
15-07-2004, 10:14
non conosco a memoria tutte le flag del comando adduser, ma se metti in un file l'elenco degli utenti:

basta dare da shell questo comando:



for i in `cat listautenti`; do adduser $i; done


praticamente fa un ciclo nel contenuto del file, e per ogni nome inserito esegue il comando adduser.
Naturalmente vorrai aggiungere tutte le opzioni del caso...


:ciauz:

cicciobaliccio
15-07-2004, 10:18
Grazie!
altra cosa di useradd

se scrivo questo comando

useradd -d /home/nuovo -m -k /etc/skel -p password nomenuovo

mi aggiunge effettivamente l'utente ma poi quando mi voglio loggare non mi fa entrare!
perch?!

gianiaz
15-07-2004, 10:22
dalla pagina man di adduser:


A home directory is created by the same rules as for normal users. The
new system user will have the shell /bin/false (unless overridden with
the --shell option), and have a disabled password. Skeletal configura-
tion files are not copied.


vuol dire che quando crei un utente, di default avrai un utente senza shell, e quindi senza l'accesso al sistema da console.
Se controlli il tuo file /etc/passwd vedrai qualcosa del genere per il tuo utente appena creato:


gdm:x:101:104:Gnome Display Manager:/var/lib/gdm:/bin/false

mentre qualcosa del genere per root:


gianiaz:x:1000:1000:Debian User,,,:/home/gianiaz:/bin/bash

vedi la differenza?
gdm ha /bin/false
mentre gianiaz /bin/bash


:ciauz:

cicciobaliccio
15-07-2004, 10:25
grazie gianiaz!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
sei un grande!!!!!!!! :D

gianiaz
15-07-2004, 10:32
addirittura :biifu:

grazie :fighet:

cicciobaliccio
15-07-2004, 10:34
:nonono:

ritiro tutto :D

allora quando creo l'utente con il comando sopra la shell che gli d di default /bin/bash

sto usando una mandrake ma anche cn la red hat faceva la stessa cosa
utente nuovo e di default bin bash

se con root apro direttamente /etc/passwd nell'ultimo campo ho la shell impostata a /bin/bash e non a /bin/false

il /bin/false dove lo vedo scusa nn ho capito io mi sa :D

cicciobaliccio
15-07-2004, 10:46
bho nn riesco :dh:

Loading