PDA

Visualizza la versione completa : [java] applet compilate non visualizzate in IE


Cozza
15-07-2004, 23:20
allora il problema è questo: se io creo un applet anche semplicissima tipo 'ciao mondo' e la eseguo col comando appletviewer funziona
mentre se la richiamo dal browser vedo solo un quadrato grigio, ma questo
mi succede solo con le applet che compilo io, se invece mi scarico il .class
di uno degli esempi di html.it e lo richiamo dal browser funzica quindi non è un problema di browser

ah se vado col mouse nel riquadro grigio, sulla statusbar vedo il messaggio 'class miaclasse not found' ma mi sembra una caxxata i file sono tutti nella stessa directory esattamente come quelli delle applet che scarico :messner:

ah la stessa cosa mi succede sia sul PC che sul portatile :dottò:

I don't capisc :bhò:

keratox
15-07-2004, 23:30
Succedeva anche a me..
mi notifico alla discussione...
chissà se non risolvo anch'io
:fagiano:

MMarzia
16-07-2004, 08:45
cozza, ho modificato il titolo , inserendo il linguaggio e rendendolo meno generico

la prossima volta però pensaci tu

Oiziorbaf
16-07-2004, 18:20
Originariamente inviato da Cozza
allora il problema è questo: se io creo un applet anche semplicissima tipo 'ciao mondo' e la eseguo col comando appletviewer funziona
mentre se la richiamo dal browser vedo solo un quadrato grigio, ma questo
mi succede solo con le applet che compilo io, se invece mi scarico il .class
di uno degli esempi di html.it e lo richiamo dal browser funzica quindi non è un problema di browser

ah se vado col mouse nel riquadro grigio, sulla statusbar vedo il messaggio 'class miaclasse not found' ma mi sembra una caxxata i file sono tutti nella stessa directory esattamente come quelli delle applet che scarico :messner:

ah la stessa cosa mi succede sia sul PC che sul portatile :dottò:

I don't capisc :bhò:

Ankio avevo lo stesso problema....prova a inserirle con programmi come front page o dreamweawer, e poi dai un'altezza e un larghezza...così dovrebbe andare!

nella pagina html devi inserire l'apposito tag cioè:


<applet code="nome classe" width=larghezza height=altezza> </applet>

:ciauz:

Cozza
16-07-2004, 22:37
Originariamente inviato da Oiziorbaf
Ankio avevo lo stesso problema....prova a inserirle con programmi come front page o dreamweawer, e poi dai un'altezza e un larghezza...così dovrebbe andare!

nella pagina html devi inserire l'apposito tag cioè:


<applet code="nome classe" width=larghezza height=altezza> </applet>

:ciauz:

faccio già così , altrimenti non mi fuzionerebbero neanche quelle non compilate da me :madai!?:

comunque grazie concittadino :zizi:

Oiziorbaf
17-07-2004, 09:21
Anke tu di como??? WOW!!! di dove precisamente????
Cmq è strano ke se te le compila in modo corretto dopo nn funzioni... :confused:

Bo cmq forza COMO :unz:

I'mtheleader
18-07-2004, 09:38
Stesso problema anche a me... io adesso i class li creo con il Visual J++.. :unz:

krakovia
19-07-2004, 10:24
1. con cosa compili i class?
2. perchè non posti un po 'di codice? (sia HTML che JAVA a qs punto)

Loading