PDA

Visualizza la versione completa : Installazione Pen USB


markus007
18-07-2004, 21:12
Ragazzi, rieccomi con il solito tormentone della pen drive. :D

Questa volta il problema diverso:
dando mount -t vfat /dev/sda4 /mnt/pendrive, che prima di formattare ha funzionato alla grande, con la stessa pendrive adesso mi da:
/dev/sda4 is not a valid block device

Non riesco a capire se realmente la pen drive sia stata riconosciuta e se sia su sda1, sda4, sdb3 e chi pi ne ha pi ne metta.

Ho letto in giro che a volte necessario anche il modulo sd_mod, ma ecco il mio output:
modprobe sd_mod
Can't locate module sd_mod

Inoltre con lsmod usb-storage risulta installato ma tra parentesi mi da UNUSED. Che vuol dire? :master:

Ho una debian sid, se volete vedere altri listati non ci sono problemi, basta che risolva il problema! :yuppi:

McGuolo
18-07-2004, 23:34
Da quanto mi e' stato detto da fonte autorevole sda4 e' un errato partizionamento di alcune chiavette (anche la mia si vedeva li'); poi dopo la seconda formattazione e' finita in sda1. Se vuoi vedere dove sta, dai un ls -hl /dev/sda*. Cosi' vedi quale dispositivo sd* e' il link al tuo device (mi sono spiegato male, lo so... ma tra i file che vengono listati dovrebbe esserci un link). Naturalmente la chiavetta deve essere inserita.

markus007
19-07-2004, 01:47
Mi sa che la pen drive non viene riconosciuta.
Ecco cosa mi d il comando # ls -hl /dev/sda*

brw-rw---- 1 root disk 8, 0 Mar 14 2002 /dev/sda
brw-rw---- 1 root disk 8, 1 Mar 14 2002 /dev/sda1
brw-rw---- 1 root disk 8, 10 Mar 14 2002 /dev/sda10
brw-rw---- 1 root disk 8, 11 Mar 14 2002 /dev/sda11
brw-rw---- 1 root disk 8, 12 Mar 14 2002 /dev/sda12
brw-rw---- 1 root disk 8, 13 Mar 14 2002 /dev/sda13
brw-rw---- 1 root disk 8, 14 Mar 14 2002 /dev/sda14
brw-rw---- 1 root disk 8, 15 Mar 14 2002 /dev/sda15
brw-rw---- 1 root disk 8, 2 Mar 14 2002 /dev/sda2
brw-rw---- 1 root disk 8, 3 Mar 14 2002 /dev/sda3
brw-rw---- 1 root disk 8, 4 Mar 14 2002 /dev/sda4
brw-rw---- 1 root disk 8, 5 Mar 14 2002 /dev/sda5
brw-rw---- 1 root disk 8, 6 Mar 14 2002 /dev/sda6
brw-rw---- 1 root disk 8, 7 Mar 14 2002 /dev/sda7
brw-rw---- 1 root disk 8, 8 Mar 14 2002 /dev/sda8
brw-rw---- 1 root disk 8, 9 Mar 14 2002 /dev/sda9


A quanto pare sono tutti vuoti, e la pen drive ovviamente inserita! :madai!?:

Mi sa che un problema di porte usb.

Ecco invece cosa mi d con lsmod:
Module Size Used by Not tainted
soundcore 3236 0 (autoclean)
keybdev 1664 0 (unused)
sg 24452 0 (unused)
ide-scsi 7488 0
usbkbd 2848 0 (unused)
input 3072 0 [keybdev usbkbd]
usb-storage 97152 0 (unused)
usb-uhci 20708 0 (unused)
usbcore 48032 0 [usbkbd usb-storage usb-uhci]


Cosa non va??? :dh:

gianiaz
19-07-2004, 09:18
hai abilitato il supporto per hotplug?
i dati che hai dato fin'ora non servono molto alla risoluzione del problema...

ciao

markus007
19-07-2004, 10:33
Come si abilita il supporto per hotplug? :master:

gianiaz
19-07-2004, 10:39
compilando il kernel.

markus007
19-07-2004, 10:41
Si, lo stavo leggendo proprio adesso in giro.
Ma guarda un p, non ho l'idea di come si compila il kernel! :oVVoVe:

Magari se mi passassi qualche suggerimento potrei provarci, forse pi facile di quanto mi immagini...

Loading