PDA

Visualizza la versione completa : boot.ini


Ranma2
22-07-2004, 21:41
Vorrei far partire il mio Linux Red Hat 9.0 dal boot.ini, premettendo che non ho installato ne GRUB ne lilo, ho proceduto nel seguente modo

dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1

dove hda2 Ŕ la partizione con linux, ma mi sono chiesto, non avendo installato il Lilo potrebbe non funzionare, quindi

dd if=/dev/fd0 of=/bootsect.lny bs=512 count=1

ho preso i due file e li ho inseriti in una partizione fat32 (vfat) precedentemente montata

Ho avviato windows e ho modificato il boot.ini aggiungendo queste due righe alla fine del file

C:\BOOTSECT.LNX="Linux"
C:\BOOTSECT.LNY="Linux"

Riavvio il sistema e provo con la prima opzione, nessuna risposta, solo una schermata nera

Riavvio il sistema e provo la seconda opzione, e mi da una schermata nera con scritto "Boot Failed"

Dove sta il problema?

Ranma2
22-07-2004, 23:48
up

sathia
22-07-2004, 23:51
non so.
ma posso chiederti come mai hai ucciso lilo o grub?

Ranma2
22-07-2004, 23:54
Originariamente inviato da sathia
non so.
ma posso chiederti come mai hai ucciso lilo o grub?

non li ho uccisi, non li ho installati durante l'installazione del S.O.

sathia
22-07-2004, 23:56
ah capisco:

posso chiederti come mai non li hai installati?

Ranma2
22-07-2004, 23:57
Originariamente inviato da sathia
ah capisco:

posso chiederti come mai non li hai installati?

in quanto faccio partire il tutto da floppy

sathia
22-07-2004, 23:59
ah.

e come mai?

non ti sta simpatico mbr?

Ranma2
23-07-2004, 00:00
Originariamente inviato da sathia
ah.

e come mai?

non ti sta simpatico mbr?

volevo evitare futuri casini, essendo bravo a crearli

sathia
23-07-2004, 00:01
ma no, guarda, mbr Ŕ tuo amico.

in ogni caso, qualsiasi minchiata tu riesca a fare un buon disco d'avvio ti permette di usare


fdisk /mbr



e automagicamente tutto tornerÓ come era prima

Loading