PDA

Visualizza la versione completa : Beep che va solo in x!!


skyblaze
27-07-2004, 00:44
Da quando ho messo slack con kernel 2.6.7 ho notato che il beep(segnale acustico) funge solo in x mentre in bash non emette nessun suono. Avendo un portatile il beep emesso dalle casse tramite la sk sonora......ma se in x funge con gli alsa non vedo perche non debba andare in shell. Ho anche controllato in /etc/inputrc il valore di set-bell e come di default commentato il set-bell none quindi dovrebbe andare ma invece non si sente niente.

adarkar
27-07-2004, 00:59
setterm -blength 10
?

skyblaze
27-07-2004, 01:12
Originariamente inviato da adarkar

setterm -blength 10
? niente e la stessa cosa se provo a farla suonare con echo + il carattere di escape giusto.

Sergio Pedone
27-07-2004, 09:23
prova a forzare il beep:
set bell-style audible

Poi non so, non ho altre idee al momento.

ciao.

skyblaze
27-07-2004, 09:30
Originariamente inviato da Sergio Pedone
prova a forzare il beep:
set bell-style audible

Poi non so, non ho altre idee al momento.

ciao. gia provato anche quello :bh:

Ilmalcom
27-07-2004, 10:27
Provato a farlo emettere tramite pc speaker?

skyblaze
27-07-2004, 11:48
Originariamente inviato da Ilmalcom
Provato a farlo emettere tramite pc speaker? in che senso scusa? :master:
Non mi risulta ci sia lo speaker.... per questo che usa le casse no?

Ilmalcom
27-07-2004, 14:26
Originariamente inviato da skyblaze
in che senso scusa? :master:
Non mi risulta ci sia lo speaker.... per questo che usa le casse no?
Device drivers -> Input device support -> Misc -> PC Speaker support

Cos a me il beep lo fa con le casse spente ed anche senza X

skyblaze
27-07-2004, 14:44
Originariamente inviato da Ilmalcom
Device drivers -> Input device support -> Misc -> PC Speaker support

Cos a me il beep lo fa con le casse spente ed anche senza X allora forse avevo bevuto perche riprovando lo speaker non va manco in x. Ho provato a caricare quel modulo pcspkr ed effettivamente poi lo speaker funziona e addirittura va con il vuolume del portatile quindi se metto al minimo nonsi sente per niente. Il fatto che mi ricordo con il 2.4.x il suono era migliore quindi sicuramente la usava la sk sound. Sicuramente ci sara qualche modulo da usare che nella config del 2.4.x avevo statico per far funzionare il beep con la sk sound....ma mo vallo a trovare nella config del 2.6.x :biifu:

skyblaze
27-07-2004, 14:46
ma LOL...proprio mentre premevo sul bottone reply mi sono accorto che ricaricando il modulo pcspkr ora il beep con la sk audio va perfettamente sia in x che in shell...l'unica modifica che ho fatto stato mettere in on in alsamixer lo speaker :dh: :biifu:

Loading