PDA

Visualizza la versione completa : gnome 2.6 tastiera


xegallo
27-07-2004, 15:59
non mi funzia la terza funzione del tasto in ambiente X :cry:
successo dopo un etc-update che ho combinato

andy caps
27-07-2004, 16:14
ricontrolla /etc/rc.conf rimetti la tastiera italiana e prova qualche opzione

io ho cosi
KEYMAP="it"

# Should we first load the 'windowkeys' console keymap? Most x86 users will
# say "yes" here. Note that non-x86 users should leave it as "no".

SET_WINDOWKEYS="no"

# The maps to load for extended keyboards. Most users will leave this as is.

EXTENDED_KEYMAPS=
#EXTENDED_KEYMAPS="backspace keypad"

# CONSOLEFONT specifies the default font that you'd like Linux to use on the
# console. You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).

CONSOLEFONT="default8x16"

xegallo
27-07-2004, 22:32
no il file rc.conf ok secondo me c' qualche problemino coi file di configurazione di X o gnome

andy caps
27-07-2004, 22:44
se fuori da x va allora devi provare con i tool di gnome o i vari file di gnome in etc
io sono gnomallergico :bh:

xegallo
27-07-2004, 23:27
per chi ha gnome pu postare il risualtato di
gconftool-2 -R /desktop/gnome/peripherals/keyboard


questo il mio


gconftool-2 -R /desktop/gnome/peripherals/keyboard
click_volume = 0
click = true
repeat = true
rate = 30
bell_custom_file = (valore non impostato)
delay = 500
bell_pitch = 400
bell_mode = on
bell_duration = 100
/desktop/gnome/peripherals/keyboard/xkb:
layouts = [it,us]
model = pc101
overrideSettings = false
options = []

andy caps
27-07-2004, 23:37
prova a mettere model = pc104 mentre aspetti
con debian risolveva in alcuni casi

gio14
28-07-2004, 00:30
click_volume = 0
click = true
repeat = true
rate = 30
bell_custom_file = (valore non impostato)
delay = 500
bell_pitch = 400
bell_mode = on
bell_duration = 100
/desktop/gnome/peripherals/keyboard/xkb:
layouts = [it]
model = pc105
overrideSettings = false
options = []

xegallo
28-07-2004, 20:26
adesso mi da questo errore


Errore durante l'attivazione della configurazione XKB.
Probabilmente a causa di un problema interno al server X.

Informazioni sulla versione del server X:
Gentoo Linux (XFree86 4.3.0, revision r6)
40300001

Se si riporta questo problema come baco includere i risultati dei seguenti comandi:
- xprop -root | grep XKB
- gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb


ma che comando xprop?

Caleb
28-07-2004, 20:33
http://www.xfree86.org/current/xprop.1.html

andy caps
28-07-2004, 21:04
xprop ho visto che dice solamente i settaggi che hai

a me ad esempio dice

root@localhost andy]# xprop -root | grep XKB
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "it", "", ""

provato a mettere 104 o 105 tasti ?

Loading