PDA

Visualizza la versione completa : kernel panic: vfs: unable to mount root fs on 02:20


sopadj1
31-07-2004, 11:56
ho appena finito di installare la slack 10, da lilo seleziono di far partire linux, il boot inizia a lavorare...poi si ferma e mi chiede:

vfs: insert root floppy and press enter :confused: :confused: :confused:

che devo inseri'????????????

che intende per root floppy???e perk mi chiede di insterirlo????

allora ho provato a inserire il floppy di avvio che ho fatto durante l'installazione (certe pensate....:yuppi: ) e ho premuto enter ma mi esce sempre lo stesso errore, sia con inserito il floppy sia senza:


vfs: cannot open root device "202" or 02:20

please append a correct "root=" boot option

kernel panic: vfs : unable to mount root fs on 02:20


qualcuno sa dirmi cosa successo perke' sto piu' inpanicato io che il kernel :D

KornShell
31-07-2004, 12:06
in lilo.conf non hai messo la riga in cui gli dici dov'e' la root

root = /dev/hdxx

sopadj1
31-07-2004, 12:10
ma se non me lha kiesto...... :dh: quando mi chideva di installare lilo in modalita' esperto o normale io ho scelto quello normale e non mi ha mica chiesto questa cosa....e se me lho a kiesto non ci ho fatto caso....ho il folletto di mia madre attaccato all'orecchio e non riesco tanto a ragionare :oVVoVe:....ora come posso risolvere.....

grazie

KornShell
31-07-2004, 12:13
ora devi partire con il cd o con il floppy (se l'hai fatto) in rescue mode.
editare lilo.conf e sistemarlo, poi lanciare lilo -v e fare reboot.

sopadj1
31-07-2004, 12:15
ok...capito..ma a cosa server lilo -v ???

sopadj1
31-07-2004, 12:27
.... e lilo.conf dov'? non riesco a trovarlo

francofait
31-07-2004, 12:29
Originariamente inviato da sopadj1
.... e lilo.conf dov'? non riesco a trovarlo

/etc/lilo.conf

KornShell
31-07-2004, 12:31
Originariamente inviato da sopadj1
ok...capito..ma a cosa server lilo -v ???

lilo -v + importantissimo
scrive la nuova configurazione del boot loader nell'mbr
se non lo fai dopo aver cambiato lilo.conf ti ritrovi con un'altro kernel panic...

sopadj1
31-07-2004, 12:43
bhe non lo trovo... scusate l'ignoranza ma la prima volta che mi trovo davanti a questo problema, come faccio a far partire slack in modalita' rescue usando il cd...?
fin ora lo fatto il boot dal cd e poi ho digitato


boot: bare.i root=/dev/hda6

a qualcosa di simile... corretto fare cosi????

grazie

francofait
31-07-2004, 12:50
Originariamente inviato da sopadj1
bhe non lo trovo... scusate l'ignoranza ma la prima volta che mi trovo davanti a questo problema, come faccio a far partire slack in modalita' rescue usando il cd...?
fin ora lo fatto il boot dal cd e poi ho digitato


boot: bare.i root=/dev/hda6

a qualcosa di simile... corretto fare cosi????

grazie

No devi digitare

boot: linux root=/dev/hda6

se la tua partiz. / dove hai Slackware /dev/hda6

bare.i rilancia la procedura di installazione , non avvia il SO gi installato.

Loading