PDA

Visualizza la versione completa : Modem ethernet,strano TIMEOUT


alby89
10-08-2004, 13:37
Ciao a tutti,ho un problema.da domenica non mi v pi la connessione su linux,col modem ethernet.
Domenica,ho staccato il pc,e lo ho portato da un amico,per giocare,sono tornato a casa,ho riattacato il pc,accendo il pc,linux,e poi.....TIMEOUT! :cry:
Ecco i risultati da shell:


root@mshome:/home/alby#adsl-start................TIMED OUT
/usr/sbin/adsl-start: line 194: 791 Terminated $CONNECT "$@" >/d v/null 2>&1



e

root@mshome:/home/alby# adsl-connect
eth0: unknown interface: No such device
SIOCSIFMTU: No such device
/usr/sbin/adsl-connect: line 16: ipchains: command not found
/usr/sbin/adsl-connect: line 17: ipchains: command not found
/usr/sbin/adsl-connect: line 18: ipchains: command not found
/usr/sbin/adsl-connect: line 20: ipchains: command not found
/usr/sbin/adsl-connect: line 21: ipchains: command not found
/usr/sbin/adsl-connect: line 22: ipchains: command not found
/usr/sbin/adsl-connect: line 25: ipchains: command not found
/usr/sbin/adsl-connect: line 26: ipchains: command not found
/usr/sbin/adsl-connect: line 29: ipchains: command not found
/usr/sbin/adsl-connect: line 32: ipchains: command not found
/usr/sbin/adsl-connect: line 35: ipchains: command not found
/usr/sbin/pppd: This system lacks kernel support for PPP. This could be because
the PPP kernel module could not be loaded, or because PPP was not
included in the kernel configuration. If PPP was included as a
module, try `/sbin/modprobe -v ppp'. If that fails, check that
ppp.o exists in /lib/modules/`uname -r`/net.
See README.linux file in the ppp distribution for more details.

:master: Cosa devo fare??

[]v[]aStEr
10-08-2004, 13:56
Prova a fare quello che ti dice il msg d'errore
dai modprobe -v ppp per vedere se ti carica il modulo ppp
Altrimenti prova a vedere se il modulo in questione stato compilato. Lo trovi in /lib/modules/tuokernel/net
Se c' ppp.o vuol dire che il modulo stato compilato, altrimenti preparati ad una ricompilazione del kernel :D

francofait
10-08-2004, 13:59
Originariamente inviato da alby89
Ciao a tutti,ho un problema.da domenica non mi v pi la connessione su linux,col modem ethernet.
Domenica,ho staccato il pc,e lo ho portato da un amico,per giocare,sono tornato a casa,ho riattacato il pc,accendo il pc,linux,e poi.....TIMEOUT! :cry:
Ecco i risultati da shell:


root@mshome:/home/alby#adsl-start................TIMED OUT
/usr/sbin/adsl-start: line 194: 791 Terminated $CONNECT "$@" >/d v/null 2>&1



e

root@mshome:/home/alby# adsl-connect
eth0: unknown interface: No such device
SIOCSIFMTU: No such device
/usr/sbin/adsl-connect: line 16: ipchains: command not found
/usr/sbin/adsl-connect: line 17: ipchains: command not found
/usr/sbin/adsl-connect: line 18: ipchains: command not found
/usr/sbin/adsl-connect: line 20: ipchains: command not found
/usr/sbin/adsl-connect: line 21: ipchains: command not found
/usr/sbin/adsl-connect: line 22: ipchains: command not found
/usr/sbin/adsl-connect: line 25: ipchains: command not found
/usr/sbin/adsl-connect: line 26: ipchains: command not found
/usr/sbin/adsl-connect: line 29: ipchains: command not found
/usr/sbin/adsl-connect: line 32: ipchains: command not found
/usr/sbin/adsl-connect: line 35: ipchains: command not found
/usr/sbin/pppd: This system lacks kernel support for PPP. This could be because
the PPP kernel module could not be loaded, or because PPP was not
included in the kernel configuration. If PPP was included as a
module, try `/sbin/modprobe -v ppp'. If that fails, check that
ppp.o exists in /lib/modules/`uname -r`/net.
See README.linux file in the ppp distribution for more details.

:master: Cosa devo fare??

A quanto sembra non ti riconosce l' ethernet , riconfigurala.
Oppure prima prova a togliere x un attimo lo spinotto d' alimentazione al ruter-modem , se solo disallineamento ,
col il suo riavvio risolvi.

alby89
10-08-2004, 14:09
Originariamente inviato da francofait
A quanto sembra non ti riconosce l' ethernet , riconfigurala.
Oppure prima prova a togliere x un attimo lo spinotto d' alimentazione al ruter-modem , se solo disallineamento ,
col il suo riavvio risolvi.
Lo ho gi provato :cry:
Ho provato altri comandi:

root@mshome:/home/alby# modprobe via-rhine
modprobe: Can't locate module via-rhine
root@mshome:/home/alby# ifconfig eth0 up
eth0: unknown interface: No such device
root@mshome:/home/alby#

andy caps
10-08-2004, 14:36
dai un occhiata in /lib/modules// come dice il messaggio se i moduli ci sono
sembra che il pasticcio sia li

se tu ricompilassi il kernel risolveresti subito

alby89
10-08-2004, 14:39
Originariamente inviato da andy caps
dai un occhiata in /lib/modules// come dice il messaggio se i moduli ci sono
sembra che il pasticcio sia li

se tu ricompilassi il kernel risolveresti subito
:rollo:
Vado a vedere in lib/modules

alby89
10-08-2004, 15:00
ecco il risultato :cry:
in /lib/modules/2.4.22/kernel/drivers/net ho trovato un file dummy.o
poi:

root@mshome:/home/alby# modprobe -v ppp
modprobe: Can't locate module ppp


root@mshome:/home/alby# modprobe -vppp

modprobe: invalid option -- p
modprobe: invalid option -- p

modprobe: invalid option -- p
modprobe 2.4.25
Load/Unload modules with dependencies


Load module(s):

modprobe [-a -n -v ] [-C config ] [ -t type ] pattern OR module1 module2 ...

List modules:

modprobe [-l ] [-C config ] [ -t type ] pattern

note: wildcard patterns should be escaped

Show configuration:
modprobe [-C config ] -c

Remove module(s) or autoclean:

modprobe [-C config ] -r [ module ...]


options:

-a, --all Load _all_ matching modules

-c, --showconfig Show current configuration

-d, --debug Print debugging information

-h, --help Print this message

-k, --autoclean Set 'autoclean' on loaded modules

-l, --list List matching modules

-n, --show Don't actually perform the action

-q, --quiet Quiet operation

-r, --remove Remove module (stacks) or do autoclean

-s, --syslog Use syslog to report

-t, --type moduletype Only look for modules of this type

-v, --verbose Print all commands

-V, --version Show version

-C, --config configfile Use instead of /etc/modules.conf


:master:

[]v[]aStEr
10-08-2004, 15:03
Devi ricompilarti il kernel :ciauz:

alby89
10-08-2004, 15:06
Originariamente inviato da []v[]aStEr
Devi ricompilarti il kernel :ciauz:
Ma nooooo.Non c altro modo?? :rollo:

andy caps
10-08-2004, 15:07
se hai fatto uno spegnimento violento potrebbe avere perso dei dati

il kernel il precomplato slack da installazione o lo hai ricompilato successivamente ?

Loading