PDA

Visualizza la versione completa : WLAN: ad-hoc funziona, con AP no!


don86
10-08-2004, 19:10
Fino a poche ore fa la mia piccola WLAN ad-hoc era perfettamente funzionante con due schede wireless USB Sitecom.

Caratteristiche dei PC:

PC1
IP 192.168.0.1
Subnet 255.255.255.0
Gruppo di lavoro: MSHOME
Modem ADSL Ethernet
Condivisione connessione Internet attiva

PC2
IP 192.168.0.2
Subnet 255.255.255.0
Gruppo di lavoro: MSHOME
Gateway 192.168.0.1

Su entrambi i PC la connessione ad Internet e la condivisione di file e risorse era OK.

Dopo aver disinstallato la scheda wireless USB, ho installato da poco sul PC1 un router/access point D-Link DSL-604+ (IP 192.168.0.254, Subnet 255.255.255.0). Di conseguenza, ho cambiato i dati come segue:

PC1
IP 192.168.0.1
Subnet 255.255.255.0
Gateway 192.168.0.254

PC2
IP 192.168.0.2
Subnet 255.255.255.0
Gateway 192.168.0.254

Tuttavia, pur avendo settato correttamente la rete wireless, ora i due PC non si vedono (nemmeno il ping), PC2 non pinga nemmeno il router/AP, sebbene si colleghi correttamente all'AP (mostrandomi nella utility di configurazione la potenza del segnale e la qualità).

Premetto che i firewall per tutte le prove sono stati tutti disattivati (sia ZoneAlarm che il firewall di XP).

ipconfig /all da PC1:

C:\Documents and Settings\Don>ipconfig /all

Configurazione IP di Windows

Nome host . . . . . . . . . . . . . . : donpc
Suffisso DNS primario . . . . . . . :
Tipo nodo . . . . . . . . . : Sconosciuto
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No

Scheda Ethernet Connessione alla rete locale (LAN):

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : Scheda Fast Ethernet PCI SiS basata su 900
Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 192.168.0.1
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . : 192.168.0.254
Server DNS . . . . . . . . . . . . . : 212.216.112.112
212.216.172.62


ipconfig /all da PC2

Configurazione IP di Windows 98

Nome host . . . . . . . . . : DATI
Server DNS. . . . . . . . . :
Tipo nodo . . . . . . . . . : Trasmissione
Scope ID NetBIOS. . . . . . :
IP Routing abilitato. . . . : No
WINS Proxy abilitato. . . . : No
Risoluzione NetBIOS con DNS : No

0 - Scheda Ethernet <-- è una scheda inutilizzata, disattivata in gestione periferiche

Descrizione . . . . . . . . : PPP Adapter.
Indirizzo fisico. . . . . . : 44-45-53-54-00-00
DHCP abilitato. . . . . . . : Sì
Indirizzo IP. . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . : 0.0.0.0
Gateway predefinito . . . . :
Server DHCP . . . . . . . . : 255.255.255.255
Server WINS primario. . . . :
Server WINS secondario. . . :
Assegnazione indirizzo. . . :

1 - Scheda Ethernet <-- scheda wireless USB

Descrizione . . . . . . . . : MiniUSB Wireless Adapter
Indirizzo fisico. . . . . . : 00-60-B3-6B-8D-6D
DHCP abilitato. . . . . . . : No
Indirizzo IP. . . . . . . . : 192.168.0.2
Subnet Mask . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . : 192.168.0.254
Server WINS primario. . . . :
Server WINS secondario. . . :
Assegnazione indirizzo. . . :
Scadenza indirizzo. . . . . :


:bhò:

don86
10-08-2004, 19:42
Mmhh.. pare ci siano dei problemi con il WEP...
Appena lo disabilito funziona tutto a meraviglia :confused:

don86
10-08-2004, 20:41
Ok, problema risolto :fagiano:

Loading