PDA

Visualizza la versione completa : [MDK9.2] Interfaccia grafica con ATI Radeon 7000 64M


Ephestus
14-08-2004, 21:15
Ho sostituito da poco il pc che aveva la scheda video Matrox 400 ed ora possiedo una ATI Radeon 7000 64MB SDR Tv. Ho installato la mandrake 9.2 nello stesso modo del vecchio pc, ma stavolta all'accensione non ho più l'interfaccia grafica KDE, ma mi parte il modalità testo.
Ho cercato con google e lycos, ma non ho trovato nulla che facesse al caso mio.
Essendo anche abbastanza nuovo nel settore Linux, non so se sia colpa mia o è la 9.2 che ha dei problemi.

Durante l'installazione, infatti, devo andare a configurare a mano la scheda video (non la riconosce automaticamente). Scelgo Ati Radeon generico e, sia con l'accelerazione hardware 3D, sia escludendola, quando faccio "Prova" crea un errore. Ho provato a cambiare tutte le impostazioni ma continua a dare lo stesso errore.

Dopo averlo configurato alla "menopeggio" :oVVoVe: riavvio e verso la fine del caricamento lo schermo si spegne e riaccende per 3 volte ed infine parte la modalità testo.

Come posso ovviare a ciò?


Grazie mille in anticipo

andy caps
14-08-2004, 21:42
fai il login da root
poi digita

mcc
con mcc scegli poi configurazione video

prova se con i radeon non i vesa
li trovi un fondo alla lista dei driver cliccando nella cartella xfree 4.3
prova a scegliere anche un monitor con frequenze non esagerate

prima dai startx e guarda quale è l'errore (lo dice)
guarda dove mette EE

Ephestus
14-08-2004, 22:20
Le impostazioni originarie che io avevo messo erano:

1024x768 a 60 Hz
ATI radeon xfree 4.3 con accelerazione 3D

In più ora è apparsa una nuova opzione: resolution -> frame-buffer

ho sostituito frame-buffer con 1024x768 24b ed ora funziona.

Resta comunque un altro problema:
io possiedo 2 hd uno IDE in cui è installato linux e l'altro SATA con su win XP.

per cambiare s.o. sono obbligato a staccare l'dg sulla IDE per poter usare winzoz e riattacarlo per entrare in linux.

che stinghe potrei mettere nel lilo.conf per far sì che al boot mi veda anche l'altro hd?


grazie infinite

andy caps
14-08-2004, 22:31
la mandrake 9.2 non aveva ancora il supporto per sata
è stato sviluppato successivamente ed ancora non a pieno

io proverei con un bootloader per windows tipo
xosl o gag

installati nella partizione di windows permettono poi di fare il boot della mandrake
altrimenti devi scaricare al mandrake 10 o la 10.1 che non dovrebbe avere problemi con sata

puoi provare anche a correggere lilo ma se non vede i dischi è un pasticcio

controlla con fdisk -l se ti elenca tutti e due i dischi

Ephestus
14-08-2004, 23:11
Ok...adesso cerco informazioni su xols e gag, poi tendo...

nel frattempo ti chiedo un altro consiglio:
l'hd in cui ho reinstallato linux proviene dal mio vecchio computer in cui funzionava perfettamente ed aveva un ottimo rapporto con win 98. Stupidamente ho staccato dal vecchio pc l'hd e riconfigurato da 0 su quest'altro.
Sono andato a riaccendere win 98 ma al boot il sistema ha ancora caricato il vecchio lilo e quindi cerca il 2° hd e si impalla. Ho provato a riattaccarlo, ma avendolo riconfigurato non parte ugualmente.

Ho prendeso il vecchio dischetto di boot per modificarlo (eliminado tutte le stringe apparteneti a linux e lasciando solo la parte riguradante winzoz, ma adesso sia con linux che con XP il dischetto risulta vuoto. :bhò: eppure l'ho usato varie volte...

Ho anche provato a rifarlo da capo, ma il comando lilo -b /mnt/fd0 non funziona. Resituisce questo:

root]lilo -b /mnt/fd0
Ignoring entry 'boot'
Fatal: raid-setup:stat ("/mnt/fd0")
[Anche questo è un mistero...]

Non so più che pesci pigliare. Esiste io modo di cambiare il boot passando dal bios o cose varie? Non posso neanche entrare in DOS.... :cry:


edito: Purtroppo non ho il CD di win XP per questo ho fatto questa domanda...cerco comunque di procurarmelo!

andy caps
15-08-2004, 00:01
:confused: non ci ho capito molto

elimina lilo da da problemi a windows

:madai!?:
avvia con il cd di mandrake e scivi rescue al boot:

ti dovrebbe proporre una mascheina da cui puoi scegliere se reinstallare lilo o rigenerare l'mbr rigenerandolo ti rimette quello di win
al limite parti con il cd di win98 e scegli avvia con supporto cdrom o quello di xp scegliendo consolle di ripristino
ti dovrebbe dare il prompt e basta digitare
fdisk /mbr per togliere lilo
con quello di xp fixmbr per ripulirlo

Ephestus
15-08-2004, 14:07
si effettivamente mi sono spiegato maluccio, comunque ho risolto aggiornando win98 che, da padrone com'è, ammazza tutto ciò che non conosce.

Per il fatto di xosl ho appena finito di fare la deframmentazione, adesso partizione come richiesto e poi vediamo...


grazie! :ciauz:

andy caps
15-08-2004, 14:14
xosl basta scompattarlo in C:/ poi avviando da floppy di dos si avvia l'exe nella sua cartella

non mi sembra che necessitasse di partizioni

Ephestus
15-08-2004, 19:43
La guida che ho trovato qua (http://www.ascrocco.it/home/gratis/manuali/tutorial/xosl.htm) afferma che bisogna possedere una partizione primaria di circa 16MB in cui far risiedere il programma...

Se, come dici tu non è necessario, allora provo subitissimo visto che partition magic non funziona [vedi thread (http://forum.html.it/forum/showthread.php?s=&threadid=699403) ]

andy caps
15-08-2004, 19:59
http://www2.arnes.si/~fkomar/xosl.org/
si raccomandano ma non c'è bisogno
io l'ho usato in passato e andava benissimo cosi

va fatto il setup ed aggiunte le varie partizioni

probabilmente dovresti prima mettere lilo di mandrake nella sua partizione di boot ma puo darsi che indicandogli semplicemente il disco la carichi dall'altro mbr

l'unico problema è che se prima la mandrake era sul primario ed adesso è sul secondario non vorra' partire
prova comunque

Loading