PDA

Visualizza la versione completa : kde 3.3 su mandrake..come lo installo?co


osvi
27-08-2004, 18:31
come da titolo :)

DarkdeAvalon
27-08-2004, 19:29
Premetto che non uso mandrake ma la procedura dovrebbe essere la seguente:

Dal sito di Kde ( www.kde.org ) scarichi tutti i pacchetti per la tua distribuzione e li infili dello alla cartella /kde sul tuo pc
da console entri nella cartella e dai il comando per l'installazione per i pacchetti ( nel caso di slackware installpkg * )
una volta installati tutti i pacchetti se hai il runlevel settato a 3 ( /etc/inittab ) lo porti a 4 per l'avvio grafico e fai partire kde

personalmente farei cosi, aspetta magari conferma da qualcuno perche, come detto, mandrake non l'ho mai usata

osvi
27-08-2004, 19:35
installpkg nn c' :cry:

DarkdeAvalon
27-08-2004, 19:36
Si, lo so, mandrake usa un altro gestore di pacchetti . l'installpkg di slackware ho postato il nome solo per dare un idea di cosa parlavo :)

ti consiglio di aspettare un utente mandrakiano cosi ti dice se giusto quanto ho scritto :)

Gondor
27-08-2004, 20:08
Mandrake usa urpmi, ma devi usare i reposity aggiornati in questo caso.

Quindi aspetta qualche buona anima pia che te li posti :)

andy caps
27-08-2004, 20:14
:D non ci sono i pacchetti di kde 3.3

mandrake sta terminando la mandrake 10.1 in cui inseriranno kde 3.2.3 perche non hanno il tempo per sistemarci il 3.3
i pacchetti del 3.3 cominceranno a metterli tra una decina di giorni dopo che saranno uscite le iso della 10.1

:fighet: io l'ho messo kde 3.3 su mandrake compilandolo con konstruct che scarica i sorgenti e li compila da se
naturalmente va benissimo anche se perde la formattazione di mandrake menu compresi io lo sto usando anche adesso se ti vuoi avventurare ti metto il link

osvi
27-08-2004, 20:56
si l'ho visto :D

solo che mi vuole gettext..ok scaricato
vado a compilarlo dice che devo compilare prima automake-lib-link

cd automake-lib-link, ./configure

configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
[root@Hysteria autoconf-lib-link]#

:jam:

why? ps una cooker :D
adesso sono bloccato a met konstruct, se nn installo gettext.. :cry:

andy caps
27-08-2004, 21:04
:D si devi installare un sacco di cosette con urpmi

gcc-cpp gcc3.3-cpp libcppsocket0-devel cpptasks imlib libimlib2_1-devel perl-Image-Imlib2 automake1.8 automake1.7 automake1.9 gcc-c++ gcc3.3-c++ gettext

comincia con questi poi via via vanno cercati

osvi
27-08-2004, 21:22
yayyyyyy :zizi:

sto compilando :D


grazie mio bel senese :sbav: :stordita: :fagiano:

vediamo se funziona

andy caps
27-08-2004, 21:31
dai make && make install nelle varie cartelle

io sono partito dalle kdelibs poi kdebase e gli altri

alla fine ti trovi 2 kde

da kdm ti avvia kde originale se bai ad init 3 e dai startx o togli il login grafico ti avia kde 3.3
compilalo da utente altrimenti ti fa la dir kde3.3 nella home di root e va solo da root

se lo fai da user poi devi mettere un file nella home .xinitrc
e dentro ci devi mettere il percorso al bin che si formera

presumibilmente

exec /home/osvi/kde3.3/bin/startkde

:D io l'ho compilato da root e poi da utente perche partiva solo da root

Loading