PDA

Visualizza la versione completa : problema con apt


jaso
29-08-2004, 10:28
ciao a tutti,

la prima volta che mi capita:

stavo scaricando aggiornamenti con apt-get update e apt-get dist-upgrade quando mi chiede di aggiornare le gcc

i pacchetti in questione sono :
g++3.3
gcc-3.3
libstdc++5-3.3-dev

appena finisce di scaricare mi dice questo strano errore che ormai da giorni che c' :

(Lettura del database ... 62318 file e directory attualmente installati.)
Mi preparo a sostituire gcc-3.3 1:3.3.4-6sarge1 (con .../gcc-3.3_1%3a3.3.4-6sarge1.1_i386.deb) ...
Spacchetto il rimpiazzo di gcc-3.3 ...
dpkg: errore processando /var/cache/apt/archives/gcc-3.3_1%3a3.3.4-6sarge1.1_i386.deb (--unpack):
tentata sovrascrittura di `/usr/share/doc/gcc-3.3-base/changelog.Debian.gz', che si trova anche nel pacchetto gcc-3.3-base
dpkg-deb: il sottoprocesso paste stato terminato dal segnale (Pipe rotta)
Mi preparo a sostituire libstdc++5-3.3-dev 1:3.3.4-6sarge1 (con .../libstdc++5-3.3-dev_1%3a3.3.4-6sarge1.1_i386.deb) ...
Spacchetto il rimpiazzo di libstdc++5-3.3-dev ...
dpkg: errore processando /var/cache/apt/archives/libstdc++5-3.3-dev_1%3a3.3.4-6sarge1.1_i386.deb (--unpack):
tentata sovrascrittura di `/usr/share/doc/libstdc++5/changelog.Debian.gz', che si trova anche nel pacchetto libstdc++5
dpkg-deb: il sottoprocesso paste stato terminato dal segnale (Pipe rotta)
Mi preparo a sostituire g++-3.3 1:3.3.4-6sarge1 (con .../g++-3.3_1%3a3.3.4-6sarge1.1_i386.deb) ...
Spacchetto il rimpiazzo di g++-3.3 ...
dpkg: errore processando /var/cache/apt/archives/g++-3.3_1%3a3.3.4-6sarge1.1_i386.deb (--unpack):
tentata sovrascrittura di `/usr/share/doc/gcc-3.3-base/changelog.Debian.gz', che si trova anche nel pacchetto gcc-3.3-base
dpkg-deb: il sottoprocesso paste stato terminato dal segnale (Pipe rotta)
Sono occorsi degli errori processando:
/var/cache/apt/archives/gcc-3.3_1%3a3.3.4-6sarge1.1_i386.deb
/var/cache/apt/archives/libstdc++5-3.3-dev_1%3a3.3.4-6sarge1.1_i386.deb
/var/cache/apt/archives/g++-3.3_1%3a3.3.4-6sarge1.1_i386.deb

Applicazione delle modiche fallita! Scorrere questa finestra per verificare l'errore


sapete aiutarmi??? grazie in anticipo

andy caps
29-08-2004, 11:17
in questi casi si da
apt-get -f install
e dpkg --configure -a

a volte se proprio non va si debbono forzare

esempio

dpkg -i --force-all /var/cache/apt/archives/gcc-3.3_1%3a3.3.4-6sarge1.1_i386.deb

Loading