PDA

Visualizza la versione completa : Installare MRTG


SkOrPiOn`87
30-08-2004, 20:23
Ciao, ho scarico MRTG ed una volta installato l'ho configurato in questo modo:

./cfgmaker --global 'WorkDir: /var/www/htdocs/mrtg' --global 'Options[_]: bits,growright' --output /usr/mrtg-2/mrtg.cfg arrakis@192.168.0.1
/usr/mrtg-2/bin/mrtg /usr/mrtg-2/mrtg.cfg


MRTG è partito senza nessun errore, però non fa niente, non genera nessuna statistica...

Qualcuno sa aiutarmi? :ciauz:

fivendra
30-08-2004, 20:47
il cfgmaker con tutte le opzioni va fatto prima di farlo partire con
/usr/mrtg-2/bin/mrtg /usr/mrtg-2/mrtg.cfg
comunque le librerie grafiche sono installate correttamente?
:ciauz:

SkOrPiOn`87
30-08-2004, 20:55
Si ho fatto in quel modo, e le librerie le ho tutte...

Nei processi non comprare neanche.

SkOrPiOn`87
31-08-2004, 11:02
nessuno?

fivendra
31-08-2004, 11:25
ma il file mrtg.cfg te lo crea?
cioè se lo apri, vedi il file di configurazione completo, con le interfaccie ethernet o no?
:ciauz:

SkOrPiOn`87
31-08-2004, 11:32
il modem è USB

questo è il config:

EnableIPv6: no
WorkDir: /var/www/htdocs/mrtg
Options[_]: bits,growright
RunAsDaemon: yes


questi i 2 processi che sono risucito a far partire:

root 24209 0.0 1.0 4700 2620 ? S 11:26 0:00 snmpd -c /usr/local/share/snmp/snmpd.conf
root 24219 0.0 3.6 10148 8756 ? Ss 11:30 0:00 /usr/bin/perl -w ./mrtg ../mrtg.cfg --logging=/var/log/mrtg


ma le pagine html non le crea... :ciauz:

SkOrPiOn`87
31-08-2004, 11:37
Sul config però ho questo errore quando lo genera:

root@arrakis:/usr/mrtg-2/bin# ./cfgmaker --global "Workdir: /var/www/htdocs/mrtg" \
> --global "options[_]: bits, growright" \
> --output /etc/mrtg.cfg \
> arrakis@192.168.0.1
--base: Get Device Info on arrakis@192.168.0.1:
SNMP Error:
no response received
SNMPv1_Session (remote host: "192.168.0.1" [192.168.0.1].161)
community: "arrakis"
request ID: -14209107
PDU bufsize: 8000 bytes
timeout: 2s
retries: 5
backoff: 1)
at /usr/mrtg-2/bin/../lib/mrtg2/SNMP_util.pm line 627
SNMPWALK Problem for 1.3.6.1.2.1.1 on arrakis@192.168.0.1::::::v4only
at ./cfgmaker line 827
WARNING: Skipping arrakis@192.168.0.1: as no info could be retrieved

--base: Writing /etc/mrtg.cfg

Dopo faccio:

root@arrakis:/usr/mrtg-2/bin# ./mrtg /etc/mrtg.cfg --logging=/var/log/mrtg
Daemonizing MRTG ...
root@arrakis:/usr/mrtg-2/bin# ps aux | grep mrtg
root 24243 0.7 3.6 10148 8756 ? Ss 11:41 0:00 /usr/bin/perl -w ./mrtg /etc/mrtg.cfg --logging=/var/log/mrtg
root@arrakis:/usr/mrtg-2/bin#

e sembra tutto ammodo

fivendra
31-08-2004, 12:12
ok, è un problema di snmp
snmp e snmp trap sono installati e attivi?
nel file snmpd.conf la community è settata a dovere?
:ciauz:

fivendra
31-08-2004, 12:13
dimenticavo, che distro usi?
:ciauz:

Loading