PDA

Visualizza la versione completa : Problema configurazione router cisco


fox80129
31-08-2004, 18:16
Ho effettuato una procedura di password recovery su un Cisco 827 (salvando
prima la config perfettamente funzionante su file di testo).
Dopo aver terminato il recovery sono andato in config t e ho incollato la
configurazione precedentemente salvata.
Dopo averla inserita ho digitato il comando copy run start per salvarla.
Sia nello sh run che nello sh config viene riportata la nuova configurazione
inserita,ma nessun computer della rete ha più accesso a internet.
Vi posto la configurazione...spero possiate aiutarmi.


Using 1616 out of 131072 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router_CISCO
!
logging rate-limit console 10 except errors
enable secret xxxxx
enable password xxxx!
ip subnet-zero
no ip routing
no ip finger
ip name-server 151.99.125.2
ip name-server 151.99.125.3
ip dhcp excluded-address 10.10.10.100
!
no ip dhcp-client network-discovery
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
!
interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
ip address xx.xxx.xxx.xx 255.255.255.248 secondary
ip address xx.xxx.xxx.xx 255.255.255.248
ip nat outside
no ip route-cache
pvc 8/35
protocol ip xx.xxx.xxx.xx oam-pvc 0
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
ip http server
!
ip nat inside source list 102 interface ATM0.1 overload
ip nat inside source static tcp 10.10.10.100 5900 interface ATM0.1 5900
ip nat inside source static tcp 10.10.10.100 25 interface ATM0.1 25
ip nat inside source static tcp 10.10.10.100 110 interface ATM0.1 110
ip nat inside source static tcp 10.10.10.100 21 interface ATM0.1 21
ip nat inside source static tcp 10.10.10.100 80 interface ATM0.1 80
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 120 0
password xxx
login local
length 0
!
scheduler max-task-time 5000
end

Caleb
31-08-2004, 19:52
ma non manca un no shutdown sulla ethernet0?

fox80129
31-08-2004, 20:16
Ops....domani allora provo a modificare la config in questo modo:

interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
no shutdown
no ip route-cache
no ip mroute-cache


Toglimi una curiosità,a che server il comando no shutdown,e soprattutto è possibile che impedisca il funzionamento di internet?
Grazie :ciauz:

Caleb
31-08-2004, 20:27
serve ad abilitare l'interfaccia ethernet del router

shutdown la tira giù, no shutdown la abilita

se non la abiliti nessun pc potrà mai passare per il router
poi magari il problema non è quello eh

fox80129
31-08-2004, 20:32
Originariamente inviato da Caleb
serve ad abilitare l'interfaccia ethernet del router

shutdown la tira giù, no shutdown la abilita

se non la abiliti nessun pc potrà mai passare per il router
poi magari il problema non è quello eh

Grazie.
Speriamo sia quello il problema....sono 5 giorni che sto sbattendo la testa su questa config.
Una settimana fa sono venuti quelli della telecom a cambiare la linea dati e mi hanno cambiato gli IP statici.Hanno smanettato vicino al router e poi hanno reinserito la password in modo sbagliato.
La config (che salvai accuratamente prima del password recovery)funzionava correttamente,dopo il password recovery non ha funzionato più. :cry:

Caleb
31-08-2004, 20:43
ci sono buone probabilità che sia quello il problema: i vari shutdown/no shutdown non vengono compresi quando dai show conf, quindi la configurazione che visualizzi non è mai identica a quella che hai inserito --> non va bene come backup

fox80129
01-09-2004, 16:54
Ho risolto...era proprio il comando no shutdown...solo che ora la connessione va più lenta di un 56 kb e ho una connessione a 1200 kb.

Caleb
01-09-2004, 18:27
prova ad aggiungere atm vc-per-vp 64 nella sezione interface ATM0... di più non so

Loading