PDA

Visualizza la versione completa : SID] Aggiornamento e poi non risale


innovatel
07-09-2004, 21:21
ciao a tutti. stasera prima di cena ho fatto

apt-get update & apt-get upgrade & apt-get dist-upgrade

spengo per cena e ora lo riaccendo e mi trovo lo schermo nero che più nero non si può.

Ho pensato non sarà + configurato x- scrivo xf e premo il tab e mi appare xf<qualcosa>gamma

io come diamine lo riconfiguro? non ho voglia di reinstallarla. ho detto oggi che non ero ancora riuscito a demolirla ... così però non vale :stordita:

andy caps
07-09-2004, 21:28
dpkg-reconfigure xserver-xfree86

:D sei riuscito a rompere anche la debian ?

andy caps
07-09-2004, 21:28
basta apt-get update e poi apt-get dist-upgrade comunque

innovatel
08-09-2004, 07:20
esatto andy, ho distrutto anche questa :fighet:

ho provato come dici te, ho provato ad usare il file della knoppix ... nulla ... sempre schermo nero. ho montato una slack al volo per salvare i dati della home.

mi sà che aspetterò qualche giorno prima di rimetterla, voglio provare vidalinux se la trovo fuori bit torrent :)

ps -> grazie per la cosa del update
ps2 -> non sò perchè ma immaginavo rispondessi te :p

andy caps
08-09-2004, 07:46
ieri hanno aggiornato tutto xserver
se hai installato i driver reinstallali o scegli un driver vesa provvisoriamente
con il solito

dpkg-reconfigure xserver-xfree86
:D aspeta a demolire tutto

controlla anche che l'aggiornamento sia andato a buon fine dai un apt-get update e apt-get dist-upgrade
con un dpkg --configure -a e apt-get -f install

e prova anche

apt-get --reinstall install x-window-system-core xterm xlibs

innovatel
08-09-2004, 19:40
andy, grazie 1000 ma non và.

devo aver fatto dei danni non sò come ... non và nemmeno apt-get :stordita:

stò riscaricando la iso della netinstall poi via via belli rapidi :)

ciau e a presto by debian :)

oTTony
09-09-2004, 15:30
Riprendo questo post per non aprirne un altro , dopo un apt-get updare && apt-get dist-upgrade ricevo quest'errore :
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libperl5.8: Depends: perl-base (= 5.8.4-2.2) but 5.8.4-2 is installed
perl: Depends: perl-base (= 5.8.4-2.2) but 5.8.4-2 is installed
E: Unmet dependencies. Try using -f.
--------------------------------------------------------------------------------------------------------------
Alchè gli ho dato dpkg --configure -a + un apt-get -f install
ma mi ritorna quest'errore sulle librerie di perl :

Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
perl-base
The following packages will be upgraded:
perl-base
1 upgraded, 0 newly installed, 0 to remove and 60 not upgraded.
4 not fully installed or removed.
Need to get 0B/747kB of archives.
After unpacking 172kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 48301 files and directories currently installed.)
Preparing to replace perl-base 5.8.4-2 (using .../perl-base_5.8.4-2.2_i386.deb) ...
Unpacking replacement perl-base ...
dpkg: error processing /var/cache/apt/archives/perl-base_5.8.4-2.2_i386.deb (--unpack):
trying to overwrite `/usr/lib/perl/5.8', which is also in package libclass-multimethods-perl
Errors were encountered while processing:
/var/cache/apt/archives/perl-base_5.8.4-2.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
-----------------------------------------------------------------------------------------------------------------------
Non capisco bene quale sia il problema di ste librerie ........ :master:
Qualcuno ha qualche idea ??? :confused: Grassie!

Maxer
09-09-2004, 15:57
# dpkg --force-overwrite -i /var/cache/apt/archives/perl-base_5.8.4-2.2_i386.deb

così scavalchi l'errore...
era già apparso in lista, ed era anche stato spiegato il motivo...però ora non ricordo :fagiano:
ciau
:ciauz:

oTTony
09-09-2004, 16:18
Sembra OK Grassie Mille !!! :yuppi:

innovatel
10-09-2004, 18:45
andy caro ... ho messo una sarge pulita e andava. ho dato lo stesso comando e sono al punto di partenza. che devo fare? andare a farmi benedire?

ho pensato ... mi tengo la sarge senza problemi. Bene, fregatura che tra 5 gg l'attuale sid diventerà sarge e quindi sarò al punto di partenza :(

Loading