PDA

Visualizza la versione completa : installare modulo via-rhine su debian


Sayron
08-09-2004, 22:14
Ciao a tutti,
Dovrei installare il modulo via-rhine per far funzionare la scheda di rete su debian. Ho controllato nella directory /lib/modules/2.2.20-idepci/net e non e' presente. Partendo dal sorgente (via-rhine.c) quali sono i passi che devo seguire per poter dare modprobe via-rhine ?(ora non va a buon fine ovviamente)

Grazie in aticipo

andy caps
08-09-2004, 22:24
se digitavi al boot bf24 ti metteva il kernel 2.4.18 che ha anche via-rhine
non credo avesse via-rhine il 2.2
lo puoi scaricare da via e metterlo manualmente o compila un kernel piu recente

andy caps
08-09-2004, 22:31
http://www.scyld.com/modules.html


guarda qui comunque

Sayron
09-09-2004, 14:39
se volessi aggiornare il kernel come posso fare ? ho visto che ricompilandolo devo imbattermi nella scelta di tutti i componenti e moduli da includere ma ho paura di fare qualche danno omettendone qualcuno...

mi sai dare qualche dritta a riguardo?

andy caps
09-09-2004, 14:56
io reinstallerei

ci metti la cosa piu rapida
aggiornare il kernel richiede un minimo di esperienza
se reinstalli ed digiti al boot:bf24

in dieci minuti hai debian installata con il kernel 2.4.18 e da modconf puoi caricare il modulo via-rhine tranquillamente
se metti anche ppp_deflate ed hai un modem ethernet in 1 minuto sei connesso

altrimenti puoi provare ad installare un kernel immagine

quello si installa semplicemente la guida questa
-----------

il kernel 2.4.19 era nei cd di woody allegati ad una rivista un annetto va ma puoi scaricarne anche uno piu recente dal sito di debian > package
-----------
Kernel 2.4.19

Per installare l'ultima versione precompilata del kernel 2.4.19 seguite la seguente procedura:

aprite col vostro editor preferito il file /etc/lilo.conf, cercate la sezione con label=Linux e aggiungete in coda ad essa la riga: initrd=/initrd.img
lanciate:
# apt-get install kernel-image-2.4.19-386
Potete sostituire alla dicitura 386 finale la sigla del vostro processore, ad es. 686, 686-smp, k6, k7...
Rispondete nel modo seguente alle domande che vi verranno poste:

Do you want to stop now? n
Do you want me to create a link from /boot/initrd.img-2.4.19-k6 to initrd.img? Y
Install a boot block using the existing /etc/lilo.conf? Yes

Eseguite un reboot.


se reinstalli comunque meglio

Loading