PDA

Visualizza la versione completa : immagini che si corrompono in upload


..::h0p::..
09-09-2004, 16:53
ho un modulo in php che fa l'upload su un server RedHat Linux 8.0.
Le immagini uploaddate in questo modo arrivano corrotte, non si riescono a visualizzare. Se la stessa immagine viene uploaddata via FTP o con WinSCP, l'immagine arriva integra.

Qualcuno sa dove può essere il problema?
PHP o settaggi di sistema del Linux?

PunkIvi
09-09-2004, 17:38
Io credo che sia un problema del form php. Come è fatto?

wittgen105
09-09-2004, 20:41
Originariamente inviato da ..::h0p::..
ho un modulo in php che fa l'upload su un server RedHat Linux 8.0.
Le immagini uploaddate in questo modo arrivano corrotte, non si riescono a visualizzare. Se la stessa immagine viene uploaddata via FTP o con WinSCP, l'immagine arriva integra.

Qualcuno sa dove può essere il problema?
PHP o settaggi di sistema del Linux?

Io credo che sia un problema relativo al protocollo http e quindi al server apache, hai provato a reinstallarlo???

..::h0p::..
10-09-2004, 10:12
no. non ho provato. primo perchè non l'ho mai fatto. secondo perchè è un server di produzione

l.golinelli
10-09-2004, 12:10
Non è che devi settare la modalità BIN tipo come in FTP?

wittgen105
10-09-2004, 14:30
Originariamente inviato da l.golinelli
Non è che devi settare la modalità BIN tipo come in FTP?

Luca, non capisco? :confused:

l.golinelli
10-09-2004, 15:04
In FTP se usi la modalità ASCII per trasferire files binari questi si corrompono... Bisogna usare la modalità BINARY...
Tutto qui... Magari è una cosa del genere... :dottò:

wittgen105
11-09-2004, 15:25
Originariamente inviato da l.golinelli
In FTP se usi la modalità ASCII per trasferire files binari questi si corrompono... Bisogna usare la modalità BINARY...
Tutto qui... Magari è una cosa del genere... :dottò:

Se lo metti in auto???

Loading