PDA

Visualizza la versione completa : Configurare samba per condivisionew senza password


iacchi
15-09-2004, 18:58
Ciao a tutti,
sono un newbie di linux, e mi trovo per la prima volta a battere il capo contro smb.conf...
il problema questo: vorrei condividere due cartelle del computer senza che l'altro utente della rete debba inserire una password per accederci.
Ho impostato tutti i parametri per permettere l'accesso pi libero possibile (only guest = yes; public = yes), ho impostato il parametro "guest ok = yes" e la modalit "share" nella sezione global, ma tuttavia, appena tento di accedere alle risorse condivise, mi chiede immancabilmente la password (che tra le altre cose neanche conosco...).
Che parametri devo impostare??? :dh: :dh: :dh:

ecco il file:



[global]
netbios name = Anna
security = share
printcap name = /etc/printcap
password server = None
encrypt passwords = no
load printers = yes
guest ok = Yes

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = yes

[desktop]
comment = Desktop
path = /home/anna/Desktop
writeable = yes
guest ok = yes
guest only = yes

[documenti]
comment = Documenti
path = /home/anna/Desktop/documenti
writeable = yes
guest ok = yes
guest only = yes


Inoltre: come si fa a riavviare il servizio per rendere operative le modifiche?

iacchi
16-09-2004, 16:33
up :(

oTTony
16-09-2004, 17:43
Non so se funziona ma hai provato con /sbin/smbpasswd -n nomeutente

da quello che penso io non che non ti chiede la password , semplicenmente non la si mette .

-----------------------------------------------------------------------------------------------------------------------------------------
fai un bel man smbpasswd e vedrai che :

-n This option specifies that the username following should have
their password set to null (i.e. a blank password) in the local
smbpasswd file. This is done by writing the string "NO PASSWORD"
as the first part of the first password stored in the smbpasswd
file.

Note that to allow users to logon to a Samba server once the
password has been set to "NO PASSWORD" in the smbpasswd file the
administrator must set the following parameter in the [global]
section of the smb.conf file :

null passwords = yes
-----------------------------------------------------------------------------------------------------------------------------------------
poi mettere null passwords = yes nella sezione [global]

iacchi
16-09-2004, 20:14
un'altra domanda: devo creare un utente anche per il computer windows? no vero?

oTTony
17-09-2004, 10:11
Originariamente inviato da iacchi
un'altra domanda: devo creare un utente anche per il computer windows? no vero?

Non obbligatorio , l'importante che lo UserName+Pass con cui accedi da M$win esista nella macchina linux e sia configurato in smbpasswd .

Domanda :
Funziona il sistema che ti ho consigliato sopra ? Sai non ho mai provato il le pass le uso , non si s mai !!!

:rollo:

iacchi
17-09-2004, 17:07
allora, pu darsi che non abbia capito bene: io in samba ho un utente configurato, che quello della linuxbox e a cui appartengono le cartelle condivise. Ho impostato la password a nulla per quell'utente, ma se vado sull'altro computer mi chiede comunque la password. Forse devo creare in samba anche l'utente "Server" (che il nome di rete del computer windows) e impostare la password a nulla? come si fa?

iacchi
20-09-2004, 18:34
up

Loading