PDA

Visualizza la versione completa : Slackware 9.1 & Alsa


speed_web
20-09-2004, 14:25
Salve a tutti,

in un messaggio ormai un p datato mi era stato detto che quando aggiornavo slackware 9.1 con swaret (1.6.2) il non funzionamento di alsa era dovuto al kernel in quanto serviva almeno il 2.4.26... ebbene volendo testare questa cosa ho installato la slackware 9.1 mettendogli il kernel 2.4.27 sucessivamente ho aggiornato con swaret, ho riavviato e ho lanciato alsaconf e mi dice non supported pnp or pci card found would you like to probe lagacy isa ecc.... anche se gli dico si non trova nulla lo stesso! la skeda audio che ho una sb live (pci) che funzionava correttamente dopo aver installato la slackware con il suo kernel base.
Vorrei capire il motivo del non funzionamento e sapere se dopo l'aggiornamento con swaret oltre ad alsa anche altri sw potrebbero non andare pi ? xk se cos fosse l'aggiornamento mi pare che rappresenti la tipica zappata sui piedi..
Ringrazio in anticipo chi avr la pazienza e la gentilezza di rispondermi.

andy caps
20-09-2004, 15:00
deseleziona semplicemente in rc.modules il modulo della scheda o dai un modprobe
magari lancia un generate-modprobe.conf e poi rilancia alsaconf
va tutto perfettamente anche aggiornando al 2.6 se da qualche problemino con i moduli del nuovo kernel non niente di preoccupante

speed_web
20-09-2004, 16:49
Originariamente inviato da andy caps
deseleziona semplicemente in rc.modules il modulo della scheda o dai un modprobe
magari lancia un generate-modprobe.conf e poi rilancia alsaconf
va tutto perfettamente anche aggiornando al 2.6 se da qualche problemino con i moduli del nuovo kernel non niente di preoccupante

ho dato modprobe e mi dice:
modprobe: Nothing to load ???
Specify at least a module or a wildcard like \*
ho lanciato generate-modprobe.conf e poi alsaconf ma niente dice sempre non supported pnp or pci card ecc... non capisco com' che agli altri vada tranne a me...

speed_web
20-09-2004, 18:37
[cut]
forza ragazzi ditemi qualcosa non so che fare :confused:
non fatevi pregare...

:ciauz:

Cimi
20-09-2004, 18:54
allora i driver di alsa della slackware sono dei "pacchetti" (cerca di imparare il concetto di "pacchetto". in linux esistono questi "pacchetti" che sono per lo pi programmi/librerie ecc che vengono distribuiti dalle varie distribuzioni con le informazioni utili alla loro installazione. da questo "pacchetto". immagina di aprire una scatola (il pacchetto :D) e trovare il programma con una pagina per l'installazione. su linux i programmi si installano, disinstallano, aggiornano con una logica che regna sovrana... niente viene installato "a caso", coscch non ti ritrovi pieno di porcherie sparse per l'hd, e quando clicchi sopra disinstalla si cancella TUTTO il programma) che sono "compilati" (altra parola da imparare, se non la sai dimmelo che spiego) per il kernel 2.4.26.
ci vuol dire che se hai aggiornato il kernel devi anche installare i driver nuovi, compilati per il tuo kernel.
(ti faccio un esempio per capirci... i driver di windows 98 non vanno su windows xp perch windows xp ha un altro kernel)
quindi cerca i driver per il 2.4.27...

alsa-driver-1.0.6a:
http://slackware.at/data/slackware-current/slackware/l/alsa-driver-1.0.6a_2.4.27-i486-1.tgz
alsa-lib-1.0.6a:
http://slackware.at/data/slackware-current/slackware/l/alsa-lib-1.0.6-i486-1.txt
alsa-oss-1.0.6a:
http://slackware.at/data/slackware-current/slackware/l/alsa-oss-1.0.6-i486-1.tgz
alsa-utils-1.0.6a:
http://slackware.at/data/slackware-current/slackware/ap/alsa-utils-1.0.6-i486-1.tgz

andy caps
20-09-2004, 20:07
dai un modprobe emu10k1

e rilancia alsaconf

in /etc/rc.d/rc.modules

devi decommentare le righe che riguardano emu10k1

###togliere il commento
togliere il commento

al riavvio poi te la dovrebbe trovare

speed_web
20-09-2004, 21:33
Originariamente inviato da andy caps
dai un modprobe emu10k1

e rilancia alsaconf

in /etc/rc.d/rc.modules

devi decommentare le righe che riguardano emu10k1

###togliere il commento
togliere il commento

al riavvio poi te la dovrebbe trovare

hmmmmm... ho capito... ora per c' altro nel senso che grazie all'indicazione di Cimi (anche se il secondo link punta a un txt cmq ho capito che serviva) alsa va nel senso che dopo aver fatto upgradepkg pacchetti scaricati indicati da Cimi e poi alsaconf mi ha rilevato la scheda anche alsamixer funziona, nel lanciare alsaconf mi ha scritto all'interndo del file /etc/modules.conf queste righe:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
# --- END: Generated by ALSACONF, do not edit. ---

ora in fase di caricamento mi ritrovo queste scritte:

insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz: insmod /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz failed
insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz: insmod snd-emu10k1 failed
insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz:unresolved symbol unregister_sound_special
insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz:unresolved symbol register_sound_special

andy se avessi letto prima il tuo messaggio naggia :dh:
:dh:
... hai/avete qualche suggerimento provo lo stesso a decommentare le righe in rc.modules ? :confused:

Grazie :ciauz:

Cimi
20-09-2004, 21:45
Originariamente inviato da speed_web
hmmmmm... ho capito... ora per c' altro nel senso che grazie all'indicazione di Cimi (anche se il secondo link punta a un txt cmq ho capito che serviva) alsa va nel senso che dopo aver fatto upgradepkg pacchetti scaricati indicati da Cimi e poi alsaconf mi ha rilevato la scheda anche alsamixer funziona, nel lanciare alsaconf mi ha scritto all'interndo del file /etc/modules.conf queste righe:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
# --- END: Generated by ALSACONF, do not edit. ---

ora in fase di caricamento mi ritrovo queste scritte:

insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz: insmod /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz failed
insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz: insmod snd-emu10k1 failed
insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz:unresolved symbol unregister_sound_special
insomd: /lib/modules/2.4.27/kernel/sound/acore/snd.o.gz:unresolved symbol register_sound_special

andy se avessi letto prima il tuo messaggio naggia :dh:
:dh:
... hai/avete qualche suggerimento provo lo stesso a decommentare le righe in rc.modules ? :confused:

Grazie :ciauz:

ma hai scaricato il tgz o il txt?

speed_web
20-09-2004, 21:52
Originariamente inviato da Cimi
ma hai scaricato il tgz o il txt?

il tgz :) :)

Loading