PDA

Visualizza la versione completa : X server, cd-rom e mouse su Debian


mrc
21-09-2004, 01:09
Prima di buttare tutto ci provo.

Ho la Deb 3.0 su un i200.

Sembra caricare tutto bene ma quando arriva al server X dice che c' un'errore di settaggio, nel log le ultime quattro righe sono:

(II) SIS: Driver for SIS chipset: SIS5597, SIS5598 etc...
(EE) No Device detected
Fatal Error
no screens found

Reistallerei, se funzionasse il lettore CD, qualunque distro metto per il Boot di installazione da CD dice una cosa in caratteri ASCII

Non funziona neanche il Mouse

Qualcuno, paziente, sa aiutarmi?

NB
Come ho fatto sto casino? una storia lunga, se qualcuno la vuol sapere gliela racconto, ma meglio che si siede che lunga.
Che mi ci raccapezzo ancora poco col Linux si capisce...

mrc
21-09-2004, 11:54
Bene in attesa di consigli, brancolando nel buio, ho fatto qualche tentativo:

La scheda video una Matrox Myst/2 (da etichetta sulla scheda).
Previa copia di sicurezza, ho aperto il file "etc/X11/X86Config-4", indicato nel log.
ho sostituito la riga

Section "Device"
Identifier "Generic Video Card"
Driver "SIS"
Option "UseFBDev"

con

Section "Device"
Identifier "Generic Video Card"
Driver "mga"
Option "UseFBDev"

Il risultato nel log successivo si vede, ma non sufficenente, riporto le righe che mi sembrano interessanti:

(--) MGA(0) Chipset mga1064sg found
(II) MGA(0) Matrox HAL module not found - using builtin mode setup inst
(--) MGA (0) Chipset: "mga1064sg"
(==) Using AGP 1x mode
(**) Using framebuffer device
(II)Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Unloading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Unloading /usr/X11R6/lib/modules/libfbdevhw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error
no screens found

Da legenda:
(--) probed
(II) informational
(==) default setting
(EE) Error

Qualcuno sa interpretare meglio di me?

Ringraziamenti anticipati

mrc
21-09-2004, 15:16
h?nfine ho trasformato:

Section "Device"
Identifier "Generic Video Card"
Driver "mga"
Option "UseFBDev"

in

Section "Device"
Identifier "Generic Video Card"
Driver "mga"

Cancellando l'ultima riga,
ed ora funziona benissimo, server X, mouse, e cd rom :fighet:

Ci risentiamo pi in l per eth e soundcard.
Ringrazio tutti:sonno:, se non altro, per l'incoraggiamento
:ciauz:

Perch poi non far i boot da CD :master:

andy caps
21-09-2004, 21:35
per i caratteri ascii proprio non so
probabilmente il lettore un po andato

al limite tutte le distro' danno la possibilita di installare da floppy e da li caricare il cdrom

:D complimenti per il primo successo autonomo comunque

Loading