PDA

Visualizza la versione completa : debian resolv.conf


alkat
24-09-2004, 17:35
ciao,
ho un problema insopportabile con i dns su debian.

per navigare devo impostare manualmente ogni volta i dns nei file /etc/resolv.conf e /etc/ppp/resolv.conf.

tempo fa avevo risolto con chattr +i che rendeva immutabili i due file e quindi niente e nessuno poteva modificarli.

ora però con la nuova installazione chattr non funziona perché ho scelto (povero cretino) di usare reiserfs.

come faccio a rendere permanenti le modifiche ai due file in questione?

grazie,
.a.

adarkar
24-09-2004, 17:50
e chi è che li modifica? :oVVoVe:

cmq non si usa reiser.. nono :nonono: su questo ti dò ragione.. proprio un cretino :fighet: :ciauz:

alkat
24-09-2004, 17:52
Originariamente inviato da adarkar
e chi è che li modifica? :oVVoVe:

credo un folletto che vive nel laptop... :madai!?:

avete qualche insetticida specifico da consigliarmi?

cambiano da soli.

.a.

adarkar
24-09-2004, 18:01
:zizi: :zizi:
ora ti passo l'insetticida :zizi:

però parlando seriamente qualcuno dovrà pur cambiarli, non cambiano certo da soli, questo sì che sarebbe una magia :zizi:

alkat
24-09-2004, 18:14
Originariamente inviato da adarkar
:zizi: :zizi:
ora ti passo l'insetticida :zizi:

però parlando seriamente qualcuno dovrà pur cambiarli, non cambiano certo da soli, questo sì che sarebbe una magia :zizi:

nessun essere vivente può cambiarli... sono l'unico qui ad usare linux e la mia schizofrenia non ha ancora raggiunto questi livelli! :D

non riesco a capire quale processo li cambi e non so da dove iniziare per investigare.

ecco come ho impostato la connessione:

#ifconfig eth0 up

#pppoeconf

a questo punto cerca il concentratore d'accesso, lo trova e va a modificare /etc/ppp/peers/dsl-provider.

poi mi fa questa domanda:
Most people using popular dialup providers prefer the options 'noauth' and 'defaultroute' in their configuration and remove the 'nodetach' option. Should I check your configuration file and change these settings where neccessary?

rispondo yes

inserisco il nome utente e la password, poi mi chiede se voglio che il provider mi invii automaticamente gli indirizzi di server e li inserisca nel file /etc/resolv.conf, dico di no perché li voglio mettere io.

infine scelgo di avviare la connessione al boot.


ad ogni riavvio però i dns cambiano e la connessione va lentissima.

uso debian sarge installata con un netinstaller del 20 settembre mi pare, kernel 2.6.8-1

.a.

adarkar
24-09-2004, 18:16
comunque mi spiace ma io non so dirti :bhò: non uso neanche ppp per cui sono proprio a zero, da me il resolv.conf è così da quando l'ho scritto durante l'installazione :bhò:

alkat
24-09-2004, 20:55
Originariamente inviato da adarkar
comunque mi spiace ma io non so dirti :bhò: non uso neanche ppp per cui sono proprio a zero, da me il resolv.conf è così da quando l'ho scritto durante l'installazione :bhò:

aspetto un esorcista allora!


...


andy? :)

.a.

andy caps
24-09-2004, 20:59
:( niente lo fa anche a me
a volte va perfettamente a volte tocca rifare la trafila

è la telecom che da questi dns
quando ti connetti contratta la connessione e affibbia questi dns che a volte vanno e a volte no

:confused: speriamo che trovino una soluzione

io mi sono fatto il resolv.conf nella home e quando fa cosi sovrascrivo gli esistenti

alkat
24-09-2004, 21:15
Originariamente inviato da andy caps
:( niente lo fa anche a me
a volte va perfettamente a volte tocca rifare la trafila

è la telecom che da questi dns
quando ti connetti contratta la connessione e affibbia questi dns che a volte vanno e a volte no

:confused: speriamo che trovino una soluzione

io mi sono fatto il resolv.conf nella home e quando fa cosi sovrascrivo gli esistenti

quello che faccio anch'io, che palle però!!!

ma mamma telecom ne fa una giusta ogni tanto? :incupito:

cmq quando avevo installato su ext3, con il comando chattr +i riuscivo a sistemare il problema: rimanevano sempre i dns che decidevo io. ora con reiserfs non posso: usi anche tu reiserfs?

però è proprio strano che non si possa fare nulla...

sulla mailing list di debian mi hanno consigliato di cancellare /etc/ppp/ip-up.d/0000usepeerdns o di installare resolvconf ma in realtà non risolvo niente così... e in qualche risposta dopo mi dicono che resolvconf è il responsabile di questi cambiamenti... :confused:

suppongo che tu le abbia già provate tutte, vero?

mi sa che ributto tutto su una debian con ext3... la terza installazione di debian in meno di 10 giorni... :(

.a.

andy caps
24-09-2004, 21:49
a me lo fa a volte adesso per esempio va benissimo
ed ha nel resolv.conf

nameserver 80.19.134.152
nameserver 151.99.125.1

:confused:

prova a mettere questi

Loading